engine light - Genesis Forum: GenCoupe Hyundai Genesis Forums
 
LinkBack Thread Tools
#1 Old 08-29-2011, 06:55 PM
Senior Member
 
PR_Gen787's Avatar
 
Join Date: Aug 2011
Location: Texas
Posts: 726
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
engine light

So I just bought my 2011 gen coupe 2.0t with like 2000 miles on it and my engine light just turned on. I have no clue what it can be.
PR_Gen787 is offline  
Sponsored Links
Advertisement
 
#2 Old 08-29-2011, 07:04 PM
Senior Member
 
trustinger's Avatar
 
Join Date: Jan 2010
Location: Anchorage, Alaska
Posts: 815
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Neither would we....you need to get the code read.

Useless thread is useless.
trustinger is offline  
#3 Old 08-29-2011, 08:02 PM
Nord Grey 2.0T
 
Szucs's Avatar
 
Join Date: Mar 2010
Location: Toronto, Canada
Posts: 138
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Quote:
Originally Posted by trustinger View Post
Neither would we....you need to get the code read.

Useless thread is useless.
Epic answer !
This should be good :P ha ha ha ha ha

Nordschleife Gray 2.0T Premium Package
Custom Intake
Forge BOV
SFR ReFlash

Anyone In Ontario Who Needs Anything Talk To "cdnsigop" Awesome Service & Best Prices !!
Szucs is offline  
#4 Old 08-30-2011, 04:18 PM
Member
 
MikeS54's Avatar
 
Join Date: Jul 2011
Location: MD
Posts: 32
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

yeah my check engine light came on when i hit 1200 miles on it and it was P0139, O2 sensor. I had to leave my car at the dealer for 3 days so they could get a new O2 sensor from California.
MikeS54 is offline  
#5 Old 09-05-2011, 04:21 PM
Junior Member
 
Join Date: Apr 2011
Location: Waterloo, Ontario
Posts: 25
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

hmmm that is interesting... i just hooked my car up to OCD and i had the same P0139 error with the 02 sensor...
kommanderkev is offline  
#6 Old 09-05-2011, 04:31 PM
Member
 
MikeS54's Avatar
 
Join Date: Jul 2011
Location: MD
Posts: 32
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

that sucks man, mine ran OK with the error on, but i took it to the dealer and they kept the car for 3 days to order a replacment sensor. I just wonder why it went bad with so few miles on it. How many you got on yours?
MikeS54 is offline  
#7 Old 09-05-2011, 04:33 PM
Junior Member
 
Join Date: Apr 2011
Location: Waterloo, Ontario
Posts: 25
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

engine light didnt turn on but my uncle had an OCD shipped today so I tried it out on my car too and saw that problem

so it could've been anywhere from 0 - 10k.

i have to go for an oil change soon so I hope to get it checked at the same time.
kommanderkev is offline  
#8 Old 09-05-2011, 04:42 PM
Senior Member
 
AKGC's Avatar
 
Join Date: Jul 2009
Posts: 12,462
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 11 Post(s)

just erase the code. its a 2nd 02 sensor code. either the its a sensor heat circuit isn't working or the sensor isn't seeing what it likes.

if you have a catless primary, its normal.

if it really urks you, take it to the dealer. they'll most likely replace the o2 sensor
AKGC is offline  
#9 Old 09-05-2011, 04:43 PM
Junior Member
 
Join Date: Apr 2011
Location: Waterloo, Ontario
Posts: 25
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

oh that is interesting. thanks a lot. takes a bit off my mind
kommanderkev is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Genesis Forum: GenCoupe Hyundai Genesis Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
check engine light Medsport 2.0T Discussion 2008-2012 18 12-18-2012 04:59 AM
Service Engine Light??? Chrisqo Engine 6 08-09-2011 12:48 PM
Service Engine Light??? Chrisqo 2.0T Discussion 2008-2012 7 08-07-2011 04:08 PM
Check Engine light on new 2.0T GC1118 Engine 5 04-21-2011 08:57 AM
Engine light allentru 2.0T Discussion 2008-2012 12 03-29-2010 03:33 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome