Problems with Revs going up between shifts. Throttle position sensor? - Hyundai Genesis Forum
 
LinkBack Thread Tools
post #1 of 7 Old 05-07-2015, 12:11 PM Thread Starter
Member
 
Join Date: Aug 2013
Location: Perrysburg, OH
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
(Thread Starter)
Problems with Revs going up between shifts. Throttle position sensor?

If i am accelerating nd I go to shift it goes like this:

1) take foot off gas
2) push in clutch
3) rpms go up relative to the throttle position before taking my foot off
4) after they go up some they will go back down after about 2 seconds

At the same time this started my cruise control also stopped working.

I was thinking it was a throttle position sensor. I stopped by a NAPA and an Autozone, and neither of them could get one. Where can I buy one?
Ecreps is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 05-07-2015, 04:56 PM
Senior Member
 
TenZen's Avatar
 
Join Date: Feb 2015
Location: Kentucky
Posts: 507
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 177 Post(s)
Garage

Throttle by wire throttle bodies don't have a TPS.

2013 3.8 Track 8 Speed A/T
K&N Replacement Filter
BFGoodrich g-Force COMP-2 A/S (OE size)
TenZen is offline  
post #3 of 7 Old 05-07-2015, 06:36 PM Thread Starter
Member
 
Join Date: Aug 2013
Location: Perrysburg, OH
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
(Thread Starter)

Quote:
Originally Posted by TenZen View Post
Throttle by wire throttle bodies don't have a TPS.
So I would need to buy the entire throttle body?

Does anyone have any input on what they think this issue may be caused by?

The three main things I can think of are:

Throttle Body
Pedal assembly
ECU
Ecreps is offline  
post #4 of 7 Old 05-07-2015, 07:02 PM
Senior Member
 
TenZen's Avatar
 
Join Date: Feb 2015
Location: Kentucky
Posts: 507
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 177 Post(s)
Garage

Quote:
Originally Posted by Ecreps View Post
So I would need to buy the entire throttle body?

Does anyone have any input on what they think this issue may be caused by?

The three main things I can think of are:

Throttle Body
Pedal assembly
ECU
No idea what could cause it. You could disconnect the battery for a bit and see if it does it again. I would dig for info to see any ways of testing the throttle body and pedal assembly, I'm not familiar with this system.

2013 3.8 Track 8 Speed A/T
K&N Replacement Filter
BFGoodrich g-Force COMP-2 A/S (OE size)
TenZen is offline  
post #5 of 7 Old 05-07-2015, 11:53 PM
Senior Member
 
MiloBear's Avatar
 
Join Date: Jan 2014
Location: Everett, Washington
Posts: 307
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 47 Post(s)
Garage

I have similar issue have had it since bought car.

Rev hanging I've noticed it's worse when cold so assume it's something to do with ECU and protecting engine.
MiloBear is offline  
post #6 of 7 Old 05-08-2015, 09:12 PM
Senior Member
 
Join Date: Feb 2012
Location: San Diego
Posts: 633
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 237 Post(s)

not very wise to throw parts at a car before a diagnosis is made.

It sounds like rpm hang. Mine does this as well until its warmed up fully, ecu also limits boost until it reaches operating temp. Downside of DBW (drive by wire) is how much control the ecu has over throttle inputs.

Mine hands even once warm randomly. Makes having an aftermarket bov to scare ricers away mostly useless unless aggressive WOT shifts because it wont fully lift throttle when I do to decel the engine and vent any built up pressure, it just hangs for a second or two.

2013 Empire State Gray 2.0t Base 6MT
- HKS SSQV
- K&N Drop-In
- Exceladyne CBE
thomas91169 is offline  
post #7 of 7 Old 05-09-2015, 04:31 PM
99.9% Lurker...
 
ScarlettGen's Avatar
 
Join Date: Oct 2014
Location: Waco, TX
Posts: 78
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 33 Post(s)
Garage

Check the switch at the top of the clutch pedal. If may have gotten stuck in the "pressed/closed" position.

2014 2.0T R-Spec

Mods:
K&N SRI
Synapse BOV
Treadstone IC piping
Snow Performance Stage 2 W/M Kit
TurboXS Racepipe
Exceladyne Cat Back
MAMBA GTX3076r
SPA T3 Manifold
Precision 39mm Wastegate
394whp 320wtq SAE (No meth) @23psi
ScarlettGen is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Hyundai Genesis Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
hm throttle position sensor? throttle cable? throttle body stuck? hajimah 2.0T Discussion 2008-2012 9 02-22-2015 03:16 PM
Throttle position sensor output voltage lead? YellowGC 3.8 V6 Discussion 2008-2012 20 07-14-2010 01:31 AM
boost vs throttle position KEgcYYC 2.0T Discussion 2008-2012 4 05-04-2010 05:34 PM
Throttle Position vs HP Floorit 2.0T Discussion 2008-2012 7 01-05-2010 09:37 AM
electronic throttle and gear position sensor; are we getting ****ed? mr_desmo Engine 46 03-10-2009 03:20 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome