Oil Control Valve (OCV) Failing - Genesis Forum: GenCoupe Hyundai Genesis Forums
Reply
 
LinkBack Thread Tools
#1 Old 08-28-2011, 08:05 PM
Junior Member
 
Join Date: Aug 2011
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Arrow Oil Control Valve (OCV) Failing

Hey guys,

I have a 2010 3.8 Grand Touring Genesis Coupe w/ 30k miles.
A few weeks ago, the check engine light came on so I brought it the dealership. The told me the oil control valve failed. The good news is that it was fully covered by the warranty. They put me in a rental car (for free) and I was back in my car in a couple of days.

I wish that was the end of the story Last week, the check engine light came on again! I went to the dealership and they said the OCV failed again.

The mechanic said he's going to replace it for the 2nd time and that I should get an oil change. Has anyone else ran into this issue? Any advice?

Thanks!

P.S. The only resource I could find was here:
pages.suddenlink.net/daydreamer/Coupe%20TSBs/Engine%20Mechanical%20System/09-EM-002%20CVVT%20OIL%20CONTROL%20VALVE%20INSPECTION.pd f
Gugel is offline  
Sponsored Links
Advertisement
 
#2 Old 08-28-2011, 08:23 PM
I'd rather do it myself
 
Red Raspberry's Avatar
 
Join Date: Aug 2009
Location: Flat lands of Illinois
Posts: 12,430
Mentioned: 0 Post(s)
Tagged: 1 Thread(s)
Quoted: 3 Post(s)
Garage

Is it failing electrically or mechanically?

2010 Red 2.0L track

Quote:
(R=D)<TPTB
Red Raspberry is online now  
#3 Old 08-28-2011, 08:27 PM
Senior Member
 
Ibnzmonkey's Avatar
 
Join Date: Aug 2011
Location: Austin Tx
Posts: 2,092
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)

Welcome to gencoupe?

California Special 5.0 - Mech E.

"Extraordinary claims require extraordinary proof!" -Bill Nye
Ibnzmonkey is offline  
#4 Old 08-28-2011, 09:40 PM
Junior Member
 
Join Date: Aug 2011
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)

Quote:
Originally Posted by Red Raspberry View Post
Is it failing electrically or mechanically?
Not sure. I'll call the dealership tomorrow and ask.
Gugel is offline  
#5 Old 08-30-2011, 06:41 PM
Junior Member
 
Join Date: Aug 2011
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)

The mechanic didn't find any metal shavings in the OCV so the problem must have been electrical. It was giving a P0014 timing over-advanced error.

Anyway, they replaced the OCV and I got an oil change just in case. The check engine light is off for now, but we'll see how it goes.
Gugel is offline  
#6 Old 10-02-2011, 12:34 PM
Junior Member
 
Join Date: Aug 2011
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)

Ugh! It just happened again! This is the third time this has happened! What can be causing the OCV to keep on failing (despite being replaced)?
Gugel is offline  
#7 Old 10-02-2011, 12:42 PM
FUNCTION OVER FORM
 
Tufast's Avatar
 
Join Date: Nov 2008
Posts: 5,361
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Garage

Quote:
Originally Posted by Gugel View Post
Ugh! It just happened again! This is the third time this has happened! What can be causing the OCV to keep on failing (despite being replaced)?
I don't think it is the valve keeps failing due to internal issue, because we don't replace many of them. Its not a common issue like a brake lamp switch. So something is causing it to fail or the code is being set by something else with the OCV not actually being bad.

Sponsored By:
Columbus Body Works / ARK Performance / Modern Automotive Performance / Forged Performance
Tufast is offline  
#8 Old 10-02-2011, 12:46 PM
I'd rather do it myself
 
Red Raspberry's Avatar
 
Join Date: Aug 2009
Location: Flat lands of Illinois
Posts: 12,430
Mentioned: 0 Post(s)
Tagged: 1 Thread(s)
Quoted: 3 Post(s)
Garage

Is it always the same side?

2010 Red 2.0L track

Quote:
(R=D)<TPTB
Red Raspberry is online now  
#9 Old 10-02-2011, 12:46 PM
Junior Member
 
Join Date: Aug 2011
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)

Quote:
Originally Posted by Tufast View Post
I don't think it is the valve keeps failing due to internal issue, because we don't replace many of them. Its not a common issue like a brake lamp switch. So something is causing it to fail or the code is being set by something else with the OCV not actually being bad.
What do you recommend I tell the dealership when I come in?
Gugel is offline  
#10 Old 10-02-2011, 12:48 PM
I'd rather do it myself
 
Red Raspberry's Avatar
 
Join Date: Aug 2009
Location: Flat lands of Illinois
Posts: 12,430
Mentioned: 0 Post(s)
Tagged: 1 Thread(s)
Quoted: 3 Post(s)
Garage

Tell them to find the problem. Even a monkey can swap parts.

What is your oil change frequency? What oil do you use?

2010 Red 2.0L track

Quote:
(R=D)<TPTB
Red Raspberry is online now  
#11 Old 10-02-2011, 12:53 PM
Junior Member
 
Join Date: Aug 2011
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)

Quote:
Originally Posted by Red Raspberry View Post
Tell them to find the problem. Even a monkey can swap parts.

What is your oil change frequency? What oil do you use?
Yup, same side.
Oil change every 5k miles. Last oil change was 1.5k miles ago. I've been using Mobile 1 Synthetic.
Gugel is offline  
#12 Old 10-02-2011, 12:54 PM
I'd rather do it myself
 
Red Raspberry's Avatar
 
Join Date: Aug 2009
Location: Flat lands of Illinois
Posts: 12,430
Mentioned: 0 Post(s)
Tagged: 1 Thread(s)
Quoted: 3 Post(s)
Garage

My guess would be the wiring or the connector. But let them do the work as far as diagnosis.

2010 Red 2.0L track

Quote:
(R=D)<TPTB
Red Raspberry is online now  
#13 Old 10-02-2011, 02:07 PM
Junior Member
 
Join Date: Sep 2010
Posts: 26
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Could be the connector, harness, heck even possibly the ECM. Most of the time I see them is from an clogged up OCV filter or passageways in the cvvt/passageways normally due to lack of maintenance. I just had to replace a theta engine in an 07 sonata due to sludging. However since you said your oil looks good and has been changed at correct intervals, then I would probably point to the connector and later a break/short in the harness.
Dustwalker14 is offline  
#14 Old 10-03-2011, 01:14 PM
FUNCTION OVER FORM
 
Tufast's Avatar
 
Join Date: Nov 2008
Posts: 5,361
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Garage

Quote:
Originally Posted by Gugel View Post
What do you recommend I tell the dealership when I come in?
Like Red said, ask them to please find out what is shorting it out as you are tired of returning & wasting fuel.

Quote:
Originally Posted by Dustwalker14 View Post
Could be the connector, harness, heck even possibly the ECM. Most of the time I see them is from an clogged up OCV filter or passageways in the cvvt/passageways normally due to lack of maintenance. I just had to replace a theta engine in an 07 sonata due to sludging. However since you said your oil looks good and has been changed at correct intervals, then I would probably point to the connector and later a break/short in the harness.
Yep, when we do have one come in for an OCV issue it is due to sludging.

Sponsored By:
Columbus Body Works / ARK Performance / Modern Automotive Performance / Forged Performance
Tufast is offline  
#15 Old 10-04-2011, 12:28 PM
Senior Member
 
Join Date: Mar 2011
Posts: 1,294
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)

Quote:
Originally Posted by Gugel View Post
What do you recommend I tell the dealership when I come in?
Failed a third time. It'd tell them they better fix it this time, because if they don't you qualify for lemon law.
Jpc647 is offline  
#16 Old 03-27-2013, 04:53 PM
Junior Member
 
viperj284's Avatar
 
Join Date: Feb 2010
Location: Oxford, PA
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

They ever figure out what it was? Curious because I'm having the same issue. OCV failure on exhaust side. Second one replaced in a month.

Acqua Mineral Blue 2.0T Base Auto
viperj284 is offline  
#17 Old 03-27-2013, 06:57 PM
Junior Member
 
Join Date: Aug 2011
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)

Quote:
Originally Posted by viperj284 View Post
They ever figure out what it was? Curious because I'm having the same issue. OCV failure on exhaust side. Second one replaced in a month.
The engine finally gave out after 50k miles. Luckily, the warranty covered it and I got a brand new engine. So far so good.
Gugel is offline  
#18 Old 03-27-2013, 08:16 PM
xFa
 
Violak's Avatar
 
Join Date: Feb 2013
Location: sac, ca
Posts: 446
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Quote:
Originally Posted by Gugel View Post
The engine finally gave out after 50k miles. Luckily, the warranty covered it and I got a brand new engine. So far so good.
wow o.O

2013 Genesis Coupe 2.0T RSPEC

Lowering Springs 1.5F/1.2R
Violak is offline  
#19 Old 03-28-2013, 03:41 AM
Junior Member
 
viperj284's Avatar
 
Join Date: Feb 2010
Location: Oxford, PA
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Holy crap!

Acqua Mineral Blue 2.0T Base Auto
viperj284 is offline  
#20 Old 04-15-2013, 12:33 PM
Senior Member
 
Ian S's Avatar
 
Join Date: Jul 2009
Location: North Central Phoenix, AZ
Posts: 396
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)

Dang, I just had my 2011 GT in for that CEL last week and am still waiting for the part. Fortunately, all the oil/filter changes have been done by the dealership. Because I don't drive that many miles, the changes have been every six months since new.
Ian S is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Genesis Forum: GenCoupe Hyundai Genesis Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
is there an egr valve on 2.0t?? davidp 2.0T Discussion 2008-2012 9 06-17-2011 11:32 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome