DEPO Racing O2 Housing Install and Review - Page 3 - Hyundai Genesis Forum
Reply
 
LinkBack Thread Tools
post #41 of 177 Old 08-19-2011, 06:28 PM
Vroom Vroom Party Starter
 
Kolk1's Avatar
 
Join Date: Jun 2011
Location: Alton IL
Posts: 1,472
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Garage

Im still on my Rich(low 10s A/F) 22lb tune, and if I reset the light, and drive around for 3-4 days, it stays off, as soon as I do a couple of hard pulls, it seems pops back on. I have not tried it with my 20lb tune, and when I had my 20lb tune was redone, and is usually low 12s A/F.

Daily: 2011 SHO Taurus, AWD Twin Turbo, livernois Stage 4 kit.

For Sale: 2010 R-Spec 2.0T, 6sp, tinted windows, viper keyless R/S, basic little stuff.

Cruiser/Bruiser Bike: 2007 ZX-14, 300whp, Built block, Garrett GT2871R turbo, you name it.

Touring/backroading Bike: 2013 ZX-14R, Full titanium Hindle exhaust, dyno tuned, drop pegs, bar risers, Puig DB screen,
Kolk1 is offline  
Sponsored Links
Advertisement
 
post #42 of 177 Old 08-20-2011, 12:00 AM Thread Starter
End Me, Begin Him
 
OMEGA's Avatar
 
Join Date: Mar 2011
Location: NC
Posts: 675
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 73 Post(s)
(Thread Starter)

^ CEL came on at 11,799 Miles and hasn't gone off lol. I guess I wasn't lucky like the other guys. I got about 250 miles without it. Oh well, my BR-Reflash is on its way and it should take care of the CEL

**edit** My CEL went off at 12,329 miles!

Last edited by OMEGA; 08-22-2011 at 12:03 PM. Reason: new info
OMEGA is offline  
post #43 of 177 Old 08-20-2011, 04:19 PM
Vroom Vroom Party Starter
 
Kolk1's Avatar
 
Join Date: Jun 2011
Location: Alton IL
Posts: 1,472
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Garage

Im thinking about trying those spacers that put the O2 sensor out further, Im wondering how that would work, since it would be out twice as far since we already have a 1inch extended bung. As long as it still fits, Ill try it out. The exhaust gases would have to go through the normal small hole, then a 2nd small hole, so I would only assume it would slow down the amount of gases that reach all the way to the sensor. Ill glady try it out. Give me a couple days. lol

Daily: 2011 SHO Taurus, AWD Twin Turbo, livernois Stage 4 kit.

For Sale: 2010 R-Spec 2.0T, 6sp, tinted windows, viper keyless R/S, basic little stuff.

Cruiser/Bruiser Bike: 2007 ZX-14, 300whp, Built block, Garrett GT2871R turbo, you name it.

Touring/backroading Bike: 2013 ZX-14R, Full titanium Hindle exhaust, dyno tuned, drop pegs, bar risers, Puig DB screen,
Kolk1 is offline  
post #44 of 177 Old 08-20-2011, 04:57 PM Thread Starter
End Me, Begin Him
 
OMEGA's Avatar
 
Join Date: Mar 2011
Location: NC
Posts: 675
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 73 Post(s)
(Thread Starter)

^Interesting, in for results
OMEGA is offline  
post #45 of 177 Old 08-20-2011, 07:21 PM
Senior Member
 
AKGC's Avatar
 
Join Date: Jul 2009
Posts: 13,269
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 248 Post(s)

"spacer" = spark plug anti-foulers. they are like $5~ at any auto parts store.
AKGC is online now  
post #46 of 177 Old 08-20-2011, 10:20 PM
Vroom Vroom Party Starter
 
Kolk1's Avatar
 
Join Date: Jun 2011
Location: Alton IL
Posts: 1,472
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Garage

Quote:
Originally Posted by AKGC View Post
"spacer" = spark plug anti-foulers. they are like $5~ at any auto parts store.
Yea, I was at work making a quick post while I was waiting on my next appointment to show up. I knew they were cheap, that's why I figured if it's fits I'll try it out, but I'm not off work aging until Tuesday.

Daily: 2011 SHO Taurus, AWD Twin Turbo, livernois Stage 4 kit.

For Sale: 2010 R-Spec 2.0T, 6sp, tinted windows, viper keyless R/S, basic little stuff.

Cruiser/Bruiser Bike: 2007 ZX-14, 300whp, Built block, Garrett GT2871R turbo, you name it.

Touring/backroading Bike: 2013 ZX-14R, Full titanium Hindle exhaust, dyno tuned, drop pegs, bar risers, Puig DB screen,
Kolk1 is offline  
post #47 of 177 Old 08-20-2011, 10:56 PM
Senior Member
 
Abstract's Avatar
 
Join Date: Jun 2009
Location: Muharraq, Bahrain
Posts: 332
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

I used 2 small spark plugs defoulers on my Turbo XS o2 housing. Yeah, the CEL didn't come on, but after 2 days of driving, the car started bogging down in 4th and 5th gear on the highway. When I used to step on the gas, say when I'm cruising, the RPM wouldn't move and the car feels like it will come to a stop although the boost gauge is showing boost. Plus, I would hear a garggling sound from the engine. Removed the spacers and everything was back to normal.

I don't know if this happened because I was running almost all bolt-ons(still rocking the stock downpipe with a magnaflow catback at the moment) without a tune. So probably I was running lean...or the readings were off because the sensor was spaced out.

Grey 2.0t Track- A/T

Mods:
*Sarona Grill
*ProSport boost gauge
*SuperLUX LED tail light
*Greddy Oil Catch Tank
*AEM Cold Air Intake
*Dynojet Wideband kit
*Kinugawa 16g turbo(BTRcc stage 3 tune)
*Evo X injectors
*Mishimoto Radiator hose kit
*Beyond Redline manifold spacer
*CX Racing FMIC kit
*TurboXS o2 housing
*TurboXS RFL BOV
*Magnaflow muffler
*AEM F/IC 6(coming soon)
Abstract is offline  
post #48 of 177 Old 08-21-2011, 08:48 AM
Vroom Vroom Party Starter
 
Kolk1's Avatar
 
Join Date: Jun 2011
Location: Alton IL
Posts: 1,472
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Garage

You did space out the Rear O2 sensor right? I could see if you spaced the front one, it would try and fix the fuel ratio and mess up all types of stuff.

Daily: 2011 SHO Taurus, AWD Twin Turbo, livernois Stage 4 kit.

For Sale: 2010 R-Spec 2.0T, 6sp, tinted windows, viper keyless R/S, basic little stuff.

Cruiser/Bruiser Bike: 2007 ZX-14, 300whp, Built block, Garrett GT2871R turbo, you name it.

Touring/backroading Bike: 2013 ZX-14R, Full titanium Hindle exhaust, dyno tuned, drop pegs, bar risers, Puig DB screen,
Kolk1 is offline  
post #49 of 177 Old 08-21-2011, 11:17 AM
Senior Member
 
Abstract's Avatar
 
Join Date: Jun 2009
Location: Muharraq, Bahrain
Posts: 332
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

^I don't understand. How many o2 sensors does the car have? What I know is there are 2 cats and one sensor, which is located in the first cat right after the turbo outlet. The TurboXS, like any other aftermarket cat has 3 bungs, one for the o2 sensor and the other for the wideband sensor. Where's the second sensor located?

Grey 2.0t Track- A/T

Mods:
*Sarona Grill
*ProSport boost gauge
*SuperLUX LED tail light
*Greddy Oil Catch Tank
*AEM Cold Air Intake
*Dynojet Wideband kit
*Kinugawa 16g turbo(BTRcc stage 3 tune)
*Evo X injectors
*Mishimoto Radiator hose kit
*Beyond Redline manifold spacer
*CX Racing FMIC kit
*TurboXS o2 housing
*TurboXS RFL BOV
*Magnaflow muffler
*AEM F/IC 6(coming soon)
Abstract is offline  
post #50 of 177 Old 08-21-2011, 11:36 AM
Vroom Vroom Party Starter
 
Kolk1's Avatar
 
Join Date: Jun 2011
Location: Alton IL
Posts: 1,472
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Garage

Stock, the Car has 2 cats, and 2 sensors. In order it goes like this

{Turbo} O2 Sensor [Cat] O2 Sensor, then a piece of flex pipe and 3 feet later [2nd Cat]

Both of the 02 Sensors are on the same piece of pipe as the primary cat. The 2nd cat is under the car, about 3 feet down stream.

First O2 sensor actually monitors how the car is running, and makes changes to Air Fuel, The 2nd O2 sensor is only there to make sure the Primary cat is working properly. There are no sensors to make sure the 2nd cat is working, so it can be removed if needed, and there is no way you will see a code, or any changes in the car, if its pulled off.

Some aftermarket downpipes that replace the primary cat, do have 3 bungs. Normally, the first and third bung is for the 2 stock O2 sensors, and then you use the middle one for your wideband.

Heres a pic of my Down pipe, next to the stock Primary cat, They are sitting on the stool to where the turbo side is on the right. I do not have a 3rd bung. On my new downpipe you can barley see the bolt in the primary O2, its kinda underneath the pipe. Then at the very end of the pipe on the far left, you can see a longer 2inch Bung, thats where the 2nd O2 Sensor goes. Its extended so the 2nd sensor sees less exhaust gas, that way its tricked into thinking the Cat is still on the car.



If you removed the O2 sensor thats about 3 inchs from the turbo, your going to have a ton of issues. To get to the 2nd O2 sensor, you will need to get under the car, and look up slightly, its at the bottom of the firewall.

Daily: 2011 SHO Taurus, AWD Twin Turbo, livernois Stage 4 kit.

For Sale: 2010 R-Spec 2.0T, 6sp, tinted windows, viper keyless R/S, basic little stuff.

Cruiser/Bruiser Bike: 2007 ZX-14, 300whp, Built block, Garrett GT2871R turbo, you name it.

Touring/backroading Bike: 2013 ZX-14R, Full titanium Hindle exhaust, dyno tuned, drop pegs, bar risers, Puig DB screen,
Kolk1 is offline  
post #51 of 177 Old 08-21-2011, 11:47 AM
Senior Member
 
Abstract's Avatar
 
Join Date: Jun 2009
Location: Muharraq, Bahrain
Posts: 332
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

That's weird. I'm sure I've spotted only one o2 sensor when I was at the exhaust shop, which is on the stock primary cat. That's the one I spaced out and got trouble with. Could it be that I have a different regional spec than NA/Canada? Or probably I did miss seeing it.

Thanks for clarifying though.

Grey 2.0t Track- A/T

Mods:
*Sarona Grill
*ProSport boost gauge
*SuperLUX LED tail light
*Greddy Oil Catch Tank
*AEM Cold Air Intake
*Dynojet Wideband kit
*Kinugawa 16g turbo(BTRcc stage 3 tune)
*Evo X injectors
*Mishimoto Radiator hose kit
*Beyond Redline manifold spacer
*CX Racing FMIC kit
*TurboXS o2 housing
*TurboXS RFL BOV
*Magnaflow muffler
*AEM F/IC 6(coming soon)
Abstract is offline  
post #52 of 177 Old 08-21-2011, 11:52 AM
Vroom Vroom Party Starter
 
Kolk1's Avatar
 
Join Date: Jun 2011
Location: Alton IL
Posts: 1,472
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Garage

Didnt notice that, you might not have a 2nd one then, I dont know for sure. I just know what mine has.

But regardless, the 1st primary O2 sensor can not be spaced out. It needs to read full exhaust. I

Daily: 2011 SHO Taurus, AWD Twin Turbo, livernois Stage 4 kit.

For Sale: 2010 R-Spec 2.0T, 6sp, tinted windows, viper keyless R/S, basic little stuff.

Cruiser/Bruiser Bike: 2007 ZX-14, 300whp, Built block, Garrett GT2871R turbo, you name it.

Touring/backroading Bike: 2013 ZX-14R, Full titanium Hindle exhaust, dyno tuned, drop pegs, bar risers, Puig DB screen,
Kolk1 is offline  
post #53 of 177 Old 08-21-2011, 01:40 PM
I'd rather do it myself
 
Red Raspberry's Avatar
 
Join Date: Aug 2009
Location: Flat lands of Illinois
Posts: 15,653
Mentioned: 17 Post(s)
Tagged: 1 Thread(s)
Quoted: 3 Post(s)
Garage

The second O2 sensor tells the ECu if the cat is working. They all have two.

You can pull the 10A fuse in the passenger side (motor side of fuse box) fuse box to clear the code and not lose any presets anywhere.

2010 Red 2.0L track

Quote:
If the Pharaohs had duct tape, the Sphinx would still have a nose...."
Red Raspberry is offline  
post #54 of 177 Old 08-21-2011, 05:04 PM
Vroom Vroom Party Starter
 
Kolk1's Avatar
 
Join Date: Jun 2011
Location: Alton IL
Posts: 1,472
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Garage

I wasnt sure if all countries had the same Emissions equipment or not. But I would assume they all would.

Daily: 2011 SHO Taurus, AWD Twin Turbo, livernois Stage 4 kit.

For Sale: 2010 R-Spec 2.0T, 6sp, tinted windows, viper keyless R/S, basic little stuff.

Cruiser/Bruiser Bike: 2007 ZX-14, 300whp, Built block, Garrett GT2871R turbo, you name it.

Touring/backroading Bike: 2013 ZX-14R, Full titanium Hindle exhaust, dyno tuned, drop pegs, bar risers, Puig DB screen,
Kolk1 is offline  
post #55 of 177 Old 08-21-2011, 06:52 PM
I'd rather do it myself
 
Red Raspberry's Avatar
 
Join Date: Aug 2009
Location: Flat lands of Illinois
Posts: 15,653
Mentioned: 17 Post(s)
Tagged: 1 Thread(s)
Quoted: 3 Post(s)
Garage

There has to be some way to check the operation of the first O2 sensor.

2010 Red 2.0L track

Quote:
If the Pharaohs had duct tape, the Sphinx would still have a nose...."
Red Raspberry is offline  
post #56 of 177 Old 08-21-2011, 10:30 PM Thread Starter
End Me, Begin Him
 
OMEGA's Avatar
 
Join Date: Mar 2011
Location: NC
Posts: 675
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 73 Post(s)
(Thread Starter)

Nvm I spoke too soon. My CEL went off at 12,329 miles lol
OMEGA is offline  
post #57 of 177 Old 08-25-2011, 12:57 PM
Oh crap a speed bump.....
 
ZXRider's Avatar
 
Join Date: Jul 2010
Location: Garland TX
Posts: 360
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Garage

so this does not have a third bung for a wideband sensor correct? i'd have to order the racing depot downpipe aswell for a place to put my wideband? lol right now i have the gauge installed, but the sensor is just hanging in my engine bay, cause I didn't want to install it so close to the turbo and burn it out.

2011 K White 2.0T R-Spec
Magnaflow CBE|CP-e Catless DP|AEM CAI|HKS SSQV|mishimoto stealth intercooler|Matte black wing badge|M&S type D grill|8K HID's|Megan racing coilovers|
RMR Owners Club

*Join my facebook group if you are located in North TX*

NTX Genesis coupe owners
http://www.facebook.com/groups/208767555854830
ZXRider is offline  
post #58 of 177 Old 08-25-2011, 01:10 PM
Jedi Master
 
cris90's Avatar
 
Join Date: Feb 2011
Location: Bergen County NJ
Posts: 6,462
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)

^ search but i know someone had made a heat shield for the wideband bung out of copper, seam really straight forward and it worked well for then.

I am not a list of mods but what i know and share:
http://www.gencoupe.com/2-0t/94778-fuel-system-what-you-need-know.html
http://www.gencoupe.com/2-0t/86146-wastegate-101-a.html
http://www.gencoupe.com/2-0t/91199-compressor-maps-how-read-them.html

Fav. JT Quote

Quote:
I know you like making threads about these things that have been covered a ton, but this time, no.
cris90 is offline  
post #59 of 177 Old 08-25-2011, 03:40 PM
Senior Member
 
Join Date: Mar 2010
Location: San Jose
Posts: 615
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)

Another review

I ended up trying out this testpipe after the positive reviews here. Let me start off by saying this testpipe does not fit perfectly. I requires re-drilling of the turbo side flange, and a custom fabrication to the mounting hardware that connects below. This is not a simple bolt on so buyers beware, you will need to work, to make this work. I had the tools and resources to make this fit, but others might find it disappointing and frustrating.

Otherwise, the pipe seems to function properly with no leaks. Will have to monitor this long term for the quality assessment.

The second o2 sensor bung comes pre-extended (non fouler not needed) and sealed with a small opening to give the sensor the 'hacked' readings. However, it does not work. I got a CEL within 100 miles.

CEL code P0140 - indicates an inactive downstream o2 sensor (no reading from it)

I'm guessing that the opening is either too small or the extension is too long. I ended up drilling through the opening to make it wider, freeing up more flow for the sensor to read. No CEL yet but I havent driven much. Will keep updated on this too.

Overall, I give this testpipe 2/5. I give it 2 points because its dirt cheap, significantly cheaper than the mainstream pipes. But you get what you pay for...
solidfish is offline  
post #60 of 177 Old 08-27-2011, 07:59 PM
Vroom Vroom Party Starter
 
Kolk1's Avatar
 
Join Date: Jun 2011
Location: Alton IL
Posts: 1,472
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Garage

Ive been slacking and paying attention to my ZX14 lately. Sorry guys.

I just put on my 20lb tune, so ill see if goes away with my dynotuned/leaner tune.

I wish there was a 100% way to see if the O2 CEL is coming on due to too much, or not enough gas reading, but that may differ from car to car. Ill try this 20lb tune for a couple days, and see what happens, if its still on by thursday, ill try adding the spark plug adapters so it gets less gas, to see if that helps it go off. Drilling a hole so it gets more gas would be a last resort, because unless I can stick a welder up there, there is no way to make that hole smaller again after its drilled out.

Daily: 2011 SHO Taurus, AWD Twin Turbo, livernois Stage 4 kit.

For Sale: 2010 R-Spec 2.0T, 6sp, tinted windows, viper keyless R/S, basic little stuff.

Cruiser/Bruiser Bike: 2007 ZX-14, 300whp, Built block, Garrett GT2871R turbo, you name it.

Touring/backroading Bike: 2013 ZX-14R, Full titanium Hindle exhaust, dyno tuned, drop pegs, bar risers, Puig DB screen,
Kolk1 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Hyundai Genesis Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Depo Racing 3" O2 Housing 119.99 shipped Depo Racing Engine 281 11-29-2016 02:03 PM
depo racing intercooler kit :) Nikko@ImportShark 2.0T Discussion 2008-2012 55 06-07-2013 12:14 PM
Depo Racing Intercooler $239.99 Shipped Depo Racing Engine 38 05-24-2012 07:37 PM
Exceladyne or Depo racing FMIC keltic 2.0T Discussion 2008-2012 29 07-15-2011 02:22 PM
MXP O2 Housing Pre-install review Mcmonopoly GENRACER 23 06-24-2011 08:47 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome