Engine problem, P0340 and P0365 - Hyundai Genesis Forum
 
LinkBack Thread Tools
post #1 of 4 Old 03-05-2018 Thread Starter
Junior Member
 
Join Date: Oct 2013
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Garage
(Thread Starter)
Engine problem, P0340 and P0365

Hello! I got the codes, P0365 (exhaust camshaft signal missing) and P0340 (camshaft position sensor A circuit malfunction bank 1 or single sensor). Does anyone have experience of these codes? I have read that the timing chain could be stretched, but no case where this is confirmed.
Please help me!
limpix92 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 03-25-2018
Senior Member
 
genesisgenius's Avatar
 
Join Date: Jan 2018
Posts: 223
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 40 Post(s)
Garage

whats your symptoms, no start? any compression. might have jumped timing if no start and need timing chain kit and valves as this is a interference motor meaning the piston hits the valves when it jumps timing

GenesisGenius
Youtube Channel. http://youtube.com/c/genesisgenius
genesisgenius is offline  
post #3 of 4 Old 03-25-2018
Senior Member
 
genesisgenius's Avatar
 
Join Date: Jan 2018
Posts: 223
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 40 Post(s)
Garage

those camshaft codes pop up when it has jumped timing already fixed one like that. causes are low oil, dirty oil, going to long with oil changes, using shitty oil filters and wrong oil viscosity. always use a 5w-20, 5w-30, or 5w40 never 10w.

GenesisGenius
Youtube Channel. http://youtube.com/c/genesisgenius
genesisgenius is offline  
 
post #4 of 4 Old 2 Weeks Ago
Junior Member
 
Join Date: Aug 2019
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

Quote:
Originally Posted by genesisgenius View Post
those camshaft codes pop up when it has jumped timing already fixed one like that. causes are low oil, dirty oil, going to long with oil changes, using shitty oil filters and wrong oil viscosity. always use a 5w-20, 5w-30, or 5w40 never 10w.
What was your fix for this? Timing chain?
Todd Wayne is offline  
Sponsored Links
Advertisement
 
Reply

Related Threads
Thread Thread Starter Forum Replies Last Post
P0365 Camshaft Position Sensor "B" Circuit Evink 2.0T Discussion 2013 and up 43 2 Weeks Ago 04:40 PM
Engine water problem chochich 2.0T Discussion 2008-2012 3 09-16-2015 05:03 AM
Potential future exhaust or engine problem? jab General Discussion 2 07-28-2013 02:51 PM
Transmission/engine problem? Pyrophor2011 Drivetrain 11 06-13-2011 03:24 AM
Engine problem Bobaguy 2.0T Discussion 2008-2012 51 03-06-2011 12:09 PM


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Hyundai Genesis Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome