No power? - Page 3 - Hyundai Genesis Forum
Reply
 
LinkBack Thread Tools
post #41 of 48 Old 04-25-2019
CRC
Member
 
Join Date: May 2011
Location: South Central, Louisiana
Posts: 110
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

Quote:
Originally Posted by Jasperxxl View Post
My apologies if this has been answered, I have searched some forums and google a bunch and not sure where I should start.

So the other day I was coming home from work being tired and 11:30 at night I wasn't in any mood to "handle" my car like I would on any other day. Everything seemed fine heard the turbo spool when I started the car and when I was on the freeway trying to get up to speed my car was extremely sluggish, wouldn't go past about 5k RPM and wasn't able to hear the turbo. I stopped, got gas thinking I had low fuel as my gas gauge isn't working properly right now, start rolling out, heard no turbo spool and had no power still. I got home that night started looking at my motor, everything seemed fine, no smoke, no weird noise or smell. Finally got all the piping and stuff off the turbo and made sure the turbo itself still spun by hand and made sure the blades were not damaged. I checked all inter-cooler piping and I did have what I think is a vacuum line was cracked so I had replaced to no difference. Also, there is no CEL or anything on the dash. So, as of now I have three theories.

1. The turbo pressure sensor is bad

2. The waste gate is stuck open

3. The turbo is just bad.

What do you mean by this statement? If your ecu thinks you're low on fuel it will limit boost.

2010 2.0T Track M/T Tsukuba Red

BR Stage 1 Tune
BR Cat-back Exhaust
CNT Test Pipe
AGP Catch Can and Breather
CRC is offline  
Sponsored Links
Advertisement
 
post #42 of 48 Old 04-25-2019 Thread Starter
Member
 
Join Date: Dec 2017
Posts: 35
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 13 Post(s)
(Thread Starter)

Quote:
Originally Posted by CRC View Post
What do you mean by this statement? If your ecu thinks you're low on fuel it will limit boost.
My gauge is just reading wrong like +/- a couple gallons or it will float back up just past half if im just under half just random ****. Like it shows I have more than half a tank of gas which is true as i just filled up but it doesn't think im empty or anything. I know if you are low on fuel your turbo doesn't kick in. I have been running this for a couple months now with no issue.
Jasperxxl is offline  
post #43 of 48 Old 04-25-2019
Love the corners
 
barfoboy's Avatar
 
Join Date: Mar 2012
Location: Texas
Posts: 26
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)

The timing code may be solved by replacing the sensor. Erratic timing is a bad thing.

Test the new sensor by disconnecting the battery, connect the battery then drive the car.

After that are soooo many possibilities.
barfoboy is offline  
 
post #44 of 48 Old 04-25-2019 Thread Starter
Member
 
Join Date: Dec 2017
Posts: 35
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 13 Post(s)
(Thread Starter)

Quote:
Originally Posted by Pchelka View Post
it wont...
AKGC is right on the sensors... try cylinder leak test
So new discoveries, I added oil to the car and cleared the codes. I ran the car around the block with same results as before with no power. I came in and ran the codes. P0014 cleared, but P0299 persisted. Interesting.... I did a small vacuum test on the WG and the BOV. The BOV opened and then closed once I released the vacuum. When I did the same for the WG, uhh the vacuum held pressure. I pulled the rod on the WG and nothing happened, I'm not sure what I'm expecting it to do. With no vacuum pressure, I pulled the rod to the WG and it didnt create a vacuum.

Not sure if this helps with anything, I have a WG on its way.
Jasperxxl is offline  
post #45 of 48 Old 04-26-2019
Senior Member
 
lightthemup's Avatar
 
Join Date: Sep 2011
Posts: 726
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 73 Post(s)
Garage

The WG works off boost not vacuum, if you have no boost the wastegate is naturally closed by spring pressure, you have to pull hard on the arm to open it.
My guess is the flap that closes the WG on the turbine broke off, but it's just my guess.

Sent from my SM-G935V using Tapatalk


My Dad told me I should turn the other cheek... but keep my fist ready...
2011 base Auto. BK2 engine, Elite Evo 9 kit with TD06SL2R-20G 7+7 billet compressor wheel and anti surge cover, BTR stage 3 tune, 550cc injectors, fuel return line, AEM Methanol injection,CXR intercooler, full exhaust with ARK, LSD...ported heads and intake manifold...bla.bla.bla
lightthemup is offline  
post #46 of 48 Old 04-26-2019
I'd rather do it myself
 
Red Raspberry's Avatar
 
Join Date: Aug 2009
Location: Flat lands of Illinois
Posts: 18,017
Mentioned: 18 Post(s)
Tagged: 1 Thread(s)
Quoted: 3 Post(s)
Garage

You should still get about 5 lbs of boost even with low fuel.

2010 Red 2.0L track

Quote:
If the Pharaohs had duct tape, the Sphinx would still have a nose...."
Red Raspberry is offline  
post #47 of 48 Old 04-26-2019
Member
 
Join Date: Apr 2018
Posts: 99
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 26 Post(s)

Quote:
Originally Posted by lightthemup View Post
The WG works off boost not vacuum, if you have no boost the wastegate is naturally closed by spring pressure, you have to pull hard on the arm to open it.
My guess is the flap that closes the WG on the turbine broke off, but it's just my guess.

Sent from my SM-G935V using Tapatalk
That can be checked - just grab the rod (Do NOT twist it) push and pull on it, you should hear the flapper actually making a sound when it closes / hits the exhaust port

Last edited by Pchelka; 04-26-2019 at 05:05 AM.
Pchelka is offline  
post #48 of 48 Old 05-13-2019 Thread Starter
Member
 
Join Date: Dec 2017
Posts: 35
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 13 Post(s)
(Thread Starter)

Good morning, afternoon, evening.

The not so epic conclusion to the story, It was the turbo. The exhaust turbine shaft was bent, went out on a limb and bought a used turbo and put it in last night. Back to normal. Little leaky cause old gaskets but they have been ordered.

Thanks to everyone for your inputs, I have learned a lot about my car.
Jasperxxl is offline  
Sponsored Links
Advertisement
 
Reply

Related Threads
Thread Thread Starter Forum Replies Last Post
Agency Power Exhausts Clearance sale!!!! TuscaniCustoms Engine 44 09-20-2014 05:05 PM
░░▒▒▓▌Agency Power Cat-Back for 2.0T & 3.8 V6! [CLEARANCE PRICE!] ║ GenRacer GenRacer Support Engine 1 10-07-2013 07:29 AM
Power Axel Power x 2 With br tune 150+shipping shawnt321 Engine 15 08-01-2011 10:51 AM
Another RRM Next State Power Pro Review brandon1987 3.8 V6 Discussion 2008-2012 111 01-28-2010 01:41 PM
Official ROAD/RACE- Next Stage Power Pro Challenge ROCK 2.0T Discussion 2008-2012 337 01-23-2010 08:52 PM


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Hyundai Genesis Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome