Throttle Body issue/P2118 - Hyundai Genesis Forum
 
LinkBack Thread Tools
post #1 of 9 Old 03-25-2019 Thread Starter
Senior Member
 
Dima's Avatar
 
Join Date: Jul 2013
Location: Toronto
Posts: 193
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 18 Post(s)
(Thread Starter)
Throttle Body issue/P2118

My car has been idling rough and lots of hesitation under light/steady throttle. Then the car finally threw a P2118 and went into limp mode, had to turn the car on and off to get rid of limp mode and the car seems to be fine under moderate/heavy throttle, just that light/steady throttle. Also it comes and goes, there is no rhyme or reason to this.

Looks like this user had the same issue https://www.gencoupe.com/2-0t-discus...18-2110-a.html

Going to try to clean the throttlebody first before going the replacement route, can anyone recommend what to clean the TB with?
Also, can anyone confirm/deny if warranty covers the TB? Tt's part of the engine so it should be covered by powertrain warranty but from what the OP in that thread said the dealer wouldn't cover it..

Thanks.

2013 Casablanca White R-Spec
Dima is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 03-25-2019
Junior Member
 
yochu's Avatar
 
Join Date: Jul 2014
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

Is this happening in a certain throttle range, like between 0%-10% pedal input from a stop? I am not familiar with the code, but it sounds a little like an issue I had when I got my car.

I had an issue where from a stop/low throttle it didn't accelerate very much sometimes, then past about 10% pedal input it would take off like a rocket. It was like the throttle was lagging in response to the input on the pedal, or that it was bogging down until it reached a certain amount of pressure then snapping open to correct. This drove me nuts for a while because it didn't happen every time. I found that if I revved a little before engaging the clutch, it was usually fine.

There was a TSB with a firmware update for acceleration issues, and that helped a little. It is in my records from ABC Hyundai in Vegas as "ECM Update 14-FL-005 in response to customer statement of intermittent hesitation when accelerating".

A dirty TB was also partially responsible. Mine gets gunked up on the rear of the butterfly pretty quick even with catch cans. I would suggest popping your off, and cleaning/lubricating the butterfly.

I also got an electronic throttle controller, and that made a lot of difference in the acceleration curve, and it no longer felt laggy when initially accelerating. There are a bunch of these for sale with different names (I.e sprint booster, xtros potent booster, pedal commander etc.) and it allows some user adjustment of the throttle curve.

All of that together made it a lot better. Not perfect, but a lot more enjoyable to drive. You can also have some of the tuners change the throttle map for something closer to 1-1 response if you are inclined to get a tune.

Sorry if that isn't what you are experiencing, but it sounded like you may be having something similar.
yochu is offline  
post #3 of 9 Old 03-25-2019
I'd rather do it myself
 
Red Raspberry's Avatar
 
Join Date: Aug 2009
Location: Flat lands of Illinois
Posts: 17,968
Mentioned: 18 Post(s)
Tagged: 1 Thread(s)
Quoted: 3 Post(s)
Garage

How is the idle speed? When i got a dirty TB and a code I could also see the ECU going crazy with timing at idle trying to control the speed.

2010 Red 2.0L track

Quote:
If the Pharaohs had duct tape, the Sphinx would still have a nose...."
Red Raspberry is offline  
 
post #4 of 9 Old 03-25-2019
I'd rather do it myself
 
Red Raspberry's Avatar
 
Join Date: Aug 2009
Location: Flat lands of Illinois
Posts: 17,968
Mentioned: 18 Post(s)
Tagged: 1 Thread(s)
Quoted: 3 Post(s)
Garage

How is the idle speed? When i got a dirty TB and a code I could also see the ECU going crazy with timing at idle trying to control the speed.

2010 Red 2.0L track

Quote:
If the Pharaohs had duct tape, the Sphinx would still have a nose...."
Red Raspberry is offline  
post #5 of 9 Old 03-25-2019 Thread Starter
Senior Member
 
Dima's Avatar
 
Join Date: Jul 2013
Location: Toronto
Posts: 193
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 18 Post(s)
(Thread Starter)

Quote:
Originally Posted by Red Raspberry View Post
How is the idle speed? When i got a dirty TB and a code I could also see the ECU going crazy with timing at idle trying to control the speed.
When it's happening it's bouncing between like 500 and 1200 RPM. I just cleaned the TB and waiting for my OBD2 reader to come in so I can monitor timing and codes, and other things.

Quote:
Originally Posted by yochu View Post
Is this happening in a certain throttle range, like between 0%-10% pedal input from a stop? I am not familiar with the code, but it sounds a little like an issue I had when I got my car.

I had an issue where from a stop/low throttle it didn't accelerate very much sometimes, then past about 10% pedal input it would take off like a rocket. It was like the throttle was lagging in response to the input on the pedal, or that it was bogging down until it reached a certain amount of pressure then snapping open to correct. This drove me nuts for a while because it didn't happen every time. I found that if I revved a little before engaging the clutch, it was usually fine.

There was a TSB with a firmware update for acceleration issues, and that helped a little. It is in my records from ABC Hyundai in Vegas as "ECM Update 14-FL-005 in response to customer statement of intermittent hesitation when accelerating".

A dirty TB was also partially responsible. Mine gets gunked up on the rear of the butterfly pretty quick even with catch cans. I would suggest popping your off, and cleaning/lubricating the butterfly.

I also got an electronic throttle controller, and that made a lot of difference in the acceleration curve, and it no longer felt laggy when initially accelerating. There are a bunch of these for sale with different names (I.e sprint booster, xtros potent booster, pedal commander etc.) and it allows some user adjustment of the throttle curve.

All of that together made it a lot better. Not perfect, but a lot more enjoyable to drive. You can also have some of the tuners change the throttle map for something closer to 1-1 response if you are inclined to get a tune.

Sorry if that isn't what you are experiencing, but it sounded like you may be having something similar.
I'm not talking about input lag, this does happen between 0 and 10% throttle roughly but it's like it keeps opening and closing on it's own when I keep my foot steady on the throttle. It even happens if I have my cruise control on.

2013 Casablanca White R-Spec
Dima is offline  
post #6 of 9 Old 03-26-2019
I'd rather do it myself
 
Red Raspberry's Avatar
 
Join Date: Aug 2009
Location: Flat lands of Illinois
Posts: 17,968
Mentioned: 18 Post(s)
Tagged: 1 Thread(s)
Quoted: 3 Post(s)
Garage

I used brake cleaner to clean my TB and a rag.

2010 Red 2.0L track

Quote:
If the Pharaohs had duct tape, the Sphinx would still have a nose...."
Red Raspberry is offline  
post #7 of 9 Old 03-26-2019 Thread Starter
Senior Member
 
Dima's Avatar
 
Join Date: Jul 2013
Location: Toronto
Posts: 193
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 18 Post(s)
(Thread Starter)

I got a throttle body cleaner, smells simialr to break cleaner. Problem is still persisting though.

2013 Casablanca White R-Spec
Dima is offline  
post #8 of 9 Old 03-26-2019
I'd rather do it myself
 
Red Raspberry's Avatar
 
Join Date: Aug 2009
Location: Flat lands of Illinois
Posts: 17,968
Mentioned: 18 Post(s)
Tagged: 1 Thread(s)
Quoted: 3 Post(s)
Garage

Could be a bum TB. If you get a scanner watch the absolute throttle position as well as the timing.

2010 Red 2.0L track

Quote:
If the Pharaohs had duct tape, the Sphinx would still have a nose...."
Red Raspberry is offline  
post #9 of 9 Old 03-26-2019
Junior Member
 
yochu's Avatar
 
Join Date: Jul 2014
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

When you cleaned it, was there a lot of gunk on either side of the butterfly? I used TB cleaner and then a shot of white lithium (WD-40 spray on lithium) to make sure it moved freely.

P2118 Throttle Actuator Control Motor Current Range -

"The PCM controls the Throttle Actuator Control System by monitoring one or more throttle position sensors. The operation of the throttle body is determined by the position of the throttle plate that is controlled by one or more Throttle Actuator Control Motors. The PCM also monitors the accelerator pedal position sensor to determine how fast the driver wants to go and then determines the appropriate throttle response. The PCM accomplishes this by a changing current flow to the Throttle Actuator Control Motor that moves the throttle plate to the desired position. Some malfunctions will cause the PCM to restrict the operation of the Throttle Actuator Control System. This is known as fail-safe or limp mode where the engine is held at idle or may not start at all.

Read more at: https://www.obd-codes.com/p2118"

Sounds like your issue may be more than simple cleaning if there was not a noticeable buildup. It may be the connection, the TPS sensors, or calibration etc. These are the things I would consider doing if I was in your position.

Could try reseating the connector on the TB, and while unplugged, check the 6 pins in the connector in case they are bent/damaged, and if any of the wire is exposed from either end of the sheath, make sure it isn't damaged. If pins/wire are good, maybe a shot of deox-it on the metal parts of the connector to clean it up.

If you have a friend with a GC, see if you can borrow their TB for a little bit for diag and see if one you know works changes your cars response. You may have to do the step below for calibration if you do switch with a friend.

There was also a TB recalibration process explained by SFR on the forum, may be worth doing. [email protected] refered to it as the "Key Dance", and this may help if the ECU thinks the butterfly position should be different.

There is also the hyundai GDS diagnostic/repair software and I believe it has a more in depth TB calibration if you know anyone that has access to it. I haven't used it before, just seen pics, so I am not sure what the calibration process is like.

Let us know if you solve it and what you did. Good luck!

Last edited by yochu; 03-26-2019 at 01:53 PM.
yochu is offline  
Sponsored Links
Advertisement
 
Reply

Related Threads
Thread Thread Starter Forum Replies Last Post
Never-ending throttle body replacements Cryptonic_Sonic 3.8 V6 Discussion 2013 and up 18 6 Days Ago 04:58 AM
::THROWDOWN:: P2R Throttle Body Spacers Now For Sale @ Throwdown Performance!! Throwdown Engine 442 07-17-2016 11:13 PM
Haltech ECU Technical Information HaltechAdam 2.0T Discussion 2008-2012 780 04-05-2016 10:47 AM
FS: 2.0 OEM throttle body (TB) w/ gasket D!RTYLOUD Engine 1 02-18-2016 06:20 AM
**Interest Thread** P2R PowerRevRacing Throttle Body Spacers for 2.0T & 3.8 V6!!! Throwdown Engine 62 12-13-2011 02:27 AM


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Hyundai Genesis Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome