Seems like the fun times in my genesis coupe are over. No one seems to understand my - Hyundai Genesis Forum
 1Likes
Reply
 
LinkBack Thread Tools
post #1 of 22 Old 3 Weeks Ago Thread Starter
Junior Member
 
Join Date: Jul 2019
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
(Thread Starter)
Seems like the fun times in my genesis coupe are over. No one seems to understand my

my car is working harder than it suppose to i have done everything to get it checked out but no local mechanic shops understands what i’m saying.

My coupe A/T bK1 3.8 engine rpms are working harder than it should.
For example when using the sport mode feature where you can shift gears my Genesis Coupe rpms are a lot higher in every gear now.

Before i would be driving in 3rd gear @40 mph at 2500-3000 rpm now at the same speed same gear i’m getting 3200-3500 rpm @40 mph

Second the vibrating feeling in the cabin you can feel it in the seats, when you put your hands on the wheel and when you put your hand on the gear selection knob.

All this started happening soon after i refilled my A/C due to a huge leak in the system that i have. So i filled it back up with a/c refrigerant and took off driving my car started to buck and did not move at all and wouldn’t move until i shifted to neutral then back into drive and that was when the car starting moving again soon i put the car back into sport mode feature and while driving and upshifted the car started sputtering.

once that happened and i pulled over and let the car rest for a second after restarting the car and drove home i felt huge decline in Acceleration and lag in torque and now i have to put my foot down on the pedal just gain speed to pass someone etc. not to mention it feels like my engine will stall out at any moment sometimes. now when turning on the A/C you can hear whistle noise behind the vents and funny thing is sometimes when A/C will engage when i turn it on the car acceleration will somewhat return to normal which very odd

i have replaced my sparkplugs and coils did a trans service and made sure it wasn’t a transmission issue as i thought at first. i had my car looked at by 3 different shops checking my exhaust Cat etc. and they can’t see or understand my issue with the lost of acceleration i’m having. Hate to do this as my last option but i have to take it to the stealership to see if they might pinpoint this issue.
Tim.Rich92 is offline  
Sponsored Links
Advertisement
 
post #2 of 22 Old 3 Weeks Ago
Reader of many threads
 
TKJode's Avatar
 
Join Date: Aug 2010
Location: Toronto, ON
Posts: 1,421
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 206 Post(s)
Garage

hesitation, stumbling, near stalling, loss of power and excessive vibration sounds like an induction/fuel/ignition issue. You already checked coils/spark so that should be OK....

Did anything get moved around/disconnected while working on the A/C problem? Check for loose or crimped hoses under the hood. I had a PCV hose pop off and it caused similar symptoms. Check the intake seal at the throttle body for good measure.

Beyond that, invest in an OBD2 reader and try to diagnose the problem from sensor readings. You might find pending codes that'll give you an idea of where the problem is. PCV issue for me threw too-lean Bank 2 b/c of air bypassing the airflow sensor.

2010 Silverstone 380GT
TKJode is offline  
post #3 of 22 Old 3 Weeks Ago
Senior Member
 
AKGC's Avatar
 
Join Date: Jul 2009
Posts: 14,777
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 746 Post(s)

If it indeed started happening after you refilled the AC, then it sounds to me that you OVERFILLED it.

What I mean is, even if you have an AC leak, there is still AC oil in the system. 90% if the diy ac cans have ac oil included.


Also... how did you refill it?
Once you replace the leaking part, you HAVE to vacuum out the system to 32 psi of vacuum, then fill the system with refrigerant.
Vacuuming out the system won't remove the oil that's still in there.
AKGC is online now  
 
post #4 of 22 Old 3 Weeks Ago Thread Starter
Junior Member
 
Join Date: Jul 2019
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
(Thread Starter)

Quote:
Originally Posted by TKJode View Post
hesitation, stumbling, near stalling, loss of power and excessive vibration sounds like an induction/fuel/ignition issue. You already checked coils/spark so that should be OK....

Did anything get moved around/disconnected while working on the A/C problem? Check for loose or crimped hoses under the hood. I had a PCV hose pop off and it caused similar symptoms. Check the intake seal at the throttle body for good measure.

Beyond that, invest in an OBD2 reader and try to diagnose the problem from sensor readings. You might find pending codes that'll give you an idea of where the problem is. PCV issue for me threw too-lean Bank 2 b/c of air bypassing the airflow sensor.
i had a midas do a A/C check and refill couple days before they were trying to see why the A/C was low but at that time but couldn’t see a issue. Also i forgot to mention that weird humming noise around the A/C Compressor and alternator and vibration is coming from there it seems other than that i recently had a smoke test done and fixed vac leak on the intake that was a easy fix but the issue i’m having is still present
Tim.Rich92 is offline  
post #5 of 22 Old 3 Weeks Ago Thread Starter
Junior Member
 
Join Date: Jul 2019
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
(Thread Starter)

Quote:
Originally Posted by AKGC View Post
If it indeed started happening after you refilled the AC, then it sounds to me that you OVERFILLED it.

What I mean is, even if you have an AC leak, there is still AC oil in the system. 90% if the diy ac cans have ac oil included.



Also... how did you refill it?
Once you replace the leaking part, you HAVE to vacuum out the system to 32 psi of vacuum, then fill the system with refrigerant.
Vacuuming out the system won't remove the oil that's still in there.
i agree i have probably overfilled the system and i refilled it via low side port the can came with a adapter that connects right on it
Tim.Rich92 is offline  
post #6 of 22 Old 3 Weeks Ago
Senior Member
 
AKGC's Avatar
 
Join Date: Jul 2009
Posts: 14,777
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 746 Post(s)

Quote:
Originally Posted by Tim.Rich92 View Post
i had a midas do a A/C check and refill couple days before they were trying to see why the A/C was low but at that time but couldnít see a issue. Also i forgot to mention that weird humming noise around the A/C Compressor and alternator and vibration is coming from there it seems other than that i recently had a smoke test done and fixed vac leak on the intake that was a easy fix but the issue iím having is still present
Did midas hook it up to a machine, or did they use cans?

Take it to a shop that is licensed to do HVAC maintenance.
Basically, take it to a shop that has a big machine for AC removal and refilling.
AKGC is online now  
post #7 of 22 Old 3 Weeks Ago
I'd rather do it myself
 
Red Raspberry's Avatar
 
Join Date: Aug 2009
Location: Flat lands of Illinois
Posts: 18,235
Mentioned: 21 Post(s)
Tagged: 1 Thread(s)
Quoted: 3 Post(s)
Garage

I've seen my rpms climb as the tires wear down.

2010 Red 2.0L track

Quote:
If the Pharaohs had duct tape, the Sphinx would still have a nose...."
Red Raspberry is online now  
post #8 of 22 Old 3 Weeks Ago
Senior Member
 
Gaijinn's Avatar
 
Join Date: Jul 2017
Location: Indianapolis In
Posts: 768
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 241 Post(s)
Trouble............

My coupe A/T bK1 3.8 engine rpms are working harder than it should.
For example when using the sport mode feature where you can shift gears my Genesis Coupe rpms are a lot higher in every gear now.

Before i would be driving in 3rd gear @40 mph at 2500-3000 rpm now at the same speed same gear iím getting 3200-3500 rpm @40 mph.


^^^

So the above is symptomatic of a high mileage trans where the fluid was never maintained. How many miles on the car. How many miles since or even "if" you changed the trans fluid. Which trans do you have.

If you have a really abused high mileage trans, add the LUCAS trans stuff that the youtube mechanic "Scotty" swears by. If the above is the case it will just buy you time. People who exceed 100K with the same ATF,(and there are alot of people that do this), have sealed the trans fate.

**You canalso do the following. If you change out your trans fluid, switch to CERMA ATF. It doesnt matter what type of fluid you need. Its better/suited for any trans made today. If you have internal seals hardened it will re-juvenate them worth a shot. Replacing/rebuilding your trans is worth more than the car probably.

Here we go again !
Gaijinn is offline  
post #9 of 22 Old 3 Weeks Ago Thread Starter
Junior Member
 
Join Date: Jul 2019
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
(Thread Starter)

Quote:
Originally Posted by Gaijinn View Post
My coupe A/T bK1 3.8 engine rpms are working harder than it should.
For example when using the sport mode feature where you can shift gears my Genesis Coupe rpms are a lot higher in every gear now.

Before i would be driving in 3rd gear @40 mph at 2500-3000 rpm now at the same speed same gear i’m getting 3200-3500 rpm @40 mph.


^^^

So the above is symptomatic of a high mileage trans where the fluid was never maintained. How many miles on the car. How many miles since or even "if" you changed the trans fluid. Which trans do you have.

If you have a really abused high mileage trans, add the LUCAS trans stuff that the youtube mechanic "Scotty" swears by. If the above is the case it will just buy you time. People who exceed 100K with the same ATF,(and there are alot of people that do this), have sealed the trans fate.

**You canalso do the following. If you change out your trans fluid, switch to CERMA ATF. It doesnt matter what type of fluid you need. Its better/suited for any trans made today. If you have internal seals hardened it will re-juvenate them worth a shot. Replacing/rebuilding your trans is worth more than the car probably.
i had the trans completely flushed at 80,000 miles

the car currently at 92,000 had the trans looked at by a shop and they said transmission had nothing wrong with it but then again they could be wrong
Tim.Rich92 is offline  
post #10 of 22 Old 3 Weeks Ago
Senior Member
 
Gaijinn's Avatar
 
Join Date: Jul 2017
Location: Indianapolis In
Posts: 768
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 241 Post(s)

Which trans do you have ? If you have a 8AT. You cant "flush" them.

With any AT 60,000 change is wise. 45,000 for severe duty. Severe duty includes any tune/a turbo/auto X etc.

Here we go again !
Gaijinn is offline  
post #11 of 22 Old 3 Weeks Ago Thread Starter
Junior Member
 
Join Date: Jul 2019
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
(Thread Starter)

Quote:
Originally Posted by Gaijinn View Post
Which trans do you have ? If you have a 8AT. You cant "flush" them.

With any AT 60,000 change is wise. 45,000 for severe duty. Severe duty includes any tune/a turbo/auto X etc.
ZF Trans 6Speed A/T
Tim.Rich92 is offline  
post #12 of 22 Old 3 Weeks Ago
Senior Member
 
AKGC's Avatar
 
Join Date: Jul 2009
Posts: 14,777
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 746 Post(s)

Quote:
Originally Posted by Gaijinn View Post
So the above is symptomatic of a high mileage trans where the fluid was never maintained. How many miles on the car. How many miles since or even "if" you changed the trans fluid. Which trans do you have.
That would be the case IF something is slipping, but that would be under load, not cruising.

The only thing in a auto trans designed to "slip" like that is the torque converter.

The clutch packs are designed to slip a little, but thats only "during shifts", not cruising. If it starts slipping like suggested, then it's usually means you're going to lose a gear.



It could be the timing chain throwing off valve timing, because of normal wear, making it feel like it's struggling. If it is, then I HIGHly suggest changing the chains, unless you like bricking your motor.
AKGC is online now  
post #13 of 22 Old 3 Weeks Ago
br2
Bill
 
Join Date: Dec 2014
Location: San Antonio
Posts: 539
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 142 Post(s)

first thing i thot was failing trans... i'd have the dealer check it out.
br2 is offline  
post #14 of 22 Old 3 Weeks Ago
Senior Member
 
AKGC's Avatar
 
Join Date: Jul 2009
Posts: 14,777
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 746 Post(s)

Quote:
Originally Posted by Tim.Rich92 View Post
i had the trans completely flushed at 80,000 miles

the car currently at 92,000 had the trans looked at by a shop and they said transmission had nothing wrong with it but then again they could be wrong
Now, was it flushed because of the issue, or was it done just because?

What method did they use to flush it?
What ATF did they use to flush it with?

How it's flushed and what fluid they used, can cause all sorts of issues.
AKGC is online now  
post #15 of 22 Old 3 Weeks Ago
Senior Member
 
Gaijinn's Avatar
 
Join Date: Jul 2017
Location: Indianapolis In
Posts: 768
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 241 Post(s)

Quote:
Originally Posted by AKGC View Post
Now, was it flushed because of the issue, or was it done just because?

What method did they use to flush it?
What ATF did they use to flush it with?

How it's flushed and what fluid they used, can cause all sorts of issues.

Its a ZF, albeit a 6speed. I guarantee the shop did it wrong,...you dont "flush" a ZF. None of them. Im sure they used some janky AC Delco crap fluid too. Flush literally means and incomplete/partial drain/fill to me.

Some know it alls on here think you can gravity drain/fill these ZF's,...or Hyuandai reverse engineered ZFs. You cant. I know for a fact they are supposed to be pressure evacuated,...then pressure filled. Then warmed,...measured,...filll,..warmed, driven, re-measured. Well that the right way at least.The guy who did mine says it pretty involved, but that internal air pockets in these types of trans can be very problematic.

I would find a bigger Hyundai dealer to do the trans again. Or I'd find a BMW or Merecedes specialist center who are familiar with ZF in general.

Here we go again !

Last edited by Gaijinn; 3 Weeks Ago at 11:27 AM.
Gaijinn is offline  
post #16 of 22 Old 3 Weeks Ago
Senior Member
 
AKGC's Avatar
 
Join Date: Jul 2009
Posts: 14,777
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 746 Post(s)

Quote:
Originally Posted by Gaijinn View Post
Its a ZF, albeit a 6speed. I guarantee the shop did it wrong,...you dont "flush" a ZF. None of them. Im sure they used some janky AC Delco crap fluid too. Flush literally means and incomplete/partial drain/fill to me.

Some know it alls on here think you can gravity drain/fill these ZF's,...or Hyuandai reverse engineered ZFs. You cant. I know for a fact they are supposed to be pressure evacuated,...then pressure filled. Then warmed,...measured,...filll,..warmed, driven, re-measured. Well that the right way at least.The guy who did mine says it pretty involved, but that internal air pockets in these types of trans can be very problematic.

I would find a bigger Hyundai dealer to do the trans again. Or I'd find a BMW or Merecedes specialist center who are familiar with ZF in general.
What you described is not a flush. That's just a drain. With a drain and filter change there is still a lot of ATF in the torque converter.

And in my experience a pressure flush causes all sorts of shifting issues with the valve body, even if the proper ATF is used.

The way I do it is; fill and drain from the trans cooler lines going to the radiator, until the ATF runs out clean, then remove the top "drain" plug to make sure that the ATF level is correct.
The plus side of this is that you don't have to open the transmission, the down side is that you can't change the filter unless you open it up.
AKGC is online now  
post #17 of 22 Old 3 Weeks Ago
Senior Member
 
Gaijinn's Avatar
 
Join Date: Jul 2017
Location: Indianapolis In
Posts: 768
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 241 Post(s)

Quote:
Originally Posted by AKGC View Post
What you described is not a flush. That's just a drain. With a drain and filter change there is still a lot of ATF in the torque converter.

And in my experience a pressure flush causes all sorts of shifting issues with the valve body, even if the proper ATF is used.

The way I do it is; fill and drain from the trans cooler lines going to the radiator, until the ATF runs out clean, then remove the top "drain" plug to make sure that the ATF level is correct.
The plus side of this is that you don't have to open the transmission, the down side is that you can't change the filter unless you open it up.
Wrong,... a pressure removal pushes everything out. The delaer where mine was done has special equipment for these Genesis (coupes and sedans) trans. It removes all fluid in its entirety. They then match the volume with original specs, and then begin their fine tune leveling. It takes 2 or three hours.What your saying makes no sense at all,...drain as in gravity,..does not suffice. Yes, if your a DIY an attempt the pressure removal you probably will have problems.

I always encourage owners of 8ATs to have this done by factory trained Genesis guys. (and use CERMA ATF). My next change will be in 25K miles.

***If you are refferring to a 6 spd with a trans filter that would be all the more reason to have the pros do it. I dont know if the 8AT has a filter but if it does, They replace/clean it with their service Im sure.

Here we go again !

Last edited by Gaijinn; 3 Weeks Ago at 01:52 PM.
Gaijinn is offline  
post #18 of 22 Old 3 Weeks Ago
Senior Member
 
AKGC's Avatar
 
Join Date: Jul 2009
Posts: 14,777
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 746 Post(s)

Quote:
Originally Posted by Gaijinn View Post
Wrong,... a pressure removal pushes everything out. The delaer where mine was done has special equipment for these Genesis (coupes and sedans) trans. It removes all fluid in its entirety. They then match the volume with original specs, and then begin their fine tune leveling. It takes 2 or three hours.What your saying makes no sense at all,...drain as in gravity,..does not suffice. Yes, if your a DIY an attempt the pressure removal you probably will have problems.

I always encourage owners of 8ATs to have this done by factory trained Genesis guys. (and use CERMA ATF). My next change will be in 25K miles.

***If you are refferring to a 6 spd with a trans filter that would be all the more reason to have the pros do it. I dont know if the 8AT has a filter but if it does, They replace/clean it with their service Im sure.
What "I" said "I" do via the transcooler lines, is have 2 buckets. one with new ATF and the other being empty. I run the engine so the transmission pump can suck in clean ATF, and puke out the old ATF. You visually tell when the old ATF is cleared out. There is NO WAY to remove the ATF out of the torque converter besides running the transmission pump (basically running the engine), or removing the torque converter and tipping it over to drain it, even then there is still a a substantial about of ATF in there when draining the torque converter manually.

The problem with power flushing, at the pressures and method used at your typical "budget service" places. Their machines usually have some sort of auto back flow features that screws up the check valves in the valve body, and wouldn't know what pressures to run their machine at.
Red Raspberry likes this.

Last edited by AKGC; 3 Weeks Ago at 04:07 PM.
AKGC is online now  
post #19 of 22 Old 3 Weeks Ago
Senior Member
 
Gaijinn's Avatar
 
Join Date: Jul 2017
Location: Indianapolis In
Posts: 768
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 241 Post(s)

I agree with you latter statement. Thats why I encourage it being done by specific ZF fluent organizations. I didnt watch the whole procedure, but I do know that every stinking ounce of old fluid was removed.

In theory your way would work,..its just youd better get the volumes just right !? LOL.

Here we go again !
Gaijinn is offline  
post #20 of 22 Old 2 Weeks Ago
Member
 
Join Date: Dec 2012
Posts: 65
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)

you know what i don't understand ? Why are you changing the fluid to start with ? what maintenance schedule are you using.? My 2013 manual says after the 150,000 mark automatic transmission fluid-No checks No service required (page7-19) It does state if operated under severe usage unpaved gravel or salt sandy roads towing as a patrol car or over 106mph replace at 60,000 miles page 7-22 states again automatic transmission should not be checked under normal usage conditions. I don't think most people know how easy it is to contaminate the transmission. If it is opened up (pan off or whatever) dirt just a couple grains of sand, gets in the valve body & sticks under a check valve ball guess what can happen. There is a reason they are sealed & a reason when you see a professional overhaul buiz. its a clean room. ever-body welcome to their own beliefs, this is just mine (& hundai maintenance)
jpweig is offline  
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Hyundai Genesis Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome