Key fob won’t not read - Hyundai Genesis Forum
 
LinkBack Thread Tools
post #1 of 5 Old 1 Week Ago Thread Starter
Junior Member
 
Join Date: Nov 2019
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Key fob won’t not read

So this has been an on going problem for 2 years. The key fob will unlock the doors lights will come on air will come on etc but car will not start. Key fob battery’s are brand new, car battery has been tested and is good, starter was replaced a year ago and is also good. Car has done this before and one day you jump in and it fires right up will run for months on end and then the same thing won’t start from anywhere too a few minutes to a week and then starts again . Also anytime it rains or I hand wash the car the alarm makes an annoying beeping noise for a while after it happens . This time I went through a car was and the car was running fine as soon as I turn it off now it’s been like 2 weeks without the car starting . Please help thank you!
Shreddedmtfr is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 1 Week Ago
I'd rather do it myself
 
Red Raspberry's Avatar
 
Join Date: Aug 2009
Location: Flat lands of Illinois
Posts: 18,245
Mentioned: 23 Post(s)
Tagged: 1 Thread(s)
Quoted: 3 Post(s)
Garage

Where is the beeping coming from?

2010 Red 2.0L track

Quote:
If the Pharaohs had duct tape, the Sphinx would still have a nose...."
Red Raspberry is online now  
post #3 of 5 Old 1 Week Ago
Senior Member
 
AKGC's Avatar
 
Join Date: Jul 2009
Posts: 14,787
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 749 Post(s)

if its smart key start then hold down the start button for like 30 sec. If it starts up without pressing any of the pedals, then it's likely the clutch or brake switch.

the switches are known to go bad.
AKGC is offline  
 
post #4 of 5 Old 1 Week Ago
Yoda
 
GC Rider's Avatar
 
Join Date: Feb 2016
Location: In a van; down by the river; in the HOTx
Posts: 126
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 38 Post(s)
Garage

Quote:
Originally Posted by AKGC View Post
if its smart key start then hold down the start button for like 30 sec. If it starts up without pressing any of the pedals, then it's likely the clutch or brake switch.

the switches are known to go bad.
The most likely culprit right here. I had to replace the brake switch twice. Luckily the dealership did it for free both times as this is a known issue. Good luck!

Suppose you were an idiot. And suppose you were a member of Congress. But I repeat myself.
- Mark Twain
GC Rider is offline  
post #5 of 5 Old 1 Week Ago
Junior Member
 
Join Date: Oct 2012
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Yeah sounds like the brake switch. There was a TSB on these going bad so the dealer should do it for free. Next time it happens, find someone to look at the back of the car to see if the brake lights light up when the brake is depressed. If they don’t light up it’s definitely the brake switch. A broken brake switch is super dangerous because it means the brake lights don’t work when you’re braking. Obviously not ideal when hard stopping on the highway.
GisforGenesis is offline  
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Hyundai Genesis Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome