Dash won't light but unlock/lock work? HELP!! - Hyundai Genesis Forum
 
LinkBack Thread Tools
post #1 of 8 Old 07-23-2012 Thread Starter
Senior Member
 
bren5279's Avatar
 
Join Date: Jan 2011
Posts: 471
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
(Thread Starter)
Electrical problem: Dash won't light but unlock/lock work? HELP!! $200 Reward!!!

NOTE: I will give $200 to whoever can lead me to the solution for this problem:

Car:2010 manual 2.0T with Push button start (proximity smart key)

Symptoms:
Key fob works (unlock/lock/alarm/trunk pop)
dash won't light anything but door open light
push button blinks amber when pushed
Key fob charging port led does not light (Is it supposed to?)
nothing happens when holding button for 10 seconds with fob in receiver
ESCL is locked, and can't seem to do anything to unlock it

What I know / have done:
Ive just replaced: body control module, Power distribution module, and now Smart key module with paired smart key and immobilizer/ecu
Ive checked the fuses, Unless I missed one all are fine.
I can manually jump the relays to get everything to light up, but button still blinks amber.
Took it to hyundai: they couldn't program a new key because they can connect to the body control module but nothing beyond it unless I jump the relays manually.


The only thing I haven't replaced at this point is the push button itself which Im tempted to do now, even though I would think it would be a controlling unit that would control the amber blinking....?


Im absolutely desperate, Ive already replaced basically every electric unit possible now... If someone can tell me what wires to jump to bypass something or do something to get things to work or some trick I will give them 200$ if it works.




Ive replaced the Immobilizer/ecu and keyless unit as a pair with a matching key, the body control module, and the power distribution module.


What unit does the push button tell to turn on the electronics?

Last edited by bren5279; 07-23-2012 at 06:54 PM.
bren5279 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 07-23-2012
...+.....+...+..+.++
 
GcoupeS's Avatar
 
Join Date: Feb 2012
Posts: 858
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Garage

Is it auto or manual?

if manual, is it in netural with the clutch pressed?

if auto, are you pressing the brake?

i dont have the smart key but from what i have seen on other cars you can turn the acc power on without having your foot on the pedals. not sure if the genesis works that way.

have you changed the battery in your remote?

2013 2.0T 8-Speed Shoreline Drive Blue
GcoupeS is offline  
post #3 of 8 Old 07-23-2012
...+.....+...+..+.++
 
GcoupeS's Avatar
 
Join Date: Feb 2012
Posts: 858
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Garage

sent you a PM.

2013 2.0T 8-Speed Shoreline Drive Blue
GcoupeS is offline  
 
post #4 of 8 Old 07-24-2012 Thread Starter
Senior Member
 
bren5279's Avatar
 
Join Date: Jan 2011
Posts: 471
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
(Thread Starter)

Anyone!?
bren5279 is offline  
post #5 of 8 Old 05-06-2014
Junior Member
 
Join Date: Jan 2011
Posts: 21
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

did you find the solution i am having the same issue
sandhurno1 is offline  
post #6 of 8 Old 05-12-2014 Thread Starter
Senior Member
 
bren5279's Avatar
 
Join Date: Jan 2011
Posts: 471
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
(Thread Starter)

nope, bought a different car
bren5279 is offline  
post #7 of 8 Old 05-12-2014
Junior Member
 
Join Date: Jan 2011
Posts: 21
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Finally the dealer figured it out today. It was the steering wheel ignition lock sensor. According to them an aftermarket alarm made it go nuts.
sandhurno1 is offline  
post #8 of 8 Old 08-17-2019
Junior Member
 
Join Date: Feb 2019
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)

I have a 2010 Gen Coupe 3.8 Automatic. I don't have power to the centerconsole at all. The only lights that come on are the Hazards and door open icon as well as the key not in car icon. When I press the brake and push the button, it blinks red 5 times and does nothing. I've replaced everything you have. I am still havin the same problem.
No accesories.
No ac.
No radio.
No start.
Idk what to do.
SetEdenOnFire is offline  
Sponsored Links
Advertisement
 
Reply

Related Threads
Thread Thread Starter Forum Replies Last Post
Dash won't light? bren5279 Interior 2008-2012 42 03-20-2018 04:57 PM
Trunk won't lock Jcorey2 Exterior 2008-2012 5 02-21-2015 01:36 PM
Lock and unlock button problems. Please help Boriqua0703 Electrical & Wiring 2008-2012 1 02-08-2012 05:35 PM
Exterior Lock/Unlock Button doczaius Exterior 2008-2012 3 01-29-2010 03:56 PM


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Hyundai Genesis Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome