Burning oil anyone? - Page 3 - Hyundai Genesis Forum
Reply
 
LinkBack Thread Tools
post #41 of 47 Old 05-23-2016
Advenio Pariter
 
TsukubaRed_PA's Avatar
 
Join Date: Apr 2011
Location: SE Pennsylvania
Posts: 3,829
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 387 Post(s)
Garage

My engine does not burn any appreciable amount during the duration of my oil changes (4k miles).

2011 Base 2.0T, 5AT
Trunk Lip Spoiler
Fog Lights
Rear Wing Badge / Blackened Front Logo
Garage Line 22mm Rear Sway Bar
Uniq Rigid Collars
Saikou Michi Catch Can - Intake
JEGS Oil Separator - Turbo
Dynamat Hoodliner
Infinity Kappa 62.11 Door and Rear Speakers
Warranty: New Tails
Non-maintenance: 2 idler pullys


2013 Elantra GT, 6AT (hers)

-- previous rides --
Salsa Red 2004 Vibe GT 6MT
Dark Red Pearl 1991 Stealth R/T 5MT
TsukubaRed_PA is offline  
Sponsored Links
Advertisement
 
post #42 of 47 Old 05-23-2016
Senior Member
 
13Track's Avatar
 
Join Date: Jul 2015
Location: US
Posts: 183
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 54 Post(s)

What I previously thought was oil burn turned out to be a leaking drain plug that was slight enough to not drip on the ground with the splash guards kept off. No oil burn detected ever since the fix. No tiny pieces of metal in the pan as previously found either. Latest UOA showed good stats too so all is well so far.
13Track is offline  
post #43 of 47 Old 10-10-2018
Junior Member
 
TheGunXpo's Avatar
 
Join Date: Oct 2016
Location: Toronto Ontario T.D.O.T
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

I've been changing my oil every 8k sometimes earlier, I'm using Royal Purple 5W20 and i've noticed the level is low to almost on the First Dot on the dipstick. i don't have any leaks but i've also noticed that when i remove the Oil cap there is a bit of milky oil around the cap. I have a 2010 3.8 Gt with 126K Anyone having the same issues?
TheGunXpo is offline  
 
post #44 of 47 Old 10-11-2018
br2
Bill
 
Join Date: Dec 2014
Location: San Antonio
Posts: 496
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 133 Post(s)

hopefully just condensation. if it were the head you'd see way worse than that.
going on 9 years old? some leakage or burning might be expected.
br2 is offline  
post #45 of 47 Old 10-11-2018
I'd rather do it myself
 
Red Raspberry's Avatar
 
Join Date: Aug 2009
Location: Flat lands of Illinois
Posts: 18,006
Mentioned: 18 Post(s)
Tagged: 1 Thread(s)
Quoted: 3 Post(s)
Garage

Make sure the PCV valve is working OK.

2010 Red 2.0L track

Quote:
If the Pharaohs had duct tape, the Sphinx would still have a nose...."
Red Raspberry is offline  
post #46 of 47 Old 10-11-2018
Advenio Pariter
 
TsukubaRed_PA's Avatar
 
Join Date: Apr 2011
Location: SE Pennsylvania
Posts: 3,829
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 387 Post(s)
Garage

Milky oil suggests water in the oil. Are you making short trips? How does the coolant look? Any oil in it? I have over 110k miles on a 2.0T and I do not use any significant oil between oil changes. It sits on the full mark.

2011 Base 2.0T, 5AT
Trunk Lip Spoiler
Fog Lights
Rear Wing Badge / Blackened Front Logo
Garage Line 22mm Rear Sway Bar
Uniq Rigid Collars
Saikou Michi Catch Can - Intake
JEGS Oil Separator - Turbo
Dynamat Hoodliner
Infinity Kappa 62.11 Door and Rear Speakers
Warranty: New Tails
Non-maintenance: 2 idler pullys


2013 Elantra GT, 6AT (hers)

-- previous rides --
Salsa Red 2004 Vibe GT 6MT
Dark Red Pearl 1991 Stealth R/T 5MT
TsukubaRed_PA is offline  
post #47 of 47 Old 10-12-2018
I'd rather do it myself
 
Red Raspberry's Avatar
 
Join Date: Aug 2009
Location: Flat lands of Illinois
Posts: 18,006
Mentioned: 18 Post(s)
Tagged: 1 Thread(s)
Quoted: 3 Post(s)
Garage

I'm at +95k miles and my engine does not burn any oil at all. In fact due to fuel dilution it makes oil....

2010 Red 2.0L track

Quote:
If the Pharaohs had duct tape, the Sphinx would still have a nose...."
Red Raspberry is offline  
Sponsored Links
Advertisement
 
Reply

Related Threads
Thread Thread Starter Forum Replies Last Post
[How-To] Build Your 3.8 (Upgrade path V2) titan2782 3.8 V6 Discussion 2013 and up 122 05-28-2019 07:28 AM
DIY oil changes and warranty Chinaman_Chong General Discussion 21 07-07-2013 03:39 AM
engine oil 10w40 recommended from hyundai DarKYiNe 2.0T Discussion 2008-2012 40 02-22-2012 05:02 PM
Enging burning oil? Tbonesteak Engine 2 07-11-2009 01:17 PM


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Hyundai Genesis Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome