2013. 2.0T Boost but no Power - Hyundai Genesis Forum
 
LinkBack Thread Tools
post #1 of 3 Old 06-03-2018 Thread Starter
Junior Member
 
Join Date: Jun 2018
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
2013. 2.0T Boost but no Power

I have a 2013 Genesis Coupe 2.0T.
93k miles
HKS SRI
Forge Bov
Sraight Exhaust cat-back

Turbo first went out at 40k miles, replaced it with no problems.

Turbo goes out again at 93k miles, replaced turbo and EWGA.
Encountered problems:

Turbo spools and produces boost, however will not translate to power and vehicle acts as if it does not want to shift.

I could find no boost leak at all.
Upon removing the previous turbo it was noted that the back turbine was sheared off and may possibly be hung up in catalytic converter.
Replaced turbo started car up runs for a few mins and it dies, motor locks.

Uncapped header, car starts runs fine with exception of aforementioned boost-power issue.

Car runs at WoT then dies. Oil temp is more than normal.

Adjusted waste gate due to much boost being created.

Very little boost is being translated to power.

CEL are P0014 for bank 1 & 2, P2562

I have checked wiring and Everything i could possibly think of. Can anyone shed any light on said issue?
Thanks.
Stephen
Smcclellan is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 06-04-2018
I'd rather do it myself
 
Red Raspberry's Avatar
 
Join Date: Aug 2009
Location: Flat lands of Illinois
Posts: 18,231
Mentioned: 21 Post(s)
Tagged: 1 Thread(s)
Quoted: 3 Post(s)
Garage

If the exhaust was blocked that would raise the oil temp and produce performance problems.

2010 Red 2.0L track

Quote:
If the Pharaohs had duct tape, the Sphinx would still have a nose...."
Red Raspberry is offline  
post #3 of 3 Old 06-04-2018 Thread Starter
Junior Member
 
Join Date: Jun 2018
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)

Quote:
Originally Posted by Red Raspberry View Post
If the exhaust was blocked that would raise the oil temp and produce performance problems.
It is uncapped. I'm currently at a loss with this car. I can't figure out what else could be wrong with it and quite frankly, I'm sick of working on it.
Smcclellan is offline  
Sponsored Links
Advertisement
 
Reply

Related Threads
Thread Thread Starter Forum Replies Last Post
Jumpy power delivery, boost leak? GhengisT 2.0T Discussion 2013 and up 18 09-26-2016 01:20 PM
Power Boost? agibbons31 3.8 V6 Discussion 2008-2012 19 07-10-2012 02:00 PM
GenCoupe Power? Boost? Tune? HELP!?!?! jadyer 2.0T Discussion 2008-2012 4 02-11-2011 04:44 PM


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Hyundai Genesis Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome