2015 3.8 R Spec Grinding Noise - Hyundai Genesis Forum
 
LinkBack Thread Tools
post #1 of 3 Old 05-16-2019 Thread Starter
Junior Member
 
Join Date: May 2019
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
(Thread Starter)

Hello All! Recently bought a used 2015 R Spec. Has just under 100,000 miles. The engine just recently started making a ticking/grinding/metallic noise. I took it to my mechanic 2 times and they could not figure out what it is. No computer codes and car seems to drive ok though I feel like it is slightly under powered. Not really kicking like usual between 3 and 5000 rpms like when I bought it. It is worse when it is hot and thicker oil plus seafoam did seem to make noise disapate. Mechanic said his guess is carbon build up but just a guess. O have attached a video with noise and again comes and goes. Any ideas ??

**Update
I have taken it to 2 mechanics now. Still no computer readings indicating issues. Checked timing and that was fine. Changed spark plugs, oil, oil filter and no change. Noise getting slowly and subtly worse. Car is extremely underpowered. Did a seafoam treatment. Seemed to help for a little but went away.

Both mechanics say noise is coming from engine, pistons or cylinders. Will have to be taken completely apart to diagnose. Any last suggestions?? Can you even get a 2015 3.8 v6 engine if the other is junked ??

Last edited by arampro; 06-25-2019 at 05:50 PM.
arampro is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 05-16-2019
Senior Member
 
AKGC's Avatar
 
Join Date: Jul 2009
Posts: 14,728
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 728 Post(s)

Quote:
Originally Posted by arampro View Post
Hello All! Recently bought a used 2015 R Spec. Has just under 100,000 miles. The engine just recently started making a ticking/grinding/metallic noise. I took it to my mechanic 2 times and they could not figure out what it is. No computer codes and car seems to drive ok though I feel like it is slightly under powered. Not really kicking like usual between 3 and 5000 rpms like when I bought it. It is worse when it is hot and thicker oil plus seafoam did seem to make noise disapate. Mechanic said his guess is carbon build up but just a guess. O have attached a video with noise and again comes and goes. Any ideas ??
thats a picture, not a video.

direct injection has an inherent issue with carbon buildup on top of the valves, in the intake port, it could be that.
Either that, or the timing chain needs to be replaced, with that many miles on it.

Both are easy for a mechanic to check, but a PITA to replace/clean.

Have your mechanic check valve timing, as it's one of those things that can junk a motor if it goes too much out of timing. Have him change the chain, if it it out of timing, because pretty sure you don't want to deal with doing it yourself and doing things incorrectly can junk the motor.

Checking the top of the valves is easy, just remove the intake manifold and look into the intake ports of the head. you can clean the yourself. plenty of youtube vids on it.
AKGC is offline  
post #3 of 3 Old 05-17-2019 Thread Starter
Junior Member
 
Join Date: May 2019
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
(Thread Starter)
arampro is offline  
Sponsored Links
Advertisement
 
Reply

Related Threads
Thread Thread Starter Forum Replies Last Post
Official Texas Roll Call - *Updated 12/28/2012* WildBill Texas 115 05-04-2018 05:26 AM


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Hyundai Genesis Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome