2016 Genesis Coupe starts then immediately shuts off. New Keys... - Hyundai Genesis Forum
 
LinkBack Thread Tools
post #1 of 6 Old 09-28-2019 Thread Starter
Junior Member
 
Join Date: Sep 2019
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
2016 Genesis Coupe starts then immediately shuts off. New Keys...

I bought a 2016 Genesis Coupe 3.8 Ultimate/R-Spec from a salvage auction. Car had no keys. Bought 2 new smart keys from dealer and had a locksmith come out to my house for programming last week. He did it, but at the time the belt was off and other things were in the way so we cranked it over for half a second and called it done. Today all ready to go I went to start it, it starts then shuts off. Wont restart until you turn the car off, wait a few seconds and try again. If you just hit the start button again and not power it down completely it never even fires. Same thing over and over. It has spark consistently so it must be a fuel issue. The locksmith swears if it cranks over his job is correct and I must have an electrical problem somewhere. According to what I read in an older service manual the fuel system is regulated by the immobilizer system. Anyone had this problem? I am about to tow it to a shop or even a local dealer to see whats up. I am 300 deep in this locksmith but maybe he is right, something else is wrong??? Any help will be appreciated!!!

Matt Babel
bigblock81 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 09-29-2019
br2
Bill
 
Join Date: Dec 2014
Location: San Antonio
Posts: 539
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 142 Post(s)

i thought the dealer had to program it... just guessing.
br2 is offline  
post #3 of 6 Old 09-29-2019 Thread Starter
Junior Member
 
Join Date: Sep 2019
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)

Quote:
Originally Posted by br2 View Post
i thought the dealer had to program it... just guessing.
The locksmith got the pin code from Hyundai using my vin and supposedly programmed it. I have a friend with a snap-on edge scanner. Im trying to get him out to the car so we can see if the fuel is enabled and to check pressure. These gdi cars have two fuel pumps. I believe they shut down the high pressure one on the engine if there is a problem. Wanted to see if this problem is common, I guess not.
bigblock81 is offline  
 
post #4 of 6 Old 09-30-2019
Senior Member
 
Join Date: Apr 2018
Posts: 153
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 42 Post(s)

Maybe connect the fuel pumps to secondary power supply (jsut make sure to NOT fry your ECU doing this and chcek if you got injectors firing ?
Or beter yet get an osciloscope and chcek if power is going to Pumps and to injectiors
Pchelka is online now  
post #5 of 6 Old 09-30-2019
br2
Bill
 
Join Date: Dec 2014
Location: San Antonio
Posts: 539
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 142 Post(s)

my primary pump failed a few years ago and it still ran in limp mode.
a specialist in Gc's may save you money over trial & error.
br2 is offline  
post #6 of 6 Old 09-30-2019
Senior Member
 
AKGC's Avatar
 
Join Date: Jul 2009
Posts: 14,777
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 746 Post(s)

salvaged?...

Did you pull codes? if it was an issue with the keys it would give you a code related to keys/immobilizer.
Since you said that the car starts, I doubt that it's that.
AKGC is online now  
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Hyundai Genesis Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome