What did you do to your Genesis Coupe today? - Page 499 - Hyundai Genesis Forum
 4666Likes
Reply
 
LinkBack Thread Tools
post #9961 of 10005 Old 3 Weeks Ago
Junior Member
 
Join Date: Sep 2019
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)

Quote:
Originally Posted by Yetisis View Post
Yeeeeeah I’ve been teasing myself with the idea of a turbo kit on my ‘15 3.8. Remnant Performance just started carrying one at a really good price compared to some of the other prefab kits we’ve had available and I live super close to their shop but when you look at the “reliable” and “safe” amounts of boost you can run with stock internals it really makes you question it, and it’s my only car and probably will be for a loooong time

I looked at their kit as well, pricing is right! I -believe- you can get away with 5psi/6 tops on boost before you need internals done as well (way too pricey). Others have mentioned adding an oil cooler and meth kit, plus tuning/install and you are ballpark 7K. Ive boosted mustangs/vettes and camaros - but never a Korean 6 cyl. Just my experience, if its your DD, dont boost...if its a weekend racer/fun car, then go for it. Ive regretted 2 of the 3 supercharger additions, those were terrible DDs...was thinking turbos at least dont make driving the low RPMs in a parking lot an adventure I dont want.

If you pull the trigger, I would love to hear your experience with their kit!
gen-x-me is offline  
Sponsored Links
Advertisement
 
post #9962 of 10005 Old 3 Weeks Ago
I'd rather do it myself
 
Red Raspberry's Avatar
 
Join Date: Aug 2009
Location: Flat lands of Illinois
Posts: 18,248
Mentioned: 23 Post(s)
Tagged: 1 Thread(s)
Quoted: 3 Post(s)
Garage

Quote:
Originally Posted by GC Rider View Post
Took out the spare to check the pressure, and it was at 23 PSI. Got the bicycle pump out an jacked it back to 60 PSI. My workout is done for the day
I had the tread separate on my spare and it had never been used. Only way I caught it was I took it out to check the pressure and I could see the distortion.


2010 Red 2.0L track

Quote:
If the Pharaohs had duct tape, the Sphinx would still have a nose...."
Red Raspberry is offline  
post #9963 of 10005 Old 3 Weeks Ago
Senior Member
 
andbudzi's Avatar
 
Join Date: Aug 2010
Location: muskegon, MI
Posts: 1,685
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 482 Post(s)

Quote:
Originally Posted by gen-x-me View Post
I looked at their kit as well, pricing is right! I -believe- you can get away with 5psi/6 tops on boost before you need internals done as well (way too pricey). Others have mentioned adding an oil cooler and meth kit, plus tuning/install and you are ballpark 7K. Ive boosted mustangs/vettes and camaros - but never a Korean 6 cyl. Just my experience, if its your DD, dont boost...if its a weekend racer/fun car, then go for it. Ive regretted 2 of the 3 supercharger additions, those were terrible DDs...was thinking turbos at least dont make driving the low RPMs in a parking lot an adventure I dont want.

If you pull the trigger, I would love to hear your experience with their kit!
Remnant kit comes with an oil cooler....it comes with all extras needed to run it safe at 6psi.
When all set a done you are looking at $4,500 for a kit, gauges and sensors, custom tune.

Realiability is all in the tune. Turbo kits comes with a can tune and tend to pop engines, while with a good custom tune you can run 9psi without math for 3 year and still no issues. Keep it at 6 and tune WITH Alphaspeed -your only reliable option.

Sent from my SM-G950U using Tapatalk

13 Genesis Track - MagnaFlow exhaust, test pipes, midpipes, custom CAI, LW Pulleys, Koning Oversteer rims, Stance coilovers, carbon fiber grill, front lip.

06 Outback 5spd - Winter muel.
14 Explorer 3.5 TT - Kids hauler with 18psi of punch.
03 Tiburon V6 custom T4E turbo - Ex mistress ...
andbudzi is offline  
 
post #9964 of 10005 Old 3 Weeks Ago
I'd rather do it myself
 
Red Raspberry's Avatar
 
Join Date: Aug 2009
Location: Flat lands of Illinois
Posts: 18,248
Mentioned: 23 Post(s)
Tagged: 1 Thread(s)
Quoted: 3 Post(s)
Garage

Put 10k miles on my Stop Tech pads this year; 309.10530 rear 309.10010 front. The EBC yellows are better. STs are dirtier and don't stop quite as well. Neither has any application problems or noise though on my car.
Odelagt likes this.

2010 Red 2.0L track

Quote:
If the Pharaohs had duct tape, the Sphinx would still have a nose...."
Red Raspberry is offline  
post #9965 of 10005 Old 3 Weeks Ago
Junior Member
 
Jroddempsey's Avatar
 
Join Date: Oct 2019
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Bein doing tune research for hours today😂😭
Jroddempsey is offline  
post #9966 of 10005 Old 3 Weeks Ago
Junior Member
 
Join Date: Oct 2019
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

I got gas.
hollysheepsht likes this.
sethrd is offline  
post #9967 of 10005 Old 3 Weeks Ago
Junior Member
 
Yetisis's Avatar
 
Join Date: Jan 2016
Posts: 23
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)

Finally got the wiring cleaned up and finished my head unit install. Can’t believe how nice the fit is on the metra dash kit. Tried to wrap it a few times in carbon fiber, kept buying cheap vinyl and getting frustrated and eventually threw it in the car naked and black. I think it looks better clean than if I was good with vinyl.What did you do to your Genesis Coupe today?-afe31f57-8d5e-47a7-b660-53a6c72989c2_1572400633566.jpeg
Yetisis is offline  
post #9968 of 10005 Old 3 Weeks Ago
In Charge of Snacks
 
Odelagt's Avatar
 
Join Date: Nov 2010
Location: Orange County, CA(We're broke, too!!!)
Posts: 2,052
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 239 Post(s)

Quote:
Originally Posted by Odelagt View Post
Ok, went back in this morning(instead of going to work) to maybe see what could be done by DSS or get the old two-piece shaft reinstalled. Finally got an acknowledgement from customer service saying that they're trying to figure out just what the sound is. Now in a holding pattern. . .
Ok, verdict is in... Driveshaft has to go back to North Carolina. Disappointing...
rthorniley likes this.

'11 3.8 R-spec
Now trying to build the impossible
Odelagt is offline  
post #9969 of 10005 Old 2 Weeks Ago
In Charge of Snacks
 
Odelagt's Avatar
 
Join Date: Nov 2010
Location: Orange County, CA(We're broke, too!!!)
Posts: 2,052
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 239 Post(s)

Ok, Installed OEM driveshaft with new giubos. I had them on before, but hadn't driven the car much. They are a vast improvement over the near 90k mile ones I tossed out a few months ago. Also did a rough alignment after having installed Feal coilovers. General impressions are good. My only niggle is that my New Tomei diff, mostly worn in, is even noisier that my out-of-spec stock setup. Race car parts, right? Oh well. Sure grips and rips nice now. Will package carbon driveshaft for return to DSS before the end of the week. Cheers!

'11 3.8 R-spec
Now trying to build the impossible
Odelagt is offline  
post #9970 of 10005 Old 2 Weeks Ago
Junior Member
 
Join Date: Oct 2019
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)

Kinda disappeared after that bleeder issue ;/. Anyway here's an update:

I bought the brembo bleeders from the dealer. I got 2 for 30 bucks. Since I'm paranoid and love my genny... I haven't touched it yet. I've been driving it pretty aggressively/normally and no leaks so woooo. If it starts leaking, I'll attempt the extraction ( and probably **** it up ( )

Today, I flushed the brake fluid with the other 7 bleeders and put some pentosin super dot 4. I'm going to take her for a wash later and clean the interior.

Next on my list is to buy some new tires which can handle 100mph + speeds, the car feels a bit wobbly when I hit 105 and I don't feel safe going any higher.

2013 3.8 Track - Silver
TROS Potent Booster
konrad is offline  
post #9971 of 10005 Old 2 Weeks Ago
I'd rather do it myself
 
Red Raspberry's Avatar
 
Join Date: Aug 2009
Location: Flat lands of Illinois
Posts: 18,248
Mentioned: 23 Post(s)
Tagged: 1 Thread(s)
Quoted: 3 Post(s)
Garage

Put some self adhesive 2" wide foil backed foam insulation on the front of the timing cover and wrapped around the oil filter. It's my anti-oil cooling idea. Seems in the winter I never get much above 170-180F with the oil.

I'll take it out and find out if it was a good idea tonight......

2010 Red 2.0L track

Quote:
If the Pharaohs had duct tape, the Sphinx would still have a nose...."
Red Raspberry is offline  
post #9972 of 10005 Old 2 Weeks Ago
Irresponsible Rookie
 
rthorniley's Avatar
 
Join Date: Jul 2018
Location: Olympia, WA
Posts: 69
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 23 Post(s)

Changed the oil in my 3.8 for winter storage.
Found aluminium particles / flakes in the oil filter cap...

No idea what from yet, looks like I will be tearing apart my engine this winter and inspecting everything.

I might start a rebuild thread to post updates if anyone is interested or has suggestions.
Odelagt likes this.

2010 3.8 Track,
Konig Hypergram, Nitto NT05, Trans Mount, Engine Leash, Diff Bushings, Intake, Powerstop Track Pads, Braided Brake Lines, Tien Lowering Springs, CAI, Thermal Gaskets, Stripped
rthorniley is offline  
Member
 
SVonhof's Avatar
 
Join Date: Jul 2019
Posts: 39
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Garage

Quote:
Originally Posted by SVonhof View Post
Got the car back today and so far, so good.

I asked the service rep what they did and he told me this story (I say this because I don't know how much to believe yet as it is my first experience with this dealer):
They found that the creak was there, so because they have 3 platinum level service tech's they have a pretty good relationship with the DSR's (dealer service reps?) and so they were able to get a special crimping and rivet tool. They took the hood and fenders off and drove it around and outside the dealer property with "chassis ears" to find the exact location of the issue. They found the two places and were able to crimp and rivet near the A pillar with no issues and no need for it to go to the body shop. They re-tested and found no noise. Waited until later in the day and re-tested with no issues.
He also said that the first gen body had bad welds and it was a bigger fix on those, but Hyundai did a better job on the BK2 bodies and when it is an issue, it is typically 2 or 3 places they need to do this.

They also had a note that the front bumper has been replaced or repainted and there is a cold air intake as well as an aftermarket HID headlight system (I didn't know about the HID headlights).
Had to call and set up another appointment. The creaks and squeaks are back. Will be bringing it in late next week.

Scott Vonhof
Casablanca White 2015 Genesis Ultimate Coupe
SVonhof is offline  
Senior Member
 
Join Date: Mar 2018
Posts: 116
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 25 Post(s)

I went through the same thing last year. Had to take my car back to the dealership several times to try to have the passenger side creak fixed. The service manager told me they used some special tool to “hammer” the broken spot welds back into place. Told me if it ever came back, they’d have to re-weld it. It was fine for a little while, until the noise ended up coming back, not as bad as before though. Haven’t taken the car back because it’s a lot of hassle, so I’ve just been dealing with it. Not too noticeable when I have music playing, though. Maybe next time I’m in, I can have em take another look at it. Hope you get it all figured out!
SynysterCoupe is offline  
Senior Member
 
Join Date: Mar 2018
Posts: 116
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 25 Post(s)

Duplicate post

Last edited by SynysterCoupe; 1 Week Ago at 10:27 AM. Reason: Duplicate post
SynysterCoupe is offline  
Member
 
yungblud's Avatar
 
Join Date: Jun 2017
Location: Southern Maryland
Posts: 44
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 27 Post(s)

Just got some all season tires. Shop did a good job mounting and balancing. But there was this god awful noise coming from the driver front wheel. Sounded like a mix between suspension rub, creaking, brake dragging, etc. Popped a jack under there and 2 lug nuts were loose, 1 was so loose I could spin it off with my fingers, and only 2 were actually tight. Itís sad when you have to double check a shops work. Now I donít know whether to raise hell or just let it go.


Sent from my iPhone using Tapatalk

2016 Genesis Coupe 3.8
yungblud is offline  
Senior Member
 
Join Date: Apr 2018
Posts: 158
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 44 Post(s)

Quote:
Originally Posted by yungblud View Post
Just got some all season tires. Shop did a good job mounting and balancing. But there was this god awful noise coming from the driver front wheel. Sounded like a mix between suspension rub, creaking, brake dragging, etc. Popped a jack under there and 2 lug nuts were loose, 1 was so loose I could spin it off with my fingers, and only 2 were actually tight. Itís sad when you have to double check a shops work. Now I donít know whether to raise hell or just let it go.


Sent from my iPhone using Tapatalk
Well, next time just watch them and for your own safety get a torque wrench and check your wheels. Where i live we have opposite problem - all shops use pneumatic guns to tighten the lug nuts and as usual they don't bother to set them to correct torque just max out the gun.

Fun thing is they always take a torque wrench and just 'click ' all they wheels for show (gun set to 150 Nm, torque wrench set to 100 nm... so yeah it will click...)
Pchelka is offline  
Senior Member
 
Join Date: Apr 2018
Posts: 158
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 44 Post(s)

FINALLY i got the timing chain job done, dealer ship held me up with long order times for parts but i got done:

- Timing chain / guides tensioner
- Oil pump chain, tensioner, guides
- MLA / valve clearances on exhaust side (intake was in specs)
- New water pump + gaskets

This would not take so long if it wouldn't be for bat parts availability
Started her up and up i have to say works a LOT better, 130 k Miles and the chain was still original and at least half a link longer than new one.
Red Raspberry and Odelagt like this.
Pchelka is offline  
Junior Member
 
Yetisis's Avatar
 
Join Date: Jan 2016
Posts: 23
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)

Haven’t been able to get my backup cam working after doing my head unit swap 6 weeks ago...checked the line for power, checked for correct video input God knows how many times, bought a second camera to troubleshoot with and finally got it to turn on yesterday morning...because it was the first time it was actually cold in the morning when I’ve started the car. After experimenting all day it turns out the head unit gets video signal when it’s cold and loses it as soon as the head unit warms up...sounds like a hairline crack in some soldered connection expanding and contracting, no? It’s not consistent with the outside temp, just the cabin temp. Now I have a warranty project to pursue for the weekend.

Any other suggestions on what it could be so I don’t have to drive around for a week with a hole in my dash? There are worse fates, but I’m all ears
Yetisis is offline  
Junior Member
 
Yetisis's Avatar
 
Join Date: Jan 2016
Posts: 23
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)

Quote:
Originally Posted by SynysterCoupe View Post
I went through the same thing last year. Had to take my car back to the dealership several times to try to have the passenger side creak fixed. The service manager told me they used some special tool to “hammer” the broken spot welds back into place. Told me if it ever came back, they’d have to re-weld it. It was fine for a little while, until the noise ended up coming back, not as bad as before though. Haven’t taken the car back because it’s a lot of hassle, so I’ve just been dealing with it. Not too noticeable when I have music playing, though. Maybe next time I’m in, I can have em take another look at it. Hope you get it all figured out!
Bk1 or bk2? I’ve heard so many people post on here about that same issue that it’s made me a complete hypochondriac about any passenger side noise I hear
Yetisis is offline  
Sponsored Links
Advertisement
 
Reply

Related Threads
Thread Thread Starter Forum Replies Last Post
[BTRcc] Sequence Genesis Coupe Spec GT and Spec RS Wings FREE SHIPPING!!! BTRcc Exterior 2 12-27-2012 03:00 PM
A very good article on our car's suspension sanengo Suspension 2008-2012 5 09-10-2012 03:16 PM
GReddy to Debut Performance Parts for Hyundai Genesis Coupe rntibbyboy Engine 23 10-19-2009 05:37 PM
Buschur Racing 2.0T Genesis Coupe *OFFICIAL PARTS RELEASE* Lineup & Pricing! [email protected] 2.0T Discussion 2008-2012 45 07-06-2009 07:33 AM
Motor Trend's First Test: 2010 Hyundai Genesis Coupe 3.8 Track McFly Media 20 03-03-2009 06:05 PM


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Hyundai Genesis Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome