Air conditioning - does yours work? - Hyundai Genesis Forum
View Poll Results: My air conditioning...
Works! Yes, it keeps me cool! 207 75.55%
Does not work! No, it makes me ANGRY! 67 24.45%
Voters: 274. You may not vote on this poll

 1Likes
Reply
 
LinkBack Thread Tools
post #1 of 169 Old 07-06-2009 Thread Starter
Senior Member
 
reneirwolf878's Avatar
 
Join Date: May 2009
Location: Northern Va
Posts: 2,407
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
(Thread Starter)
Air conditioning - does yours work?

Now, I know I've read somewhere here a few weeks ago about someone having the same problem. I tried searching "air conditioning" but I got nothing. I did see a thread in general discussion but it's a little off topic and no one answered the original poster's question.

So I figured I'd start a new thread and ask that no one tell me to suck it up and drive. I just paid for a new car, I'm entitled to have everything in working condition.

Anyways, on to my anecdote:

I picked up my 2.0 at base today from the dealer. I drove home (6 pm, 40 miles from Maryland to VA rush hour traffic :kill me with the windows down. About 2 hours ago I drove around with my dad to show off the new car.

He doesn't like the windows down so I rolled them up and started the air. It blows warm air. So I turn on the max air. After about 5 minutes of the warm, humid air blowing the windshield and side windows start to fog up. I end up having to turn off the air and roll the windows down.

I tried again 10 minutes later and had the windows down the whole time and let the system run for 10 minutes before rolling them back up. Again, no help. I tried at a stop, moving anywhere from 15-65 mph. Warm air, all the time.

So, simple questions.

1) Does your air conditioning work?

2a) Does it work well?

b) How long does it take to get "cold"?

c) Does it get worse when you stop/speed up?

Thanks for your time!
reneirwolf878 is offline  
Sponsored Links
Advertisement
 
post #2 of 169 Old 07-06-2009
Senior Member
 
dwpers's Avatar
 
Join Date: May 2009
Location: Washington D.C.
Posts: 1,985
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Mine "works" but not very well. I have it set on Lo which is like 69deg, feels more like a humid 80 coming out, has fresh full fluid...

2010 Genesis Coupe Track, 380 GT V6
Road Race Motorsports Short Ram Intake/Lightweight Pulley
AXIS Super Penta's 19x8.5" / 19x9.5", Wrapped in Falken 452's 245/19 275/19
M&S/SFR Type D Grille, Super LUX LED Taillights
35% Tint, Diode Dynamics Stage 2 LED Kit

Ark Performance True-Dual Exhaust System...and other goodies
Sponsored By: Ark Performance, BC Racing, AXIS Wheels

Quote:
Originally Posted by Ruinerofallfun View Post
Dear god man, use your search! lol
dwpers is offline  
post #3 of 169 Old 07-06-2009
Alberta Genesis Club
 
dogstar's Avatar
 
Join Date: Feb 2009
Location: Edmonton, AB, Canada
Posts: 4,135
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

1) Yes
2a) Yes
2b) 30 seconds if the car is scalding, 10-15 if it's in the high 70s-low 80s inside.
2c) Nope
dogstar is offline  
 
post #4 of 169 Old 07-06-2009
Member
 
happosai's Avatar
 
Join Date: Apr 2009
Location: Toronto
Posts: 35
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Quote:
Originally Posted by dogstar View Post
1) Yes
2a) Yes
2b) 30 seconds if the car is scalding, 10-15 if it's in the high 70s-low 80s inside.
2c) Nope
Ditto for me.
happosai is offline  
post #5 of 169 Old 07-06-2009
3.5L TT but wrong body
Moderator
 
CrookedH's Avatar
 
Join Date: Apr 2009
Location: ATX
Posts: 12,003
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Garage

1) Does your air conditioning work? - As long as I'm moving yes

2a) Does it work well? - Stops blowing cold when stopping and in traffic

b) How long does it take to get "cold"? - Depends on if I can keep moving

c) Does it get worse when you stop/speed up? - Better when I speed up worse when I stop

My wife commented on it too when she drove it for a week, so I know it's not just me being picky.




What is required for a new FS thread?
  • Detailed title of item
  • Detailed description of item (specify if its new, used, etc.)
  • Contact information (Phone number OR email preferred - not just Private Messaging)
  • Asking price
  • Location (State if local pickup or if you will ship)
  • Actual Photos of the item
Any of these missing means your thread will not be approved.
CrookedH is offline  
post #6 of 169 Old 07-06-2009
Senior Member
 
hardmack's Avatar
 
Join Date: Feb 2009
Location: Surprise, AZ
Posts: 646
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

2.0T Track... A/C sucks in the Arizona heat unless you are moving and STAY moving..

It took 20 minutes to really cool off in the car in 110 deg heat with Max AC and full fans... Plus there is a lot of glass to cool off too... gonna have to go get some reflextix or some type of glass tint SOON!
hardmack is offline  
post #7 of 169 Old 07-06-2009
Senior Member
 
Infamous_K's Avatar
 
Join Date: May 2009
Location: Richmond Hill
Posts: 244
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

did u forget to press the a/c knob so it lights up blue?
if not, that might be the problem... well, thats the only reason i can think of that blows warm air... i hope thats it for your sake... how can you live without a/c? >.<

Hyundai Sales Consultant

2010 Genesis Coupe 2.0T Premium Pkg.
Nordschleife Gray

Tinting: 35% Front// 23% Back
License Plate LED : Installed
Low Beam H11B HID Kit (hidguy.com): Installed
Fog Light 881 HID Kit: Installed
Wing Emblem Kit (kdmstuff.com): Installed

Luxon Grill: Coming Soon...
Lip Spoiler: Coming Soon...
Infamous_K is offline  
post #8 of 169 Old 07-06-2009
Resident Asshole
 
Join Date: Mar 2009
Location: Squamish, BC
Posts: 388
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

mine works great. My first car with AC that works though so maybe a poor comparison heh.

always cools right down fast, moving or not. I pretty much use max AC all the time.
It stinks though. anyone else have really bad AC smell?
1990tsi is offline  
post #9 of 169 Old 07-07-2009
거침없는 크럿츠-킼
 
AnalogHero's Avatar
 
Join Date: May 2009
Location: Seoul, Korea
Posts: 376
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

1) Does your air conditioning work? - Yes

2a) Does it work well? - Yes

b) How long does it take to get "cold"? - for me, about a minute after ignition.

c) Does it get worse when you stop/speed up? - the ac doesn't, but I have noticed that I get a weird vibration in the pedals under hard driving.
AnalogHero is offline  
post #10 of 169 Old 07-07-2009
3.5L TT but wrong body
Moderator
 
CrookedH's Avatar
 
Join Date: Apr 2009
Location: ATX
Posts: 12,003
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Garage

I'm not sure if I feel better or worse about others having the same/similar issues. About to go drop mine off for some warranty work.




What is required for a new FS thread?
  • Detailed title of item
  • Detailed description of item (specify if its new, used, etc.)
  • Contact information (Phone number OR email preferred - not just Private Messaging)
  • Asking price
  • Location (State if local pickup or if you will ship)
  • Actual Photos of the item
Any of these missing means your thread will not be approved.
CrookedH is offline  
post #11 of 169 Old 07-07-2009 Thread Starter
Senior Member
 
reneirwolf878's Avatar
 
Join Date: May 2009
Location: Northern Va
Posts: 2,407
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
(Thread Starter)

Quote:
Originally Posted by Infamous_K View Post
did u forget to press the a/c knob so it lights up blue?
I did press the button Toggling the A/C button on and off did not change how the air felt at all.
reneirwolf878 is offline  
post #12 of 169 Old 07-07-2009
RAWR!!
 
Redline G Coupe's Avatar
 
Join Date: May 2009
Location: Cleveland, Ohio
Posts: 133
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

I noticed mine didn't cool very well either when I first got it. I don't have to much to complain about though, as I don't use my AC much. I refuse to use it unless the temp is over 90 (not to often in Ohio.) I recharged mine at work. I found that the freon in the system was low. No leaks found though, just low on freon. Maybe take it to the dealer and have them check it. And like stated above, make sure you push the AC button.

2010 Karussell White 2.0t Genesis Coupe
Redline G Coupe is offline  
post #13 of 169 Old 07-07-2009
3.5L TT but wrong body
Moderator
 
CrookedH's Avatar
 
Join Date: Apr 2009
Location: ATX
Posts: 12,003
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Garage

Just dropped mine off for a list of items, AC being one of them. I'll update after I get it back. On a side note they did give me a Genesis Sedan as a loaner




What is required for a new FS thread?
  • Detailed title of item
  • Detailed description of item (specify if its new, used, etc.)
  • Contact information (Phone number OR email preferred - not just Private Messaging)
  • Asking price
  • Location (State if local pickup or if you will ship)
  • Actual Photos of the item
Any of these missing means your thread will not be approved.
CrookedH is offline  
post #14 of 169 Old 07-07-2009 Thread Starter
Senior Member
 
reneirwolf878's Avatar
 
Join Date: May 2009
Location: Northern Va
Posts: 2,407
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
(Thread Starter)

Quote:
Originally Posted by Redline G Coupe View Post
I noticed mine didn't cool very well either when I first got it. I don't have to much to complain about though, as I don't use my AC much. I refuse to use it unless the temp is over 90 (not to often in Ohio.) I recharged mine at work. I found that the freon in the system was low. No leaks found though, just low on freon. Maybe take it to the dealer and have them check it. And like stated above, make sure you push the AC button.
I'm like you, I like to have the windows down unless it's scorching hot out. I just don't want it to be not working when/if it gets above 100. I will most definitely have the dealer look at the freon level.

Quote:
Originally Posted by CrookedH View Post
Just dropped mine off for a list of items, AC being one of them. I'll update after I get it back. On a side note they did give me a Genesis Sedan as a loaner
Please keep me updated on what you find out from the dealer. And enjoy the sedan!
reneirwolf878 is offline  
post #15 of 169 Old 07-07-2009
Senior Member
 
aLi12302's Avatar
 
Join Date: May 2009
Location: Lawrenceville, GA
Posts: 426
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

i spoke to my dealer today about my a/c problem they had my car for almost 3 weeks now because the parts i needed were rare to malfunction so they weren't quick to get'em but he said he found a leak and maybe thats's why some of youz got problems with the a/c and eventually will have the same issue i had where no cold air was blowing so get that checked out
aLi12302 is offline  
post #16 of 169 Old 07-07-2009
3.5L TT but wrong body
Moderator
 
CrookedH's Avatar
 
Join Date: Apr 2009
Location: ATX
Posts: 12,003
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Garage

Somewhat encouraging to me about the leak. It may explain the bubbling sound and coolant like smell I have coming from under the hood. I'm pretty sure R134a has a somewhat sweet smell to it as well.




What is required for a new FS thread?
  • Detailed title of item
  • Detailed description of item (specify if its new, used, etc.)
  • Contact information (Phone number OR email preferred - not just Private Messaging)
  • Asking price
  • Location (State if local pickup or if you will ship)
  • Actual Photos of the item
Any of these missing means your thread will not be approved.
CrookedH is offline  
post #17 of 169 Old 07-07-2009
Senior Member
 
edjd's Avatar
 
Join Date: Apr 2009
Location: Central Texas
Posts: 390
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

+1 on cooling CONCERNS.....

it works, but darn if I dont' have to have the blower on 'high' and I have pinnacle ceramic tint as well...the a/c is not that cold...I'd like to take it in as well to have a/c checked....

Crooked H: please let us know what the dealer says and what your view is on any results....BTW: what type of warranty work did u need?..anything serious?

2.0, White GC, 6 M/T......switched from 09 MINI COOPER!
edjd is offline  
post #18 of 169 Old 07-07-2009
Alberta Genesis Club
 
dogstar's Avatar
 
Join Date: Feb 2009
Location: Edmonton, AB, Canada
Posts: 4,135
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

Quote:
Originally Posted by 1990tsi View Post
mine works great. My first car with AC that works though so maybe a poor comparison heh.

always cools right down fast, moving or not. I pretty much use max AC all the time.
It stinks though. anyone else have really bad AC smell?
When it's humid out, you HAVE to run fresh air through the system to try and air it out or you'll get mold in there. What I do is to run the A/C normally until about 5 minutes before my destination, then I turn off the A/C but keep the fan blowing and I press the outside air button.
The A/C stunk pretty bad when I got it, but now it's barely noticable and getting better.

They make sprays that will take the smell out, but once you get mold in the system it's a bugger to cure.
dogstar is offline  
post #19 of 169 Old 07-07-2009
Use the F'n Search Button
 
mmrp81's Avatar
 
Join Date: May 2009
Location: Pittsburgh
Posts: 4,280
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

I've only used the A/C maybe twice. If it's warm outside, the windows are down. Gotta get my moneys worth out of that sunroof.

But the times i DID use the A/C, i noticed it wasnt very good. Developed alot of humidity on the winshield too after/during rainstorms.
mmrp81 is offline  
post #20 of 169 Old 07-07-2009
1st GenCoupe In Louisiana
 
Join Date: Feb 2009
Location: Baton Rouge,LA
Posts: 305
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

I will get my car back after having it fixed by my dealer. I had a different issue (broken part), but my system barely cooled compared to some of the ones i sat in at the dealer the other day. I should get my car back today and let yall know if it is cooling better.

2010 Genesis Coupe GT --traded in (great while I had it)
Nordschieife Gray
------------------------------------------

2010 Santa Fe SE w/ Navi (pearl white)
--4300k HID Kit
-- Hidden Hitch
lsutiger694 is offline  
Sponsored Links
Advertisement
 
Reply

Related Threads
Thread Thread Starter Forum Replies Last Post
The Ultimate Genesis Coupe Newbie Guide to Modding << MUST READ! GenCoupeGeek New Member Section 35 05-23-2019 01:43 AM
Air conditioning problems? redbusa General Discussion 29 05-07-2015 07:38 PM
The Best Street Driven Intake Kit That Hyundai Already Makes For Us cdnsigop 2.0T Discussion 2008-2012 255 07-21-2014 10:30 AM
Remote / Custom Mounted Supercharger Discussion Thread ESBjiujitsu 3.8 V6 Discussion 2008-2012 97 05-25-2014 07:49 AM
Complete Tech Spec Break Down of all Gen Coupe Air Conditioning Systems WildBill Engine 0 02-08-2010 04:38 PM


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Hyundai Genesis Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome