Hyundai Genesis Forum - Reply to Topic
Thread: Engine Knock/Slapping 2011 2.0T Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Hyundai Genesis Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
04-24-2019 08:18 AM
AKGC If you think it's the pistons, then do a compression test.

Turbo - take off the intake hose to the front of the turbo, reach in there and check if there is any side to side, forward/back play to where might be hitting something.

These engines don't have lifters.

If you over revved it, it could be that the timing chain skipped teeth.

It could also be the dual mass flywheel having excessive play. While idling, have someone press in the clutch pedal and listen for any change in the sound.

If it's rod knock, then your're going to have to take apart the bottom half of the engine to check.
04-24-2019 07:46 AM
Matt Hryhoruk
Quote:
Originally Posted by Red Raspberry View Post
How many miles on the car?

It’s got 56000mi, I just checked the oil this morning and it looks like the oil was an inch over the full line so maybe that’s the cause of it?
04-24-2019 07:20 AM
Red Raspberry How many miles on the car?
04-23-2019 09:25 PM
Matt Hryhoruk
Engine Knock/Slapping 2011 2.0T

So I recently did an oil change and switched from 5w20 to Quaker State Synthetic 5w30 and installed a Fram oil filter after doing an engine clean with CRC Intake Valve and Turbo Cleaner as well as a little bit of ATF fluid in the oil as last oil change the new oil was still black as sin. It has only been 1500kms since last change.

I was driving a bit hard today and during idle after I parked I noticed a deep ticking/tapping sound. The noise seems to go away when I hit the accelerator and only is audible during idle. I don’t think it is the lifters because I know they make a quick higher pitched ticking sound which I have always heard. The noise I’m hearing is a slower lower pitched tick almost like a pencil on a desk or tapping your nail on a double pane window. I hear this noise along with the lifters.

I’m wondering if I should be worried about this. Could it possibly be the oil I’m using, the filter or the engine clean I did? It only started happening today after hard driving and I did the oil change a day 2 days ago. Oil isn’t low. I have also never heard the noise before I know forsure.

The only engine mod I have is an AEM cold air intake and the car has 91k on it. I’m about to take it in for a cc clutch stage 2 since my stock clutch is going on me. It’s long out of warranty and I am the 3rd owner so I am hoping it’s either perfectly normal or it’s an easy fix as this stage 2 is going to cost me 2500 after tax as it is.

Also it’s a manual

I have been reading on here it could be a rod knock, the injectors, the cam shaft, slapping pistons or the turbo but I’m just trying to get an idea before I take it in to have it looked at.

A friend of mine said the oil could be overfilled and it’s just splashing in the oil pan but it sounds more like a tick or snapping and the dip stick reads on the full line.

I’ve looked all over the forum for answers and decided to open a thread on this topic. It’s got me quite worried as this is my daily and I only bought it a year ago.

Anybody have this experience?

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome