2012 2.0T Heavy Steering - Hyundai Genesis Forum
 5Likes
  • 1 Post By AKGC
  • 1 Post By AKGC
  • 1 Post By Red Raspberry
  • 1 Post By Robert Kenneth
  • 1 Post By Red Raspberry
 
LinkBack Thread Tools
post #1 of 14 Old 4 Weeks Ago Thread Starter
Junior Member
 
Robert Kenneth's Avatar
 
Join Date: Aug 2019
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
(Thread Starter)
2012 2.0T Heavy Steering

Is you’ve seen my new members post, I have a low mileage 12 BK1 2.0 A/T.
Possible left front damage repaired minimally.

Steering. At a stop, the steering wheel turning is heavier than what I would consider normal.
Also, at any speed, the wheel will not ‘Self Center’. It’s you turn and I’ll roll back towards center and stop at about 11o’clock which no hands on the wheel and you just be have to center with hands.

Toe was checked at OEM spec, camber in the left front is “Off by 1 degree” yet the shop didn’t save nor print specs. It was a Saturday and I needed to leave.

However, 1 degree camber kick I’ve never had cause heavy steering and failure to self center.

Could this just a poor Power Steering design from Hyundai or do your BK1’s have light(er) steering and normalize self centering.

Lemme know before I start tearing the front suspension into pieces and diagnosing.
Robert Kenneth is offline  
Sponsored Links
Advertisement
 
post #2 of 14 Old 4 Weeks Ago
I'd rather do it myself
 
Red Raspberry's Avatar
 
Join Date: Aug 2009
Location: Flat lands of Illinois
Posts: 18,125
Mentioned: 20 Post(s)
Tagged: 1 Thread(s)
Quoted: 3 Post(s)
Garage

Piss poor PS design and front end geometry is my guess. They sure don't self center and mine will pull to the right without aftermarket parts.

2010 Red 2.0L track

Quote:
If the Pharaohs had duct tape, the Sphinx would still have a nose...."
Red Raspberry is offline  
post #3 of 14 Old 4 Weeks Ago Thread Starter
Junior Member
 
Robert Kenneth's Avatar
 
Join Date: Aug 2019
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
(Thread Starter)

I looked up the specs and the caster angle is 7.5.
Assuming this should place the mechanical trail over 30mm. Without knowing the actually steering axis, I can only guess.

However, with this camber vs caster spec the car should track pretty damn straight with it self righting more than it is.

There must be some odd deflection going on in general.
If itís just a wonky design, Iíll need an adjustable front tension arm and adjustable upper strut mount.

Game on...


Sent from my iPhone using Tapatalk
Robert Kenneth is offline  
 
post #4 of 14 Old 4 Weeks Ago
Senior Member
 
AKGC's Avatar
 
Join Date: Jul 2009
Posts: 14,673
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 713 Post(s)

Self centering is done by the caster angle.

Mine doesn't really go back to center, but mine sure doesn't wander.It pretty much stays where I set it, within 11 and 1.

difficult steering is not normal. Sounds you need to have your power steering checked.

I wouldn't say it's heavy, but it's light enough to where I can steer mine with a finger.
Robert Kenneth likes this.
AKGC is offline  
post #5 of 14 Old 4 Weeks Ago
I'd rather do it myself
 
Red Raspberry's Avatar
 
Join Date: Aug 2009
Location: Flat lands of Illinois
Posts: 18,125
Mentioned: 20 Post(s)
Tagged: 1 Thread(s)
Quoted: 3 Post(s)
Garage

I think one of the problems is the front subframe is in a fixed position so minor tweaking can't be done

2010 Red 2.0L track

Quote:
If the Pharaohs had duct tape, the Sphinx would still have a nose...."
Red Raspberry is offline  
post #6 of 14 Old 4 Weeks Ago Thread Starter
Junior Member
 
Robert Kenneth's Avatar
 
Join Date: Aug 2019
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
(Thread Starter)

Quote:
Originally Posted by AKGC View Post
Self centering is done by the caster angle.

Mine doesn't really go back to center, but mine sure doesn't wander.It pretty much stays where I set it, within 11 and 1.

difficult steering is not normal. Sounds you need to have your power steering checked.

I wouldn't say it's heavy, but it's light enough to where I can steer mine with a finger.


Actually, I explained above and it can be modified to an extent. Their ainít my first rodeo. Just the first rodeo with an oddly designed front suspension.

After troubleshooting the P/S and rack, there is a pressure/flow issue inside the rack. High pressure going in and low flow coming out no matter how fast I turn the wheel. Since reman. Racks are running $500, Iíll eBay a used rack and change out for my tie rods.


Sent from my iPhone using Tapatalk
Robert Kenneth is offline  
post #7 of 14 Old 4 Weeks Ago
Senior Member
 
AKGC's Avatar
 
Join Date: Jul 2009
Posts: 14,673
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 713 Post(s)

Quote:
Originally Posted by Robert Kenneth View Post
Actually, I explained above and it can be modified to an extent. Their ainít my first rodeo. Just the first rodeo with an oddly designed front suspension.

After troubleshooting the P/S and rack, there is a pressure/flow issue inside the rack. High pressure going in and low flow coming out no matter how fast I turn the wheel. Since reman. Racks are running $500, Iíll eBay a used rack and change out for my tie rods.


Sent from my iPhone using Tapatalk
Oddly designed? They've using the same basic design since the 50s. It's a macpherson suspension design. There are 2 major macpherson designs, all basically the same; the difference is whether the steering rack/ pitman arm attaches in front of the front axle line, or behind it.

It's just stupid that they have you adjust camber with an not-standard equipped OEM eccentric bolt, and no previsions for adjusting caster. Toes it adjusted by adjusting the tie-rods.
Robert Kenneth likes this.
AKGC is offline  
post #8 of 14 Old 2 Weeks Ago Thread Starter
Junior Member
 
Robert Kenneth's Avatar
 
Join Date: Aug 2019
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
(Thread Starter)

Quote:
Originally Posted by AKGC View Post
Oddly designed? They've using the same basic design since the 50s. It's a macpherson suspension design. There are 2 major macpherson designs, all basically the same; the difference is whether the steering rack/ pitman arm attaches in front of the front axle line, or behind it.



It's just stupid that they have you adjust camber with an not-standard equipped OEM eccentric bolt, and no previsions for adjusting caster. Toes it adjusted by adjusting the tie-rods.


Not uncommon. You can but a camber adjust set even from Hyundai.


Sent from my iPhone using Tapatalk
Robert Kenneth is offline  
post #9 of 14 Old 2 Weeks Ago Thread Starter
Junior Member
 
Robert Kenneth's Avatar
 
Join Date: Aug 2019
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
(Thread Starter)

I live in Phoenix currently and itís been 110 during the day. Finally got a chance to work on it without getting heat stroke in the garage and this is what was found.

STEERING BIND

I put the front end up on jack stands and test the steering turn resistance with no friction, car off.

I would guesstimate it takes 3 - 5 lbs of pull with no friction or power steering and it feels like itís binding.
Started the car with the front end off the ground and the steering has the same bind. Power Steering isnít providing much help. If you turn the wheel really fast, Iím getting the ďout of breathĒ jitter in the wheel, showing a flow issue.

CAMBER

Toe and camber were check at a shop right after I had the new Comp IIís put on it due to a hard right pull with an out of alignment wheel.

TOE is within factory spec.

CAMBER Is out about 1.5 degrees on the drivers side causing it to walk over the friggen place and pull.



So, side note. I can clearly see the paint is the factory color all around but the left front fender has a different level of orange peel and they didnít feather match to the door color. So, even when we picked up the car with only 13k at that time, it got popped in the fender.

However, not bad enough for the bumper to be removed as the VIN stickers are untouched and bolts not broken loose on top. Clean carfax meaning it was a single party accident and they took it to Josh Smow auto body.

Crawled under the car and started looking for possible damage. Nothing broke but you can see in the ATTACHED (one shows the half moon and the other side crinkled paint from slip), the engine cradle is shifted over toward the passenger side on the left/driver side. Passenger side untouched or shifted, meaning its compressed a bit at the center.

Iíve seen this, over time or instantly slightly bend the steering rack causing it to bend/bind. However the rack is forward on the cradle and that may or may not be the case. Camber bolts adjust the from the top of the hub lines and will ultimately allow the left front tire to sit in an extra 3-6mm, I donít like that at all and feel itís a bandage to a chassis issue.


TL;DR

I found a Rack and Pinion on eBay with 65k miles for $150 (made an offer from a $200 list price) and ordered it.

Iíll replace both front lower control arms.

There-after, Iíll check the camber with my camber gauge comparing left to right since passenger side is in spec. Perfectly

If itís still off, Iíll jack up the driver side and leave the rolling jack under on it (so it can roll) remove tire, put a recovery strap around the engine cradle, loosen the rear bolt only, make an index line so to I got go beyond and give it a light tug with a ďcome alongĒ or with my other car.

Already called three shops and they want two hours labor+ for subframe/k-member adjustments which is fare. At $120 labor rate, Iíll do it myself.

Once I feel Iíve un-buggered the geometry, Iíll take it for a full 4 wheel w/ thrust angle to an established alignment shop. Iíll have them set to factory, test drive and adjust to remove the KNOWN RIGHT PULL which isnít too difficult by playing with the camber and toe just .5 degrees.

Iím probably going to drive it 1800 miles to Colorado and back in a few weeks and donít want to get butt messages from the car drifting right.















Sent from my iPhone using Tapatalk
Robert Kenneth is offline  
post #10 of 14 Old 2 Weeks Ago
I'd rather do it myself
 
Red Raspberry's Avatar
 
Join Date: Aug 2009
Location: Flat lands of Illinois
Posts: 18,125
Mentioned: 20 Post(s)
Tagged: 1 Thread(s)
Quoted: 3 Post(s)
Garage

There is a bolt in the middle of the subframe, one on each side. This pins the subframe to the body position wise. They would need removed to move the subframe any. I've often wanted to try that as my car has always pulled to the right due to caster issues.
Robert Kenneth likes this.

2010 Red 2.0L track

Quote:
If the Pharaohs had duct tape, the Sphinx would still have a nose...."
Red Raspberry is offline  
post #11 of 14 Old 2 Weeks Ago Thread Starter
Junior Member
 
Robert Kenneth's Avatar
 
Join Date: Aug 2019
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
(Thread Starter)

Quote:
Originally Posted by Red Raspberry View Post
There is a bolt in the middle of the subframe, one on each side. This pins the subframe to the body position wise. They would need removed to move the subframe any. I've often wanted to try that as my car has always pulled to the right due to caster issues.


Thanks for the tip!

Yeah, this isnít uncommonly with vehicles using K-members and alignment problems. Thank goodness my automotive training (hands on) included many k-members cars and I also owned a 93 Mustang Notch.

There are a zillion and a half tricks to moving one end or the whole member over. Iím at 0 on driver side and .8 on passenger. Guessing lower ball joint to strut bearing is 28Ē in length and itís kicked over 1/4Ē, that tells me itís is a slope of .89% in change = .51 degrees. However I think the control arm bolt and drive side K-Member shifted. Together Iím guessing 3/8Ē should be .75 degrees in total if I yanked it back to the opposite slack.

Camber bolts are for suckers and people with frame damage thatís not part of the k-member. Lol!



Sent from my iPhone using Tapatalk
Robert Kenneth is offline  
post #12 of 14 Old 6 Days Ago Thread Starter
Junior Member
 
Robert Kenneth's Avatar
 
Join Date: Aug 2019
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
(Thread Starter)

Problem solved!

Rack and pump replaced with one from a rear end wreck with 30k miles.

Installed a magnetic filter in the suction line to the pump. (5/8Ē hose from reservoir to pump, FYI)

One thing I never found the answer to was about the stock filter in the reservoir.

Yes, the entire bottom of the reservoir is a poly filter (screen) which Iím guessing is about 100 micron or so. However, I wanted a magnetic one anyways since P/S Systems will eat them selves over time from their own metal shavings.

I may need to flush the system one time since the low mileage used pump and rack seemed to be full of old hydraulic fluid, contaminating my nice new and pretty German synthetic fluid... Lol

Either way,
I hope this info helps others. Your info on this forum has assisted me immensely!


Sent from my iPhone using Tapatalk
Red Raspberry likes this.
Robert Kenneth is offline  
post #13 of 14 Old 6 Days Ago
I'd rather do it myself
 
Red Raspberry's Avatar
 
Join Date: Aug 2009
Location: Flat lands of Illinois
Posts: 18,125
Mentioned: 20 Post(s)
Tagged: 1 Thread(s)
Quoted: 3 Post(s)
Garage

I've had an inline magnetic filter for the last 70k miles or so. Only on my second one.
Robert Kenneth likes this.

2010 Red 2.0L track

Quote:
If the Pharaohs had duct tape, the Sphinx would still have a nose...."
Red Raspberry is offline  
post #14 of 14 Old 6 Days Ago Thread Starter
Junior Member
 
Robert Kenneth's Avatar
 
Join Date: Aug 2019
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
(Thread Starter)

Oh!

Shifted the entire subframe over 1/8Ē and it made my camber and caster symmetrical.

What was done:

-Jackstands on lift points
- Place Rolling floor jack under k-members cross beam (below oil pan), jack it up till it makes light contact with the beam, not lift).
- Loosed 3 k-member bolts on each side (6 total) 3 turns exactly.
- Verified the member separated from the frame with a small flathead screw driver.
- Used one of the wheels/tires to bash the opposite brake/hub towards the other side (redneck dead blow hammer).
- Retorqued to factory spec in a cross pattern.

Good to go and steering now Auto-Rights to center as well.

The above only works if you have unequal camber from side to side. This will increase onside side and lower the other. If itís super knocked out on one side but the other is factory, youíve got a bent control arm, strut or tacoíd K-member.

I used my iPhone and an angle app which will give me about .50-1.00 accuracy, the garage and house is new and the slab is extremely level.
But I was looking symmetry, I didnít want one wheel in further than the other. If correction is now needed Iíll install a camber bolt on each side. Itís tracking pretty straight and I set the alignment by eye, including the steering shaft and tie-rod ends.


Sent from my iPhone using Tapatalk
Robert Kenneth is offline  
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Hyundai Genesis Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome