Hyundai Genesis Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Let me tell you a story. So on Sundady, Feb 26th my 2011 2.0t r-spec threw its first CEL at me.

for some background; i bought it about a year ago with 54k miles on it (it currently has 79k) and this was the first time it has caused me any problems whatsoever (besides some squeaky brembo's). I had oil changed on a regular basis (around 5k).

So i took my gen to my buddies who had a code reader (threw P0011 and P0014 - cam shaft sensors). I knew i had to take it in monday during my lunch break, unfortunately i didnt make it that far. The next morning i tried starting my babe and she tried her hardest but wouldnt completely turn over. she would try to crank, but no success. long story short i had it towed to hyundai and they told me i needed my tensioner and cvvt manifold replaced. they did the work - not through their warranty but through extended warranty i purchased through my credit union.

So alas, i get the call that she is set and ready for pickup. i was ecstatic, i love my gen. i pick it up and it shifted (m/t) and drove like a DREAM... for the first 5 miles. Thats when this story gets much, much worse. I get it on the highway and sure enough she threw some more codes at me. i pull over to diagnose them and they are the same ones as before. P0011 and P0014. by now the dealer had closed and so i would take it in the following morning. As i drove to my house, there was this rattling in my engine assembly at around 3k rpms and beyond whenever i touched the accelerator. you know that ebarrassing feeling of having a car that sounds like its going to break down at any moment? that was me yesterday. it was LOUD. and it sounded real bad.

I get to hyundai mall of GA (wassup atl friends) and tell them that there is something extremely wrong and i asked them if they had driven it more than 10 miles after the cvvt and tensioner fix. They assured me they had, but i know the test drive route that they take and it is literally 3 miles MAX and if they had driven it further and gotten it up to cruising speed this would have been caught before they told me it was fixed. i was frustrated, needless to say. they called me back and said that my connector rod to my solenoid was failing (i mightve forgot the exact terminology, but thats close lol). i asked them what it would take and the service writer said very plainly that i'd need a new engine assembly (whole motor) and the labor and parts if i didnt go through insurance would be around 8k (????) i was shocked.

SO right now, hyundai is in the process of pulling my engine apart to find the root cause and then determining if a whole new engine is needed or just a part.


My question for you all is: Has anyone run into this problem before? Am i crazy for thinking that this could be something hyundai caused(this never happened before the cvvt was replaced)?? Am i right to be upset with hyundai for giving me the car back without driving it enough? what do you recommend i do - extended warranty will replace the engine depending on cost and root cause (im super nervous about that).

Any and ALL comments are appreciated - show me the love gencoupers, this is my first post and a cry for help.

-smack
 

·
Premium Member
Joined
·
16,121 Posts
could be a number of problems

(assuming oil level was correct)
something blocking the oil passage to the cam solenoid, but that wouldn't cause the valve to fall out (assuming thats what happened)

something went off with the timing chain (tensioner messing up, chain guides being over worn, ect)

over revving the engine at some point, causing valve float, or the timing chain to skip teeth.

someone removing one of the valves, and not seating the keepers properly.

It is more likely that the engine just needs to be rebuilt to replace the damaged parts (valve guides, valves and piston and associated fasteners)

People at the stealership are just too lazy to bother to do a rebuild.

If you have a tune on the car and they find out, just be warned that they aren't going to warranty anything to do with the engine.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
thankfully i do not have a tune. it is bone stock outside of a tint and debadging.

i did check the oil once i returned it to hyundai with the rattling and it was very low. maybe them not putting oil in the car screwed it over?

at this point, i have initiated a repair with my 3rd party warranty. i have also brought this complaint up to hyundai corporate and a gentleman there (i will leave nameless) sounded pretty receptive to the idea of my warranty covering what they will and hyundai taking care of the rest.

granted tomorrow is the true test; the claims assessor comes to view the engine parted out. send me your good juju please and thank you ?
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #5 ·
they did not put anything but the line items themselves. one thing i did notice (im more in tune with electronics than internal engine workings) that the oil was very low when i brought it back in. i should be receiving a call tomorrow regarding the outcome of the teardown. i've been too damn patient
 
1 - 5 of 5 Posts
Top