Hyundai Genesis Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1 (Edited)
Disclaimer: I hold no responsibility for damage to your vehicle or injury to your person while attempting this modification.

THIS TUTORIAL IS MAINLY FOR A BK2 WITH THE 2.0T

OK so after seeing some people out there running a WOT box on a genesis coupe (bk1) , I decided to get one for my 2013 R-Spec 2.0t. I did not find any DIY's for a BK2 and since the wire colors are totally different, i decided to make a quick DIY for those who want it installed on a BK2 2.0T


I will not take credit from "Tufast" member who has a DIY for a BK1 however his instructions don’t apply to a BK2 since every wire is a different color. CLICK BELOW to follow the tutorial with pictures.Also for a BK2 you don't need to wire the switch on the DIY because it already has 2 switches on the clutch.
http://www.gencoupe.com/engine-drivetrain/54974-diy-n2mb-wot-box-install.html

I suggest using his DIY but instead of tapping to the wire colors he tell you to, use the following:

Green wire from WOTBOX - Green wire on the TOP clutch switch (my bk2 has a upper and a lower switch for the clutch pedal and no cruise control)




Blue wire from WOTBOX- Orange wire from gas pedal plug. ( if 2014+ don’t have orange wire use a multi-meter to see which wire has 4-5v when the gas pedal is floored and less than 1V when you let off the gas pedal)



Black wire from WOTBOX- Ground.. usually a bolt/nut on the body under the dash.(bare metal)




That’s it inside the car. Now we move to under the hood.


Yellow wire from WOTBOX- goes to number 4 injector blue Wire. (injector closest to the firewall)


If you are following the BK1 tutorial you will see that you need to remove the passenger side fuse box under the hood (2 bolts) , and flip it up side down to get to the wires in the back.Once all wires are exposed here's what you have to do.

If you have the new revised harness you will have ORANGE and RED wires left from WOTBOX.




If you have the old style harness you will be left with a BLACK and a RED wire so wire this way.



Once you finish it, the WOTBOX is wired and ready to be set up and tested.


WOTBOX SETUP:

COPY AND PASTE THIS ADDRESS INTO YOUR INTERNET BROWSER :

https://78462f86-a-8d8d997f-s-sites.googlegroups.com/a/npcompleteperformance.com/www/wotbox/software/wotbox_software_instructions.pdf?attachauth=ANoY7crOdzzFn97988QkiFEzTKSLQLEaQo73mT3kgURfWeyuDRjYW5o6hmqvYzzRi6C2nf47rI7jobHnkrwnUKWq7MUYG3zzRe9HIPyGGapDMJBDKuXO75cDhthgKSScBxRuF4cRIL9T-4FgNCMO4SLH4LYRs6ZvimkkXZC_1mooo9s0R3A3adGl9k-PlwJg17WzVuaw4QL98oeTFfIpgH5TMttJAYwd7PWQJAYudObcUI3Cc2ka23d3SdRaLkdvsDpaXxZIl3JPWV--02m_W2sBP6hZ1MED6w==&attredirects=0

If the link doesn’t work go to Software - N2MB Racing

Click SOFTWARE INSTRUCTIONS.
 

·
Registered
Joined
·
151 Posts
Thanks for writing this up! Just in case I ever grow the balls to do it :p
Btw dope drawings
 

·
Registered
Joined
·
371 Posts
could this be hooked up or configured to cut ignition during regular driving to counteract the rev hang? also will this throw a cel at all seeing as it interrupts the coil system?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
could this be hooked up or configured to cut ignition during regular driving to counteract the rev hang? also will this throw a cel at all seeing as it interrupts the coil system?
I have not tried to configure it during regular driving that's not the purpose of the box. only purpose is for a good launch and power shifting. and YES if you do it often you will get a CEL for missfire but can be easily cleared of just ignore it because you know the cause. I ignore the light because i know its nothing serious. look into buying a wifi code reader that connects to your phone clears codes anytime you want from your smart phone.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
Please read this!!! Wire color correction

if you are going to use my diy to install a wotbox please read this.

I have made a mistake in wire color while i was drawing the pictures and i am not able to edit my post for some reason.

When tapping into the injector #4 i said above its connected to a blue wire and its wrong.

You will have 2 wires (yellow+green) and you will want to tap into green. Thanks to a private message i am able to try and correct my mistake . Anyone feel free to pm me any questions.

Have a good one.
 

·
Registered
Joined
·
70 Posts
Thanks for the correction :) Although I guessed yellow :/ 50/50 shot so of course I chose wrong, lol. All fixed now. And just to confirm, you didn't use a resistor when you connected to the clutch pedal switch correct?
 

·
Registered
Joined
·
371 Posts
Just used your guide to install mine and it works great using v3.2. however I tried using v3.5 for the rev limiting being enabled on "other" timing sources, however I can't get the car to start unless I turn the box off, seems that it won't pass the spark except like once every 2-3 rotations it will fire once. However if it's already started then the features all seem to work ok. I rolled back to v3.2 and all is well again. Anyone have any ideas?

Side note, I've been using the no lift shift feature to combat rev hang when shifting during normal driving by setting the cut to 500ms and voltage threshold to 1.05 so it will activate under the slightest of throttle but won't stall the car at idle. Would this be damaging at all to the car? It's kinda nice not having to add an extra half second to my regular shifting from the rev hang and the fact that the ecu still fuels the cylinders a tiny bit even decelerating at higher rpm (you can hear and feel the difference when the box cuts the spark and when it returns), only downside is no more exhaust pops :(. but if it's bad for it then I guess I'll have to set it for racing only.
 

·
Registered
Joined
·
1,000 Posts
My injector closest to the firewall doesn't have a blue wire it's white and then a black one same thing???
Scroll up a little bit and read post #7 , I think that may be your answer.
 

·
Registered
Joined
·
1 Posts
yellow wire ( 4th fuel injector)

dude i have BK2 and on the 4th fuel injector theres only a green and orange wire ...... ived try the orange one and dosnt read any idle RPM... ill go and cut the green but you said blue and there no blue on the 4th ful injector on the BK2 2013 genesis
 

·
Registered
Joined
·
5 Posts
Can someone see the pictures on the DIY of bk1, or just know which colors am I supposed to see in a bk1 to do it with this thread? I can't see the other thread pictures.
 

·
dontmindme. justcreepin
Joined
·
182 Posts
Installed as described. Once the car is on I can enable all features and they work fine. Once I shut off and turn the car on again it doesn’t start. Enabled/disabled each feature one by one and found that it’s launch control that won’t let the car start. Any suggestions for fixing it cause I don’t want to keep a laptop in my car each time I want to enable launch control. Thanks in advance for any advice.
 
1 - 15 of 15 Posts
Top