Hyundai Genesis Forum banner

41 - 49 of 49 Posts

·
Registered
Joined
·
12 Posts
I had to delay my service appointment until tomorrow, as we had a big snow come in. However, I did find all of the TSBs and Campaigns for our cars. I found the 12-01-034 update but it is listed for the 3.8 auto. I could not find the 2.0. However, that does not mean there is not an update, so when they hook my car up, I will make sure to have them check manually. Additionally, I found TSBs for other things that could be culprit, which have TSB procedures that a lot of dealerships might not be completely aware of how to do. So, I am printing these out and taking them with me tomorrow.

12-01-034 (CAMPAIGN not TSB) 3.8L TCM UPDATE

12-AT-011 HARSH AND/OR DELAYED SHIFT (This TSB actually seems to test the solenoids and the shift time between gears. Interestingly enough, it states that if the shift time is more than 2.5 seconds, to replace the transmission LOL. But, either way, this would be a good TSB to take with you if you are having problems.

16-AT-001-2 RESET and RELEARN ADAPTIVE VALUES (We all know of this reflash)

16-AT-008 AUTOMATIC TRANSMISSION OIL PRESSURE DATA TRANSFER (This TSB is also very interesting. Apparently, there are values shown on the side of the transmission that represent pressures from the transmission. These are supposed to match certain values in the TCU. Might be something to look at)

17-AT-002 TRANSMISSION FLUID LEVEL (This TSB would be good for all of us to look over. Has diagrams of the locations of the different plugs and how to go about checking the fluid level. I could easily see a technician doing this wrong.)

18-AT-002 ATF and DCT GEAR OIL (I threw this in here just for information purposes)

I will post a link later on with an attachment of the actual pages of these.
Did you ever find a fix to the issue?
Actually just was about to report back. I had a bad experience with a dealer putting the wrong fluid in my car. However, I went to a different dealer and they put the right fluid in. Additionally, they spent a lot of time getting the fluid level right and it seemed like they checked it in ways that the original dealer did not. Now, knock on wood, I haven’t experienced any bit of the issue! Just a little bit of hard shifting but that’s normal with these carsz
What fluid was it that was wrong?
 

·
Registered
Joined
·
12 Posts
I had to delay my service appointment until tomorrow, as we had a big snow come in. However, I did find all of the TSBs and Campaigns for our cars. I found the 12-01-034 update but it is listed for the 3.8 auto. I could not find the 2.0. However, that does not mean there is not an update, so when they hook my car up, I will make sure to have them check manually. Additionally, I found TSBs for other things that could be culprit, which have TSB procedures that a lot of dealerships might not be completely aware of how to do. So, I am printing these out and taking them with me tomorrow.

12-01-034 (CAMPAIGN not TSB) 3.8L TCM UPDATE

12-AT-011 HARSH AND/OR DELAYED SHIFT (This TSB actually seems to test the solenoids and the shift time between gears. Interestingly enough, it states that if the shift time is more than 2.5 seconds, to replace the transmission LOL. But, either way, this would be a good TSB to take with you if you are having problems.

16-AT-001-2 RESET and RELEARN ADAPTIVE VALUES (We all know of this reflash)

16-AT-008 AUTOMATIC TRANSMISSION OIL PRESSURE DATA TRANSFER (This TSB is also very interesting. Apparently, there are values shown on the side of the transmission that represent pressures from the transmission. These are supposed to match certain values in the TCU. Might be something to look at)

17-AT-002 TRANSMISSION FLUID LEVEL (This TSB would be good for all of us to look over. Has diagrams of the locations of the different plugs and how to go about checking the fluid level. I could easily see a technician doing this wrong.)

18-AT-002 ATF and DCT GEAR OIL (I threw this in here just for information purposes)

I will post a link later on with an attachment of the actual pages of these.
Did you ever find a fix to the issue?
Actually just was about to report back. I had a bad experience with a dealer putting the wrong fluid in my car. However, I went to a different dealer and they put the right fluid in. Additionally, they spent a lot of time getting the fluid level right and it seemed like they checked it in ways that the original dealer did not. Now, knock on wood, I haven’t experienced any bit of the issue! Just a little bit of hard shifting but that’s normal with these carsz
Car still running good? I went to the dealer and was told that the transmission is going out, but to me that just seems like a quick and expensive fix that may or may not be necessary.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #43
Update on the rough shift from 2nd to 3rd. So my 18 year old son spun out on a rain slick road last week. Took Ginny to our local mechanic. Four new tires (it for sure needed two rear tires), + rear strut. Then on test drive the mechanic said the rear wheel bearing was noisy. Replaced. We now have the car back and it so far it drives like new. I am starting to subscribe to the theory that the rough shift is electronic not mechanical. One of the rear tires was wearing faster than the other - it kept loosing air. I'll update in a few weeks to let you know if the rough shift returns.
 

·
Registered
Joined
·
12 Posts
Update on the rough shift from 2nd to 3rd. So my 18 year old son spun out on a rain slick road last week. Took Ginny to our local mechanic. Four new tires (it for sure needed two rear tires), + rear strut. Then on test drive the mechanic said the rear wheel bearing was noisy. Replaced. We now have the car back and it so far it drives like new. I am starting to subscribe to the theory that the rough shift is electronic not mechanical. One of the rear tires was wearing faster than the other - it kept loosing air. I'll update in a few weeks to let you know if the rough shift returns.
Took mine into dealership several weeks ago. Ended up having my transmission replaced under extended warrenty. So far I haven't had any issue with the rough shifting
 

·
Registered
Joined
·
2 Posts
Hey everyone. Hate to hear that y'all are also having this issue. Popped up in my 2013 3.8 and 3 reflashes/updates later no fix. After each reflash it seems to be shifting fine (rougher shifts but maybe I'm paranoid) for about 300 miles then it starts to slip in 4-5 shift and sometimes 2-3. Dealership says no codes are being thrown so only action is to replace.

I totally agree that its either a bad OEM tune or a faulty solenoid. Highly suspect to me that a mechanical issue could be remedied by a reset. Does anyone have a VB diagram? I'd be very curious to see if we could see if there are any solenoids or valves that control hydraulics for 2-3 and 4-5 shifts. I am in no way an expert on VB's, but am fairly comfortable with the diagrams.
 

·
Registered
Joined
·
1 Posts
Hey, you mentioned that you replaced your tires and wheel bearing, did that resolve the issue? My 2013 3.8 started having the same problem recently, delayed and rough shifts from 2nd-3rd and 4th to 5th. I had the TCM update and reset which improved the shifting but it's still slipping somewhat after the car warms up in those particular gears. I was thinking it may be a transmission fluid issue and was planning on getting a fluid change but now that I think about it, my recently purchased winter tires are a square setup rather than staggered, it could be that the tire rotation speed is confusing the ECU/TCM and causing bad shifts.
 

·
Registered
Joined
·
325 Posts
Hey, you mentioned that you replaced your tires and wheel bearing, did that resolve the issue? My 2013 3.8 started having the same problem recently, delayed and rough shifts from 2nd-3rd and 4th to 5th. I had the TCM update and reset which improved the shifting but it's still slipping somewhat after the car warms up in those particular gears. I was thinking it may be a transmission fluid issue and was planning on getting a fluid change but now that I think about it, my recently purchased winter tires are a square setup rather than staggered, it could be that the tire rotation speed is confusing the ECU/TCM and causing bad shifts.

Fix your tire size. I have a square setup too but it only causes issues at higher speeds or around shift points. Or loss of traction:/
 

·
SuperNoob
Joined
·
4 Posts
any updates to this?

2013 3.8 Track 8AT. Already had the transmission fluid flushed... Same issue going from 2nd to 3rd and 4th to 5th.
 

·
Registered
Joined
·
325 Posts
More likely a TCU issue if it's not a faulty solenoid. I'd take it to a dealer. Transmission flush won't get rid of that problem.
 
41 - 49 of 49 Posts
Top