Hyundai Genesis Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
231 Posts
Discussion Starter #1
Just started having an issue where sometimes my automatic headlights don't work (don't come on at all) and my seatbelt chime acts like my seatbelt is not clicked in when it is buckled. When the auto headlights don't work, neither does the high beams, so no lights at night with auto, but if I turn the lights on manually, I have low beams but high beams don't work. The next time I get into the car everything works as designed. 3 days later same issue again, but after parking the car for a while, I can't duplicate the problem.

Any ideas? I would think relay but it would surprise me if those two systems were on the same relay.

Thanks,

Glenn
 

·
Registered
Joined
·
996 Posts
Just a possibility, but I would eliminate the battery as the problem first even if it checks out ok. I've chased many weird problems like this only to discover the battery that tested good and wasent that old had a issue. It might not be the cause but I would at least borrow a new or known good battery before I started chasing multiple electrical gremlins.
 

·
Jason
Joined
·
1 Posts
Not sure if you got this fixed yet, I have a 2013 Coupe GT 3.8L CDN version, had the same issue. Brought it to one dealer after it cleared on its own and they didn't believe anything I was saying. The 2nd time the issue happened I left the car running the entire time and drove it right to a different dealership. Showed them the issue and a mechanic said he has seen the problem before and the power block behind the dash had to be replaced. If you bring it to a dealership I can give you the info of the dealership that fixed mine to give the details of the parts and the repair.
 

·
Registered
Joined
·
33 Posts
Not sure if you got this fixed yet, I have a 2013 Coupe GT 3.8L CDN version, had the same issue. Brought it to one dealer after it cleared on its own and they didn't believe anything I was saying. The 2nd time the issue happened I left the car running the entire time and drove it right to a different dealership. Showed them the issue and a mechanic said he has seen the problem before and the power block behind the dash had to be replaced. If you bring it to a dealership I can give you the info of the dealership that fixed mine to give the details of the parts and the repair.

Yup, I have had these same issues. I have the same issues -- no auto headlights, seat belt charming constantly, and I also noticed turn signal bulbs do not light up AT ALL when this issue is occurring.. Id like to have that information as well. Thank you
 

·
Registered
Joined
·
49 Posts
Yup, I have had these same issues. I have the same issues -- no auto headlights, seat belt charming constantly, and I also noticed turn signal bulbs do not light up AT ALL when this issue is occurring.. Id like to have that information as well. Thank you
Had the seatbelt warning yesterday while driving. Don't know about locks or lights as we were driving during the day. Stopped for a bathroom break and when we got back in, all was fine.

Anyone ever get the info on the parts that need to be replaced?
 

·
Bill
Joined
·
561 Posts
had it happen 5 years ago and never since.
chalk it up to some combination of humidity and the position of the moon...
 
1 - 7 of 7 Posts
Top