Hyundai Genesis Forum banner

1 - 20 of 21 Posts

·
2.0T
Joined
·
325 Posts
Discussion Starter · #1 · (Edited)
AEM Intercooler from Autocityimports

May have A problem here....I'll keep you guys posted when I get a reply back from them again!!


 

·
Ontario Genesis Club
Joined
·
3,356 Posts
Ouch..
Btw, who is the annoy "cool" kid?
 

·
Registered
Joined
·
220 Posts
just getting his post count up. To get back on topic..

Autocity is a reputable company. This is not autocity's issue but AEM's
 

·
2.0T
Joined
·
325 Posts
Discussion Starter · #4 ·

·
Registered
Joined
·
5,262 Posts
Wow! That doesnt look too good
 

·
Registered
Joined
·
5,210 Posts
Was it shipped like that? or when you closed your hood?
 

·
Use the F'n Search Button
Joined
·
4,280 Posts
Was it shipped like that? or when you closed your hood?
I would assume it's when he shut his hood. No reason to waste time installing it, if it had a giant dent from it out of the box.

If it was from hood, damn must of shut the hood pretty hard.
 

·
dead travel fast
Joined
·
458 Posts
I would say it would an issue for AEM and not really auto city imports , I dont think I have seen this issue with that intercooler befor
 

·
Registered
Joined
·
7,839 Posts
well if he installed it and that happened that was his fault n if it came like that should of never installed it so its a lose lose but joe will make the best of this
 

·
Registered
Joined
·
65 Posts
It is most likely like that because of the type of bend needed there. If you look at all the other kits there are 2 bends welded together.
 

·
Gooood! GOOOOOD!
Joined
·
6,450 Posts
There is only so much Joe can do. I think the OP needs to contact AEM at this point. This is in no manner ACI's fault.
 

·
Registered
Joined
·
638 Posts
It would probably be best that the OP clarifies everything.
 

·
Registered
Joined
·
2,221 Posts
OUCH...give us more specifics
 

·
SUN★WORKS
Joined
·
56,362 Posts
I remember this happened with my friends aem intake on his srt4... It ended up being a clearance issue and aem replaced it.. Don't tell if that's the case here or not lol but just saying it's possible
 

·
2.0T
Joined
·
325 Posts
Discussion Starter · #18 ·
Thank you Joe (Autocityimports) problem fixed!! :)
 

·
2.0T
Joined
·
325 Posts
Discussion Starter · #19 ·
I remember this happened with my friends aem intake on his srt4... It ended up being a clearance issue and aem replaced it.. Don't tell if that's the case here or not lol but just saying it's possible
No that wasn't the problem here
 

·
Premium Member
Joined
·
434 Posts
Hey, just noticed this thread (thanks Nikko) and wanted to give an update as to what went down just clear up any concerns about the AEM intercooler kit. Without going into too much detail here's what happened...

"TorontoCoupe" noticed the pipe damage right away but continued install. The AEM intercooler and piping has no clearance issues whatsoever, this situation looks to be either a manufacturer defect or shipping damage. Either way, the situation was resolved and a replacement hot side intercooler pipe is on the way to him :)

**General rule of thumb, not just directed at TorontoCoupe but general info... if you get a damaged item from any retailer (car parts or not) it's better to not use the part. It makes for a much smoother manufacturer warranty claim and/or shipping claim.
 
1 - 20 of 21 Posts
Top