Hyundai Genesis Forum banner

1 - 20 of 23 Posts
Joined
·
1,111 Posts
Discussion Starter #1 (Edited)
Hey guys, so as the title states that is what is happening to me. I checked all the vacuum lines and everything is a-ok. When I get on the throttle and get off its happening but just 5 mins before it happened everything was ok from my drive home after I got off work. Any ideas?


Here is a video I just took....it sounds like surge and my bov is DEFINITELY not opening.


sorry you hear me talking to my sister lol
 

·
Gooood! GOOOOOD!
Joined
·
6,450 Posts
My suggestion is to do an actual leak test first. Don't just check connections. Let us know the results after the fact and we can proceed with the troubleshooting. :D
 

·
FIEBRU MEMBER
Joined
·
453 Posts
+1, but you have to give us more details in your questions.
 
Joined
·
1,111 Posts
Discussion Starter #8
+1, but you have to give us more details in your questions.
When I am accelerating and I let off the gas the bov usually vents the air into the atmosphere but now as you can see in the video it is not opening and making a whoosh sound. All I can hear is a deadly sound from the turbo spinning in the opposite direction :S. From what I've read from the big compressor surge thread it sounds like surge. It should be fixed by tomorrow.
For the time being I will be riding on the oem bpv till I pick up the hks ssqv3.

Thanks to Satheian for the suggestion for trying to reconnect the oem bpv...it blew past my mind.
 

·
FIEBRU MEMBER
Joined
·
453 Posts
Yes, you are back pressuring the compressor blades. What bov r u running?
 

·
It is not red. Not red..
Joined
·
5,706 Posts

·
It is not red. Not red..
Joined
·
5,706 Posts
Joined
·
1,111 Posts
Discussion Starter #14 (Edited)

compressor surge? wastgate chatter? or just a leaking bpv?

You can hear the ssqv3 go off then you hear the noise then it fades like wind blowing by some buildings. Weird way to describe it. Please elaborate on what you guys think it is so I can eliminate it down to one so I can either get a block off plater if it is a leaking bpv, wastegate chatter I am not too sure what to do.
Turbo surge will force me to re-route the vaccum lines.

BTW I was just free-revving. I also get it when I let off the accelerator on boost.
Thanks for that link Satheian, I'm going to try taking the hose and capping the bpv first.
 

·
Ontario Genesis Club
Joined
·
3,356 Posts
I'll have a look at it on Saturday Lance. Its definetly compression surge. Doesnt sound metallic so you're alright for now lol. But we'll definetly go over things for ya :)

Fatnfly
 

·
Ontario Genesis Club
Joined
·
3,356 Posts
All fixed!:)
 

·
Premium Member
Joined
·
4,727 Posts
What was the final verdict and problem
 

·
Ontario Genesis Club
Joined
·
3,356 Posts
It was the way Lance had the vaccuum lines ran. He had followed Super drifts way I think, and we basically changed it to the hks way. I know it was good when he left my shop so ill wait till he posts up.
 
1 - 20 of 23 Posts
Top