Hyundai Genesis Forum banner

1 - 20 of 147 Posts

·
Registered
Joined
·
266 Posts
Discussion Starter #1
I'm so fing tired of this fing car and the shifting!!!!! I drive a 2014 Rspec 2.0 MT and i have been having this problem (don't really know if it a problem or just the way the car is), but no matter what i do this car drops Boost from 1-2 and 2-3 and bogs it just so stupid. I have never experience this on other boosted cars. I know they drop boost, but not like this. My friends 2011 WRX STI doesn't do this, My friends Evo 8 doesn't do this and My friends Prelude Doesn't do this (not boosted) I'm so disappointed by this. I can be at 6RPM 6.5rpm 7rpm (7000rpm with the tune) and then it drops to 4000rpm and if I'm lucky 4200rpm but always building boost every gear change.

I have tried the following
1. I have tired with TC/SC off. Have tried with TC and SC on.
2. Have tried on stock ECU and SFR 1.0.

what is the sweet spot to shift this car. I have been told to shift the car at between 6500rpm - 6800rpm with a tune, but no matter what i have tried it bogs. I have tried shifting super fast/ fast / slow and nothing seems to help. All of my friend that drive the car first thing they ask is WTF.

I have seen many videos of other GC 2.0 with the same thing. I was reading somewhere that the 2013 and 2014 have something different in the tranny, besides the carbon coating what else is different.

check this video out at 3:06 and at 5:09 launching was great, but when it time to shift to 2 gear there goes the bog, it drops all boost and have to build it all over again and drops to 4000rpm it just so annoying.

https://www.youtube.com/watch?v=iHqUKGayfpQ

Any REAL suggestions would be appreciated.
 

·
Registered
Joined
·
266 Posts
Discussion Starter #3
B-spec what are your mods when you made the video? because if my car drove like yours i would be happy. This car shifting is killing me. was that video with a tune or no tune.
 

·
Registered
Joined
·
45 Posts
I'm so fing tired of this fing car and the shifting!!!!! I drive a 2014 Rspec 2.0 MT and i have been having this problem (don't really know if it a problem or just the way the car is), but no matter what i do this car drops Boost from 1-2 and 2-3 and bogs it just so stupid. I have never experience this on other boosted cars. I know they drop boost, but not like this. My friends 2011 WRX STI doesn't do this, My friends Evo 8 doesn't do this and My friends Prelude Doesn't do this (not boosted) I'm so disappointed by this. I can be at 6RPM 6.5rpm 7rpm (7000rpm with the tune) and then it drops to 4000rpm and if I'm lucky 4200rpm but always building boost every gear change.

I have tried the following
1. I have tired with TC/SC off. Have tried with TC and SC on.
2. Have tried on stock ECU and SFR 1.0.

what is the sweet spot to shift this car. I have been told to shift the car at between 6500rpm - 6800rpm with a tune, but no matter what i have tried it bogs. I have tried shifting super fast/ fast / slow and nothing seems to help. All of my friend that drive the car first thing they ask is WTF.

I have seen many videos of other GC 2.0 with the same thing. I was reading somewhere that the 2013 and 2014 have something different in the tranny, besides the carbon coating what else is different.

check this video out at 3:06 and at 5:09 launching was great, but when it time to shift to 2 gear there goes the bog, it drops all boost and have to build it all over again and drops to 4000rpm it just so annoying.

https://www.youtube.com/watch?v=iHqUKGayfpQ

Any REAL suggestions would be appreciated.
If you have an sfr tune which i assume btr does roughly the same thing

quoted from jay
"Now in Stage 1.5, we are making power using mostly boost maps which will make more amount of boost in every gear (peak boost will vary per gear) that it will make your car to go faster at the end."

source: http://www.gencoupe.com/seoulful-racing/132631-sfr-2013-2-0t-genesis-coupe-stage-1-stage-1-5-official-release.html

If you don't have a tune there's your problem, if you do have a tune check your lines and if you find no leaks message your tuner.
 

·
Desert Rat
Joined
·
1,246 Posts
B-spec what are your mods when you made the video? because if my car drove like yours i would be happy. This car shifting is killing me. was that video with a tune or no tune.
I have a BTR Stage 2 Catless 3 inch all the way out.. I have had all the other tunes and I have still not had an issue like you are having even when I had cats. With the BTR tune all you are concentrating on is shifting because red line just flies at you. I would be super pissed as well if I had that much of a drop in boost. You can see it big time in your video.
 

·
Registered
Joined
·
266 Posts
Discussion Starter #7
I'm going to see if i can make a video like yours, but i will see if i can have 3 different cameras to record my Shifting and the dash and hopefully i can see how i can rig something to get my foot work. I can only do a 1-3 shift in the space im gong to do this video. Man if i had it like you i would be fine. The only thing that makes me smile is that there is hope. i really hope it translate to 2014 fine. I'm going to try SFR 1.5 first and tell him about this and then Custom tune. or maybe try a different company is the 1.5 doesn't do the trick.
 

·
Registered
Joined
·
430 Posts
I have a 13 and I only had problem bogging in first if I didn't launch high enough. I would like to see your your cluster during these runs.
 

·
Registered
Joined
·
99 Posts
Maybe try getting the N2MB WOT box and just keep the gas pedal on the floor during pulls. If that doesn't work idk what will.
 

·
Registered
Joined
·
266 Posts
Discussion Starter #11
I'm editing the videos right now but you will see. I also had my friend in his Sonata turbo and man as soon as the shift happen his car left me. he even gave me a heads start. and this was with his stock tune. when he has his SFR canned I have no chance.
 

·
Registered
Joined
·
293 Posts
No offence meant, but I think it's just that your shifting is too slow. I can hear your shift lever slamming into gear and it seems like you're fumbling a bit. Then again, this tranny really does not like to be rushed anyway. You deliberately have to be rough with it to get it to shift quickly. That, and with the clutch engaging near the top just makes for clumsy shifts and you really need to adapt to it.
 

·
Desert Rat
Joined
·
1,246 Posts
No offence meant, but I think it's just that your shifting is too slow. I can hear your shift lever slamming into gear and it seems like you're fumbling a bit. Then again, this tranny really does not like to be rushed anyway. You deliberately have to be rough with it to get it to shift quickly. That, and with the clutch engaging near the top just makes for clumsy shifts and you really need to adapt to it.
:gc-smiley-sign-i-ag

After watching that video your shifting is very slow. I think that is your problem. Your RPMS are dropping way too much between shifts. If I were to launch my car the same way as you my tires would not stop spinning all the way through second gear and into third.
 

·
Registered
Joined
·
134 Posts
If clutch engagement is on top, then don't push the clutch all the way in. As long as you aren't grinding when going into gear, then your clutch pedal is pushed far enough down.

Having no load due to full 3 in TBE...even a wide mouth O2 housing will further enhance this problem. You may spool quicker, but I think the lack of initial load might affect your building boost as you catch the next gear.

You may also be shifting too high rpm. Try shifting around 5500 rpm, and see if you can catch 4000 rpm without losing the load on the engine. The load allows you to build/hold boost.

Just some guessing on my part.
 
1 - 20 of 147 Posts
Top