Hyundai Genesis Forum banner
1 - 20 of 25 Posts

·
Registered
Joined
·
150 Posts
Discussion Starter · #1 · (Edited)
So I've always found my car to be very inconsistent with pick up, sometimes even when the boost needle is all the way it feels very sluggish. Sometimes it seems to take forever to spool to full boost, other times it just doesn't make it up to full boost (at operating temp)...know this has been a common complaint.

Lately my oil temp isn't getting up to what it used to be, and it impacts boost (the first pic is after driving for almost an hour in 5 degree Celsius weather):

No Boost

Full boost (still feel really bogged down with full boost, especially when going WOT):

Boost

The inconsistency is making me crazy, sometimes it pulls like a champ. I'm ordering one of the Kiwi devices to see if I can better track this down because I know exactly what the dealership will say...
 

·
Registered
Joined
·
205 Posts
I do not know if mine is as bad as yours but I notice this as well.

I wonder how common this is?

Is it the nature of turbo cars or what?
 

·
Registered
Joined
·
150 Posts
Discussion Starter · #3 ·
Wish I knew...I'm disgusted buying a new car with this many issues and inconsistencies. The car is totally lame unless it's at full boost, feels like I'm driving a tank, even slower then my first gen. Grannies driving a 50hp tercel fly by laughing / flip me off
 

·
Registered
Joined
·
205 Posts
I will say this.

I do not think the temperature gauge (or any of the stock gauges for that matter) is the most accurate so that may contribute to the problem.
 

·
Registered
Joined
·
150 Posts
Discussion Starter · #6 ·
I want to try to keep it relatively stock, I'm *ok* with the power (while under warranty) as long as it's consistent which it hasn't been. It's got me thinking there is a problem with the bpv or turbo or wategate or who knows whatever else.
 

·
Registered
Joined
·
293 Posts
Wish I knew...I'm disgusted buying a new car with this many issues and inconsistencies. The car is totally lame unless it's at full boost, feels like I'm driving a tank, even slower then my first gen. Grannies driving a 50hp tercel fly by laughing / flip me off
Mine does the exact same thing. Never know when you put your foot down if you're going to see full boost - even when the needle reads the proper temp. I'm with you...pretty disgusted as well actually. Way too many issues/noises/rattles for a brand new car. I have 13,000 kms on mine and it feels like I'm driving a car with 100,000+ kms.
 

·
Registered
Joined
·
150 Posts
Discussion Starter · #9 ·
Agreed +MM+ - this list of issues with this and my old 2010 is exhaustive. I'm surprised there hasn't been something more definitive the collective group has figured out around the inconsistency...we hear about so many weak points like the tranny, bpv, intake manifold, this seems to be quite the gremlin

I really hate finding these issues - I love the look of the car, and when the acceleration is good it's great...Relatively minor things could be updated and it would change the experience dramatically.

After this car I am hanging up my Hyundai hat, and the way it's going it may be going for trade-in sooner rather than later (unless they somehow come out with an ecu update and fix all the other annoyances :squint:). I would have considered an ecu update if it would *fix* the accel issue, but do want to keep it stock...that and things seem to be blowing up on people with tunes
 

·
Registered
Joined
·
154 Posts
I understand where you're coming from. What irks me most is that its almost been a year and they still haven't fixed the extremely loud waste gate rattle. And they dare to say this noise is 'normal' for a car with 500km+ !?! ridiculous!.. I bought the car sounding great, not like a bunch of pop cans rattling under the hood.. i'm looking into local laws about this bc i have a feeling they're going to refuse to replace the turbo(second turbo replacement already)
 

·
Registered
Joined
·
150 Posts
Discussion Starter · #12 ·
Checked and it looks like the boost is OK it just seems really really lame most of the time when accelerating, the odd time its awesome but more often than not it feels like I'm driving a bogged down tank
Even when the boost says 17-18 or so clearly power is being lost somewhere...not sure where else to start checking...
 

·
epic lulz
Joined
·
1,211 Posts
Have you contacted your dealer about the power inconsistencies? I don't seem to have any issues with my car, aside from the wastegate rattle. And I'm now starting to think even that isn't a big problem and is just a trait of electronic wastegates. Have you heard any of the new turbo N20 BMWs? Same kind of design as us, electronic wastegate, twin scroll turbo. The wastegates on those sound like bees in a can, and dealerships all over are claiming it as normal.

Since taking my GC out of storage a couple weeks ago I have a small rattle/buzz coming from my A-pillar, but I gave it a whack and it stopped lol.
 

·
Registered
Joined
·
150 Posts
Discussion Starter · #14 ·
I have spoken to the dealer and there are multiple responses you will get back depending on who you speak with, all chalk up to 'normal operation'.

I have my car in the shop right now for two turbo gaskets, one for the exhaust (a bolt was missing from the factory which caused a minor leak and also warped the gasket warranting replacement), also when they got the turbo out they noticed the manifold gasket to cylinder head was also leaking. Not sure why. Anything else I should ask about that could cause or lead to current / premature / future failure?

I'm hoping the power inconsistency was due to a *slight leak*...
 

·
Registered
Joined
·
4,574 Posts
I have spoken to the dealer and there are multiple responses you will get back depending on who you speak with, all chalk up to 'normal operation'.

I have my car in the shop right now for two turbo gaskets, one for the exhaust (a bolt was missing from the factory which caused a minor leak and also warped the gasket warranting replacement), also when they got the turbo out they noticed the manifold gasket to cylinder head was also leaking. Not sure why. Anything else I should ask about that could cause or lead to current / premature / future failure?

I'm hoping the power inconsistency was due to a *slight leak*...
That is possible.

How did you discover the gasket issue and missing bolt?
 

·
Registered
Joined
·
150 Posts
Discussion Starter · #16 ·
I had heard the mystery rattle when I got my car. I read that it could be turbo, wastegate, heatshield, etc. Brought it in, dealer thought it was a heat shield, tried to tighten a heatshield and stripped the bolt. They had to order another screw in, brought my car in a few months later since it wasn't urgent to have the screw replaced. Still rattling (and slight exhaust noise), checked further and noticed a bolt missing on the turbo. Added / tightened it but the gasket was fried. Ordered in the gasket.

Brought the car back in a few weeks later, once they tore it apart they also found the manifold gasket was leaking. I'm wondering why, a little nervous to be honest...hoping this fixes performance issues and that there are no long term issues / bigger issues at play
 

·
I'd rather do it myself
Joined
·
19,611 Posts
Until you get a second oil temp gage and boost gage you don't really know. You can read boost through the OBDII port , I don't think you can read oil temp though. Maybe now that it is used outside the ECU you can?
 

·
Registered
Joined
·
150 Posts
Discussion Starter · #18 ·
I have an ecu sensor paired up with Torque now on my nexus tablet, and no it does not display the oil temp. I know the gauges in the center console are not entirely accurate, but when it was hitting a certain spot it seemed to full boost, when not at peak OT it would not.

It seems I was getting 16-18 psi - is that reading it before or after it 'exits'...meaning even if there is full boost it will read as such but could be creeping out / bleeding power if there is a leak / not enough back pressure?

Just got the car back, turns out the manifold gasket to the cylinder head was also leaking...not sure if I should be more concerned :dunno:
 
1 - 20 of 25 Posts
Top