Hyundai Genesis Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter #1
Hi everyone, for the past month or so i have been experiencing a variety noises from my brakes. With the cold weather coming here in Illinois, my brakes have been squealing so bad in the morning i can’t stand it. i have the powerstop K6167 brakes kit, slotted and drilled rotors with Carbon Fiber infused ceramic pads. i installed these back in May and didn’t have any issues until now. After reviewing the kit, i realized they didn’t send me all the brake hardware and they also didn’t send me the noise reducing rubber shims. i emailed them and they ended up sending me brand new pads front and rear with all the hardware. Great customer service on their part. i think the noise is a combination of not having the rubber shins, and lack of lubrication. i know it is normal to squeak when they are cold, but not that much, it is excessive and embarrassing to be honest. Also, another noise i hear is when i brake for the first time in reverse i here a knocking noise, and then the same noise when i brake for the first time in drive. it seems so only happen when they are cold, i try to replicate it after driving for a while and warming them up, but the noise is gone after that. any thoughts? also if anyone has had experience with the powerstop kit K6167 id love to hear about it. i want to make sure i install everything correctly when i go to look at them this week. thank you
 

·
Reader of many threads
Joined
·
1,424 Posts
The knocking noise is just the pad moving in the caliper - it's harmless and actually indicates your pad backings are not stuck to the pistons, which is a good thing.

I've only ever had bad all-temperature squealing on semi-metallic pads. I've never used the specific pads you have - I'd recommend you try to re-bed them in after putting the backing and shims in - they shouldn't squeal once the disc and pad surfaces are properly bedded unless the pad material is for competition and designed for extreme temperatures.
 

·
Registered
Joined
·
4 Posts
Hi everyone, for the past month or so i have been experiencing a variety noises from my brakes. With the cold weather coming here in Illinois, my brakes have been squealing so bad in the morning i can’t stand it. i have the powerstop K6167 brakes kit, slotted and drilled rotors with Carbon Fiber infused ceramic pads. i installed these back in May and didn’t have any issues until now. After reviewing the kit, i realized they didn’t send me all the brake hardware and they also didn’t send me the noise reducing rubber shims. i emailed them and they ended up sending me brand new pads front and rear with all the hardware. Great customer service on their part. i think the noise is a combination of not having the rubber shins, and lack of lubrication. i know it is normal to squeak when they are cold, but not that much, it is excessive and embarrassing to be honest. Also, another noise i hear is when i brake for the first time in reverse i here a knocking noise, and then the same noise when i brake for the first time in drive. it seems so only happen when they are cold, i try to replicate it after driving for a while and warming them up, but the noise is gone after that. any thoughts? also if anyone has had experience with the powerstop kit K6167 id love to hear about it. i want to make sure i install everything correctly when i go to look at them this week. thank you
Hi everyone, for the past month or so i have been experiencing a variety noises from my brakes. With the cold weather coming here in Illinois, my brakes have been squealing so bad in the morning i can’t stand it. i have the powerstop K6167 brakes kit, slotted and drilled rotors with Carbon Fiber infused ceramic pads. i installed these back in May and didn’t have any issues until now. After reviewing the kit, i realized they didn’t send me all the brake hardware and they also didn’t send me the noise reducing rubber shims. i emailed them and they ended up sending me brand new pads front and rear with all the hardware. Great customer service on their part. i think the noise is a combination of not having the rubber shins, and lack of lubrication. i know it is normal to squeak when they are cold, but not that much, it is excessive and embarrassing to be honest. Also, another noise i hear is when i brake for the first time in reverse i here a knocking noise, and then the same noise when i brake for the first time in drive. it seems so only happen when they are cold, i try to replicate it after driving for a while and warming them up, but the noise is gone after that. any thoughts? also if anyone has had experience with the powerstop kit K6167 id love to hear about it. i want to make sure i install everything correctly when i go to look at them this week. thank you
Unrelated, Illinois Gen's unite!
 
1 - 8 of 8 Posts
Top