Hyundai Genesis Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
Hey everyone, I’m having a issue with my 2010 Genesis coupe. My car has power to turn on the accessories but when I try to the start the car with the clutch pressed in the car doesn’t even attempt to turn over. I thought it was the battery but i had that tested and it tested good so I’m not too sure what could be causing the problem or possibly the immobilizer. If any one has some ideas please let me know. Thanks also if this was posted before my apologies.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #3
Far as I know, I didn’t have any codes. But I am considering those other possibilities you mentioned. I had it towed to the dealer where I got the car from and he said they it fixed the ground because that’s what I thought it could be but he said it’s doing the same thing.
 

·
Premium Member
Joined
·
15,259 Posts
Far as I know, I didn’t have any codes. But I am considering those other possibilities you mentioned. I had it towed to the dealer where I got the car from and he said they it fixed the ground because that’s what I thought it could be but he said it’s doing the same thing.
Is it push button start?

if so, hold down the button until it starts to crank over. If it works then it's the clutch switch and/or brake switch at the pedal.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #6
The mechanic tried to jump the clutch switch and that’s not working either unfortunately
Is it push button start?

if so, hold down the button until it starts to crank over. If it works then it's the clutch switch and/or brake switch at the pedal.
 

·
Premium Member
Joined
·
15,259 Posts
The mechanic tried to jump the clutch switch and that’s not working either unfortunately
So does it start when you hold down the button? Should be held down for at most 30 sec. If it doesn't start, then there is likely something else wrong.
 

·
Registered
Joined
·
1 Posts
Had the same issue with my 2011 ... It was the clutch switch. Had it changed out and haven't had an issue since.
 
1 - 11 of 11 Posts
Top