Hyundai Genesis Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
I had the competition clutch stage 2 for about 3 years (installed myself) with no issues until it was worn out so I've upgraded to the CC stage 3 and everything has been a total disaster from here.
After much trial and error i.e. Dropping and reinstalling the transmission many times, it seems that the TOB/slave cylinder is contacting the clutch disc and the slave is failing almost immediately. I am able to reinstall everything, bleed the clutch, and get pressure in the pedal, but once the car is started, the SC fails and fluids comes pouring from the bell housing. It seems that the stage 3 disc has a 1/4"-1/2" raised portion around the hub while the stage 2 was flat. I finally took a step backwards and reinstalled the stage 2 and now the TOB/SC was hitting the face of that disc too. Idk what to do at this point? Any help with this would be greatly appreciated.
 

Attachments

·
Registered
Joined
·
302 Posts
that clutch release bearing looks trashed would get a new one, pics 4 and 5 shouldn't look like that.
 
  • Like
Reactions: MrDestinE

·
Registered
Joined
·
15 Posts
Discussion Starter · #3 ·
I've been through several of them now. I have no idea why the disc and SC are hitting. I have a new one waiting to be installed, but idk what would be different for me to expect a different result than the last 5-6.
 

·
Registered
Joined
·
302 Posts
I've been through several of them now. I have no idea why the disc and SC are hitting. I have a new one waiting to be installed, but idk what would be different for me to expect a different result than the last 5-6.
hmmm just checking the disk should have had a sticker on it that tells where which side of the disk should be facing did you check that before install? just asking
 

·
I'd rather do it myself
Joined
·
19,439 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #6 ·
I've been through several of them now. I have no idea why the disc and SC are hitting. I have a new one waiting to be installed, but idk what would be different for me to expect a different result than the last 5-6.
hmmm just checking the disk should have had a sticker on it that tells where which side of the disk should be facing did you check that before install? just asking

Yeah I've check the direction. The disc is in properly. The stage 3 disc would only fit one direction and it's with all of the stickers facing the transmission.
I wouldn't sit properly the other way because it would hit the flywheel bolts.
 

·
Registered
Joined
·
302 Posts
would all so take a look at what red posted before
 

·
Registered
Joined
·
51 Posts
Did you ever find a resolution to this? I am having the exact same issue with mine currently
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #10 ·
Yes. The problem was eventually solved once I ran out of patience and took it to the shop.

The back portion on an old slave cylinder had gotten stuck in the transmission. It had gotten so hot that I was unable to pull it off and it actually looked like it supposed to be there. It came off with a hammer and chisel. The pictures show the silver portion that was stuck in there and what it looked like in the transmission.
 

·
Registered
Joined
·
51 Posts
If you can PM the pic or something that would be awesome. Thanks for the info, I'll check my trans out when I get home from work and hope its the same!
 
1 - 12 of 12 Posts
Top