Hyundai Genesis Forum banner

1 - 20 of 27 Posts

·
301 whp
Joined
·
1,102 Posts
Discussion Starter · #1 ·
Had to remove the Clutchmasters FX300 clutch and flywheel today and have the OEM clutch and flywheel re-installed. The CM was getting stuck in gear on occasion and the frequency was increasing over time. Getting to be a safety hazard. The mechanics pulled everything apart and could not see anything wrong visually. But I had them take it out.
Big difference in feel, damn near put my foot thru the firewall when I got in the car lol.
Looking for another solution, The DTM is out of the picture, too aggressive.
The mechanics here mentioned a Clutch made by AP which was one of the few reliable with the Gen Coupe. Anybody have any info on this? Here in Korea they can get it for 1700.00.(just the clutch) The guys in Korea are having the same problem with clutches.
On a side note they had a 3.8 with twin turbo mod in the shop on the dyno, 530WHP!
 

·
Banned
Joined
·
7,214 Posts
the DTM clutch isn't THAT aggressive... I daily drive it.

look up Competition Clutch, they prototyped a set using the OEM hardware off my car, I'm not sure if they have stock ready though. Worth a shot.
 

·
Out Pissing Off cops!
Joined
·
4,572 Posts
FFS, the only "affordable" setup that I didn't see having too much problems is not out of the picture...

I sure hope a reputable clutch company can make FX200/300, or SPec Stage 2+ or 3 equivalent without any issues soon.

For me it's the fact that my car will be driven in snow, which needs a somewhat tame clutch so I'm not burning up the tire each time I take off from a stop/traffic light.
 

·
Back to Stock!!
Joined
·
952 Posts
Had to remove the Clutchmasters FX300 clutch and flywheel today and have the OEM clutch and flywheel re-installed. The CM was getting stuck in gear on occasion and the frequency was increasing over time. Getting to be a safety hazard. The mechanics pulled everything apart and could not see anything wrong visually. But I had them take it out.
Big difference in feel, damn near put my foot thru the firewall when I got in the car lol.
Looking for another solution, The DTM is out of the picture, too aggressive.
The mechanics here mentioned a Clutch made by AP which was one of the few reliable with the Gen Coupe. Anybody have any info on this? Here in Korea they can get it for 1700.00.(just the clutch) The guys in Korea are having the same problem with clutches.
On a side note they had a 3.8 with twin turbo mod in the shop on the dyno, 530WHP!
is this problem happening to other clutch brands too? could it be the clutch master or slave causing that problem? did u upgrade the clutch hose?

FFS, the only "affordable" setup that I didn't see having too much problems is not out of the picture...

I sure hope a reputable clutch company can make FX200/300, or SPec Stage 2+ or 3 equivalent without any issues soon.

For me it's the fact that my car will be driven in snow, which needs a somewhat tame clutch so I'm not burning up the tire each time I take off from a stop/traffic light.
My stage 3+ and flywheel haven't been a problem and I've driven my car all winter as is.
 

·
Banned
Joined
·
7,214 Posts
I remember the first guy to install the Spec kit had this issue BAD, as in it wouldn't disengage on the rack after they installed it, like at all, LoL.

Gotta wonder if they messed with the lines at all but didn't bleed the system...
 

·
Out Pissing Off cops!
Joined
·
4,572 Posts
My stage 3+ and flywheel haven't been a problem and I've driven my car all winter as is.
^^Didn't you get the "No tach"+CEL for CPS a couple times?

From all the people that replaced their stock Cltuches/FW, QM and MSUgeoman are the only one I saw with ABSOLUTELY 0 problems.
 

·
Back to Stock!!
Joined
·
952 Posts
^^Didn't you get the "No tach"+CEL for CPS a couple times?

From all the people that replaced their stock Cltuches/FW, QM and MSUgeoman are the only one I saw with ABSOLUTELY 0 problems.
I know the problem went away after reconnecting the CMD, so I'm not sure the problem was the flywheel. :dunno:
 

·
Out Pissing Off cops!
Joined
·
4,572 Posts

·
301 whp
Joined
·
1,102 Posts
Discussion Starter · #11 ·
The clutch line was not upgraded, not sure if it need to be. Initially things were just fine. Problems started after about 750 miles on the new clutch. Nor problem driving iin the snow, take up and engagement were smooth and predictable. The lock up became unpredictable, requiring a serious jerk on the shifter, or a slight clutch pedal re-engagement to get it to release. The guys here in Korea, have said it is happening to all aftermarket clutches. So far this clutch from AP is the only one they have seen that does not give problems, and that is with the DM flywheel. But very expensive for them to get.
 

·
Back to Stock!!
Joined
·
952 Posts
The clutch line was not upgraded, not sure if it need to be. Initially things were just fine. Problems started after about 750 miles on the new clutch. Nor problem driving iin the snow, take up and engagement were smooth and predictable. The lock up became unpredictable, requiring a serious jerk on the shifter, or a slight clutch pedal re-engagement to get it to release. The guys here in Korea, have said it is happening to all aftermarket clutches. So far this clutch from AP is the only one they have seen that does not give problems, and that is with the DM flywheel. But very expensive for them to get.
That's something to consider. Upgrade your clutch hose and see if the feel even on the stock clutch changes a bit. It could be part of the issue maybe.
 

·
Registered
Joined
·
1,955 Posts
I didn't upgrade any lines and have nearly 2000 miles on mine since the swap.
Absolutely no such problem.

Jesus, this must be the first time in history I missed the random odd ball problem.
 

·
Flame Thrower
Joined
·
1,124 Posts
This sounds like a slave cylinder issue. EXACTLY what my 300zx TT did. I figured it out when it finally busted a few weeks back.
 

·
Premium Member
Joined
·
1,411 Posts
We have a customer (member here) that had the exact same problem and when we took it apart to inspect discovered a broken slave cylinder. Replaced it and problem solved.

Now if your stock unit is working, that points to something else completely. However if the slave is slowly failing and losing its ability to do its job correctly the stock clutch may work fine for a while.

Curious to see what you find.

Thanks,
 

·
3.5L TT but wrong body
Joined
·
12,003 Posts
^^Didn't you get the "No tach"+CEL for CPS a couple times?

From all the people that replaced their stock Cltuches/FW, QM and MSUgeoman are the only one I saw with ABSOLUTELY 0 problems.
My spec 3+ has been 100% problem free. Going on 8k miles. Reverse is touchy but that's it. vu had his CM Stage 4 take a dump at the track too...
 

·
거침없는 크럿&
Joined
·
376 Posts
Had to remove the Clutchmasters FX300 clutch and flywheel today and have the OEM clutch and flywheel re-installed. The CM was getting stuck in gear on occasion and the frequency was increasing over time. Getting to be a safety hazard. The mechanics pulled everything apart and could not see anything wrong visually. But I had them take it out.
Big difference in feel, damn near put my foot thru the firewall when I got in the car lol.
Looking for another solution, The DTM is out of the picture, too aggressive.
The mechanics here mentioned a Clutch made by AP which was one of the few reliable with the Gen Coupe. Anybody have any info on this? Here in Korea they can get it for 1700.00.(just the clutch) The guys in Korea are having the same problem with clutches.
On a side note they had a 3.8 with twin turbo mod in the shop on the dyno, 530WHP!
are you in korea? If you're talking about the SynchroG 3.8 twin turbo, it's using a Spec 3+ clutch and flywheel, but I wouldn't rock Spec Clutches unless you have a 3.8. they 2.0 specs have engagement issues and the 3.8s are the only ones we've seen that don't have that problem. DTM isn't too aggressive, I don't think, but I've been rocking a Clutchmasters FX500 for a while now. I heard if you get a bigger shim for the throwout bearing in the transmission, it fixes the problem. I only had a problem with getting it into 1st gear from dead stop, and shimmed it out. seemed to fix it, unless if it's really cold.
 

·
301 whp
Joined
·
1,102 Posts
Discussion Starter · #18 ·
are you in korea? If you're talking about the SynchroG 3.8 twin turbo, it's using a Spec 3+ clutch and flywheel, but I wouldn't rock Spec Clutches unless you have a 3.8. they 2.0 specs have engagement issues and the 3.8s are the only ones we've seen that don't have that problem. DTM isn't too aggressive, I don't think, but I've been rocking a Clutchmasters FX500 for a while now. I heard if you get a bigger shim for the throwout bearing in the transmission, it fixes the problem. I only had a problem with getting it into 1st gear from dead stop, and shimmed it out. seemed to fix it, unless if it's really cold.
Thanks for the info. I am in Korea. The 3.8 work was done at BEAT R&D near Osan. Yeah they said to steer clear of Spec.
Think I will stick with the stock clutch for now until it starts to slip, and then go back to the CM with the corrective actions mentioned here.
 

·
Out Pissing Off cops!
Joined
·
4,572 Posts
My spec 3+ has been 100% problem free. Going on 8k miles. Reverse is touchy but that's it. vu had his CM Stage 4 take a dump at the track too...
Orly...Hmm...You might sway me man, I'm starting to see mine slip here and there, and with the cold air, the car pulls like nobody's business and it isn't helping my case at all...LOL
 
1 - 20 of 27 Posts
Top