Hyundai Genesis Forum banner
1 - 16 of 16 Posts

·
Registered
Joined
·
443 Posts
Discussion Starter · #1 ·
Hi,

I have a depo intercooler kit,its really tight against the subframe causing it to rattle,anyone else with the same problem?

Did any of you found a fix for the map sensor hitting the altenator? Thinking about cutting the wires to extend it...
 

·
Registered
Joined
·
721 Posts
I installed mine last weekend and I have no issues with it banging anywhere except my k&n filter. Mine was close to the alternator but then I just pulled it out of the throttle body to move it toward the rad more and tightened the t-clamp and it has about 2 inches room all around it.

Here 2 pics.

Pic 1 - Have cardboard on the left side pipe due to rubbing with k&n




Pic 2 - Shot from left side fender toward engine showing space from alternator



Hopefully this helps
 

·
Registered
Joined
·
443 Posts
Discussion Starter · #3 ·
thanks but i got the older setup the had issues with the map sensor location,does yours come even close to the subframe in between the rad and subframe
 

·
Registered
Joined
·
350 Posts
i have depo racing piping w/ my intercooler that i had from my 240, mine does tap against the subframe on the cold pipe, all i did was to slide a piece of silcone piping on the contact points to muffled the rattles, but my intercooler was different size to the depo racing core, so i had to do some hacking and cutting of the piping to make everything fit, but mine also rubs a lil on the bottom mounts of the rad fans, but no noise, i'll hava take it out and play w/ it a bit more later when it gets warmer
 

·
Registered
Joined
·
721 Posts
You can actually hear the rattles when you drive? I don't hear anything rattling. It is close by the subframe but I don't hear anything.
 

·
Registered
Joined
·
443 Posts
Discussion Starter · #6 ·
Yes up too around 3000 rpm,and idling,i'll try to adjust everything when it get warmer here
 

·
Registered
Joined
·
915 Posts
I get a little vibrating noise at low RPM sometimes. I am buying a longer reducer coupler to try to make it so that the map sensor doesnt rub on the alternator only one company (HPS) makes them longer than 3 inches. They are fuggin expensive though, duno weather to get the 6 inch or the 4 inch...
 

·
Registered
Joined
·
443 Posts
Discussion Starter · #8 ·
I dont think a longer coupling would help me its the flange that's angled too much toward the altenator
 

·
Registered
Joined
·
443 Posts
Discussion Starter · #10 ·
fits good?Can you actually just buy the cold side pipe?
 

·
Registered
Joined
·
405 Posts
This is why the depo intercooler is so cheap you get what you pay for TXS FTW


Sent from AutoGuide.com App
 

·
Premium Member
Joined
·
398 Posts
i have depo racing piping w/ my intercooler that i had from my 240, mine does tap against the subframe on the cold pipe, all i did was to slide a piece of silcone piping on the contact points to muffled the rattles, but my intercooler was different size to the depo racing core, so i had to do some hacking and cutting of the piping to make everything fit, but mine also rubs a lil on the bottom mounts of the rad fans, but no noise, i'll hava take it out and play w/ it a bit more later when it gets warmer
Haha that's exactly what I did a year ago and still working.
 

·
Premium Member
Joined
·
398 Posts
I had a shop cut out and move the map flange away from the alternator. Also found the subframe had rubbed almost all the way through the pipe. $60 total to fix.
 

·
Registered
Joined
·
443 Posts
Discussion Starter · #15 ·
I rather pay 550$ instead of getting raped for an intercooler that is not Worth 1000$++

those are minor issues
 
1 - 16 of 16 Posts
Top