Hyundai Genesis Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
212 Posts
Discussion Starter #1
Like the title states i want to get an o2 housing and PA flash. I was wondering does the flash remove the sec o2 reading? I want to use the second bung for my wideband. I searched and no luck. Thanks in advance!
 

·
Knows some stuff...
Joined
·
6,852 Posts
yes it does, I don't even have an 02 sensor plugged in and I have no CEL. And I can still get CEL's, it isn't like it removed the capability of a CEL. Make sure you tell arvin this, as I think it is a 'custom' feature, I don't think all PA's do this.
 

·
MR TURBO 2 U
Joined
·
862 Posts
yes it does, I don't even have an 02 sensor plugged in and I have no CEL. And I can still get CEL's, it isn't like it removed the capability of a CEL. Make sure you tell arvin this, as I think it is a 'custom' feature, I don't think all PA's do this.
i would agree
 

·
Registered
Joined
·
212 Posts
Discussion Starter #4
Cool thanks. Ill get to ordering.
 

·
Projekt Soju
Joined
·
993 Posts
hey everyone, thought id post this in an existing thread since i couldnt find anything related to what i got going on, anyways

the other day after work i started up the car and got a CEL. i had a friend scan it for me, and it was for the primary cat being removed. the thing is i already have the CEL delete programed in my tune from Arvin. i reset the ecu (neg terminal off the batt for a while) and then flashed the same tune again. it worked for maybe a day or so then came back on this morning.
i also tried flashing to the other tune i have loaded on my PA module. the CEL back on after a min or two of driving. i already contacted Arvin and told him what was going on. waiting on a reply back later on today.

just wondering if anyone else has had this happen? i havnt heard of it before so i could be the first.
 

·
Premium Member
Joined
·
15,369 Posts
technically, it doesn't remove it. It just changes the parameters that it requires to cause a cel.

When tuning any ECU, you can't "delete" fields, you can only change the values.
 

·
Projekt Soju
Joined
·
993 Posts
technically, it doesn't remove it. It just changes the parameters that it requires to cause a cel.

When tuning any ECU, you can't "delete" fields, you can only change the values.
this is true, but the problem still stand that the CEL is showing up when is shouldnt. my ecu is being stubborn. ha
 

·
Premium Member
Joined
·
15,369 Posts
the PA augmented o2 parameters and a spark plug antifouler on the sensors should stop it from throwing the cel. unless its some other o2 cel error.
 

·
Projekt Soju
Joined
·
993 Posts
ill try and pull the code later on today and make sure its the right one, or some different O2 code.
 

·
Projekt Soju
Joined
·
993 Posts
crisis averted, Arvin hooked me up fat!! Arvin's the man.
 

·
Registered
Joined
·
5,262 Posts
yup! i told br to turn off both...
 

·
Registered
Joined
·
815 Posts
I dont see why you wouldnt be able to turn it off, every ECU ive tuned has the option to do so.
 

·
Premium Member
Joined
·
15,369 Posts
ill try and pull the code later on today and make sure its the right one, or some different O2 code.
I've seen 2 or 3 o2 cels.

one for the heater (o2 sensors have heaters in them)
one for it not being connected (which it was)
one for stating that the cat wasn't working.

last 2 kinda go together.
 

·
Registered
Joined
·
572 Posts
Yeah i tried just the defouler trick and my CEL light still came on, I'll have to wait on the PA module.
 

·
Premium Member
Joined
·
15,369 Posts
pull the code,

could be that the sensor is not seeing enough exhaust, seen it happen with mine.
 

·
Registered
Joined
·
572 Posts
pull the code,

could be that the sensor is not seeing enough exhaust, seen it happen with mine.
thanks I'll do that! guess if it's that i might try drilling the hole one size up.
 
1 - 17 of 17 Posts
Top