Hyundai Genesis Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
52 Posts
Discussion Starter · #1 · (Edited)
Has anyone had fitment issues with their EBC yellowstuff on the brembos? I just swapped mine in this week, and double checked the part numbers were correct. None of the pads would fit in. I tried hammering it in but the height of the pad (top/bottom when being inserted) would not fit in the slot. I checked that the pistons weren't in the way. To make it fit my dad helped me grind down each side (without touching the pads) and they went in fine. The rears were off by about 1/8", and the fronts were a few millimeters off. Unfortunately I think one of the pads may have been ground down too much so that sometimes when I touch the brake pedal I hear a clunk sound which makes me think that the pads are being forced from one side to another and that there's too much gap in between them.

They are installed correctly and the brakes work great. Just wondering if anyone came across this? Seems like a weird issue to have assuming I bought the right ones.

Edit: It's worth noting that I did not bleed the brakes yet as I ran out of time but plan on doing so ASAP. However I don't think this is the reason for it.
 

·
Registered
Joined
·
2,032 Posts
Most cars have issue with EBC. You need to file them where they fit in the slots, otherwise they will not function properly.

Sent from my SAMSUNG-SM-G900A using Tapatalk
 

·
I'd rather do it myself
Joined
·
19,453 Posts
They usually give you the wrong part. But I had to grind off a bit on each end so they would float.

DP42147R is what I got and had to file them down.

DP41845R is suppose to fit better.
 

·
Registered
Joined
·
52 Posts
Discussion Starter · #5 ·
Thanks guys - never read about the fitment issue before. I ground down at least one of them too much so it's looking like I'll have to purchase a new set.
 
1 - 5 of 5 Posts
Top