Hyundai Genesis Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
My 2013 Genesis Coupe 2.0T is throwing all four of the following codes:

P2562: Turbocharger Boost Control Position Sensor Circuit
P2563: Turbocharger Boost Control Position Circuit Range/Performance
P2564: Turbocharger Boost Control Position Sensor Low
P06A5: Sensor Reference Voltage "D" Circuit High

This is my first Turbo car and I know next to nothing about them, aside from the basics of how they function.

What happened:

On my way home I noticed my Forge BOV seemed to be quite loud even just normally driving. Like just slowly accelerating from 30-35 would trigger a big blow off when normally there wouldn't be one at all, since I was accelerating slowly.

Later that evening, I was driving up a hill and the BOV seemed to almost "get stuck" in that as I was accelerating, it was just a constant "Whooooooooooosh". I thought maybe the BOV spring was dead so I replaced it with a stiffer one that came with the package.

I drove the car around the neighborhood and the turbo then barely did anything. Maybe 5 psi. No blow offs at all. I switched the spring back to the one I had in the car and same thing. I drove the car to get the CEL checked and on the way it just felt like I had no turbo at all. The dial would still go up to like 5psi or so, but the car was massively slower and never had enough pressure to even blow off.

I read a possible solution to P2564 is a new Electronic Waste Gate Assembly ($300, from what I can tell). Those threads were only throwing one code, though, not four. Can anyone give me more information on this issue and what parts to buy? I am a broke college student and don't have the money to take it to a shop, nor can I just buy every part people theorize could work.

Help please!
 

·
Premium Member
Joined
·
14,842 Posts
what year is it?

If it's a 13-16 then check the connector to the wastegate actuator.

Unplug and plug back in.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #3
what year is it?

If it's a 13-16 then check the connector to the wastegate actuator.

Unplug and plug back in.
Tried that, didn't change anything. but thanks for the suggestion. Anyone else had an issue like this that they have successfully fixed?
 

·
Registered
Joined
·
91 Posts
I'm almost sure it's your wastegate. It's getting stuck open which makes the constant whoosh which you are probably mistaking as your BOV. and then the BOV popping open at lower rpms is your wastegate being stuck closed which is forcing air out whichever way it can find. And not building any boost is another sign of the wastegate being stuck open. It is odd for it to be doing both though... Stuck open/stuck closed cuz usually it's just one or the other which triggers 1 or 2 codes which could also explain why you're getting 4 codes but all 4 codes do appear to point to the wastegate. 300 bucks for a new wastegate is the normal price and it takes about 10 to 15 minutes to swap it out. If it were me in your shoes id go out on a limb and buy the new wastegate.
 

·
Registered
Joined
·
7 Posts
Honestly o had same issue. I had to replace the wastegate actuator and also the whole turbo itself before cel came off. The actuator was about to give out and the turbo find were hitting the sidewall of itself. Which causes some of the infamous Genesis engine rattles.
 

·
Premium Member
Joined
·
14,842 Posts
Honestly o had same issue. I had to replace the wastegate actuator and also the whole turbo itself before cel came off. The actuator was about to give out and the turbo find were hitting the sidewall of itself. Which causes some of the infamous Genesis engine rattles.
The fins, sounds like the turbo wasn't balance properly. I doubt it's the turbo, unless he miraculously has the same turbo issue.

CELs will persist until it sees consistent clean readings for a little bit, like about a day of driving. Unless you cleared them out and they came back.
 

·
Registered
Joined
·
7 Posts
Yeah, cleared the codes and it came back. At first was throwing 5 codes all of the same as etchlipsis and one other, forget what the last was cause it's been a few months but all issues since are gone.
 
1 - 7 of 7 Posts
Top