Hyundai Genesis Forum banner
1 - 8 of 8 Posts

·
Registered
2013, Genesis Coupe, 3.8, Track
Joined
·
13 Posts
Discussion Starter · #1 ·
So I got this today, just crusing around town and I do have test pipes installed but sure has nothing to do with this, anyone know which O2 sensor this is faulting? Which side and the one before or after the tipes?

Font Handwriting Rectangle Circle Art
 

·
Registered
Joined
·
62 Posts
I had this exact same code a couple months back and it went away on its own. I didn't have any issues with my car either it just popped up one day and about a week or two later it went away. I have a catback exhaust and test pipes too.
 

·
Registered
2013, Genesis Coupe, 3.8, Track
Joined
·
13 Posts
Discussion Starter · #4 ·
I’ve been told by a couple people and a local auto shop to use Catalytic Converter Cleaner from autozone or advance auto parts, worth a try? I’ve had this code for maybe 2-3 months now and when I clear it out it comes back after a couple days
 

·
I'd rather do it myself
Joined
·
19,573 Posts
Won't do any good.

look at the post cat O2 sensor voltage when driving. Once warmed up and cruising down the road at a steady speed, the voltage should be fairly steady and above .550 and below .750. It may go beyond those numbers when slowing down or speeding up.

if it is wandering around similar to the pre cat O2 then it's bad cat.
 

·
Registered
2013, Genesis Coupe, 3.8, Track
Joined
·
13 Posts
Discussion Starter · #6 ·
I dont have cats anymore though

I replaced them because of the light and put test pipes from a rattling noise it had with original cats but the light still came back on after a week.
 

·
I'd rather do it myself
Joined
·
19,573 Posts
Yes well, you got bad cats.

You can get a tune to shut the light off if you want.
 

·
Registered
Joined
·
62 Posts
Also Hyundai has an 8 year 80k miles warranty on emission parts. When my code came on I was going to take it to the dealership to get it covered under warranty but it turned off.
 
1 - 8 of 8 Posts
Top