Hyundai Genesis Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
913 Posts
Discussion Starter #1
Help my radio is turning off and Bluetooth shows up --------------------------------------------------------------------------------

idk what happen i washed my car and started it up and my radio when blank and BT showed up and screen was blank and it shuts on and off every 30 secs or so even when the radio is off..... Help i put a video

Please help!!!!
 

·
Registered
Joined
·
32 Posts
Whoa! The same exact thing is happening to my 2010 3.8! Just started yesterday too! I didn't do anything out of the ordinary, so I dunno what caused it. I didn't have my phone's Bluetooth on, nor did I turn on the car's Bluetooth either.

Tell me if this sounds familiar: If I try to connect my phone via Bluetooth, it takes like five minutes to do so, and I have to hit "Connect" in my phone multiple times for it to connect. That's the only time I can get into the BT menu. Once I'm in that menu, I try to turn off Bluetooth, but it just jumps to the "Listening" screen. Plus there is no sound from the Bluetooth system at all. The radio/CD/iPod system works fine, except that it gets interrupted like yours does in the video. Tried to fix it myself, but couldn't find a way. Made an appointment for Tuesday at the dealer, so we'll see if it gets fixed.
 

·
Registered
Joined
·
913 Posts
Discussion Starter #3
atleast the dealership cant blame us since there is more than one issue... im pissed cause i have a car show tommorow
 

·
2012 Gen. 3.8 Track w/ZF
Joined
·
763 Posts
Try pulling and then re-inserting the "Memory" fuse in the fuse box in the car. I had a bunch of elect. crap going on at the same time, including my TC was acting up. My radio and Nav all stopped working too. I tried the memory fuse and it all started working right again. Don't know why, but it did. Only kicker was having to reprogram all the presets,
 

·
Premium Member
Joined
·
15,259 Posts
It's the firmware for the radio.

after 2 separate firmware upgrades, I still had the issue.
Just about drove me insane.

I yanked that bitch out and installed an aftermarket unit.
 

·
Registered
Joined
·
3 Posts
Whoa! The same exact thing is happening to my 2010 3.8! Just started yesterday too! I didn't do anything out of the ordinary, so I dunno what caused it. I didn't have my phone's Bluetooth on, nor did I turn on the car's Bluetooth either.

Tell me if this sounds familiar: If I try to connect my phone via Bluetooth, it takes like five minutes to do so, and I have to hit "Connect" in my phone multiple times for it to connect. That's the only time I can get into the BT menu. Once I'm in that menu, I try to turn off Bluetooth, but it just jumps to the "Listening" screen. Plus there is no sound from the Bluetooth system at all. The radio/CD/iPod system works fine, except that it gets interrupted like yours does in the video. Tried to fix it myself, but couldn't find a way. Made an appointment for Tuesday at the dealer, so we'll see if it gets fixed.
Mine is doing the same thing!! Did you solve the problem???
 
1 - 8 of 8 Posts
Top