Hyundai Genesis Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
44 Posts
Discussion Starter #1
I was wondering if anyone could help me. I bought new headers and test pipes but there's only one O2 so how do I make it work?
 

·
Registered
Joined
·
44 Posts
Discussion Starter #3
I got everything hooked up but now I have no power, the door light does not work or with the car even try to start when I turn the ignition. I think that I blown a fuse because I forgot to disconnect the battery before working. Any idea which fuse if any I have blown?
 

·
I'd rather do it myself
Joined
·
18,572 Posts
If the memory fuse is good and the dome lights don't work then there is a 50A fuse in the engine fuse box that feeds the interior fuse box where the memory fuse is.
 

·
Registered
Joined
·
3,093 Posts
Sooooo did you find the other 02 sensor bung? lol
 

·
I'd rather do it myself
Joined
·
18,572 Posts
It still has air in it. You need to go through at least three heat/cool cycles with the cap on to fully purge the air.

You should only take the cap off when it is dead cold. And then the coolant should be completely full in the radiator.

If there is an air leak it will not pull coolant from the expansion tank on cool down. It will suck in air instead.

A good place to vent the system when filling is one of the throttle body hoses. Pull the hose off the TB and raise it up higher than the motor. Then slowly fill at the radiator. You have to pinch off or plug the other TB hose of it will come out of the TB.
 
1 - 17 of 17 Posts
Top