Hyundai Genesis Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Okay, I took a wrecked 2013 Coupe 2.0t and removed complete engine, 6spd Trans, ecu, and engine and body harness and swapped it into my bagged mazda b2200 lol. Engine and tranny went in smooth. Harness was not as fun but it's all in and wired up. Here's the deal... when I turn the key it will crank but it's like the ECM is not turning on fuel or spark or anything. Cluster shows airbag light and that's it. If I shoot power to ECU fuses with my power probe, on pass side engine fuse box I hear some clicks and the cooling fan turns on. I have all my grounds connected and have checked them with MM and all seem good. I'm kind of at a loss now.. bad ecu? Missing something detrimental or what... any input will help. And by the way it is a non chippewa key just base model key. I have a universal 4 post ignition switch hard wired to ignition switch wires if that makes a difference. Thanks amd look forward to any help
 

Attachments

·
Registered
Joined
·
5 Posts
Discussion Starter · #2 ·
Forgot to add. The ECU is not decting the ecm when I hook up my scan tool. It will detect bcm but for some reason I'm not getting ecu signals. Maybe bad ecu or idk that's where I'm stuck.
 

·
I'd rather do it myself
Joined
·
19,184 Posts
It needs to see a key in input, probably to the BCM.

Isn't the regular key start still use a transponder key?
 

·
Registered
2011 Hyundai Genesis Coupe 2.0T Premium 6MT - Silverstone
Joined
·
397 Posts
This thing is so cool and unique
 
  • Like
Reactions: Ma5t3rmeckanick

·
Registered
Joined
·
5 Posts
Discussion Starter · #6 ·
It needs to see a key in input, probably to the BCM.

Isn't the regular key start still use a transponder key?
It is a non transponder key model. No SMARTA system or whatever it's called.

There is a "keysense" om stock ignition... I wonder if those wires should be grounded to 5-12v with key inserted?
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #8 ·
Bump... anybody else got any input on this. Havent been able to spend a lot of time on it but im still stuck with this problem. Any advice would be appreciated.
 
1 - 8 of 8 Posts
Top