Hyundai Genesis Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I have a 2013 2.0 Turbo Premium. I do not drive it a lot and it is not unusual for it to sit for several days. Last week I started it up and the Nav screen stayed dark and my radio played for a few seconds, went silent for a few seconds, played for a few seconds and kept repeating. I drove down the road randomly pushing buttons that should change the display or radio station to no avail. After about 5 minutes, it came back on and ran fine for about 2 minutes and then went out again. Came back on about a minute later and stayed on, even between turning the car off and on. Did not drive it again for a few days and did so today. Exact same scenario as before, even to the point where it came back on (both times) at the same point in my ride???!!!

Looking for thoughts and experiences and very inexpensive ways to deal with it lol. Any help appreciated.
 

·
Premium Member
Joined
·
15,457 Posts
First thing I would do is write down all your radio settings and disconnect the battery and put it on a trickle charger.

This does 2 things. It resets all the computers in the car, and it will charge up the battery just in case it's a low voltage issue.

if it happens again, get the battery tested. If it's good, then it's probably the radio.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Thank you for the reply and sorry for late get back. Have been waiting as oddly enough it has not done it again since the second time! Doesn't matter if driven daily or sits for a week. The low voltage seems to make sense and will look at that if/when it returns. Thanks again.
 
1 - 3 of 3 Posts
Top