Hyundai Genesis Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
When I'm using the shift paddles do make a hard launch from a dig. The car goes to 8k rpms and you can't shift it until the rpms come back down ,then you can shift up to 2nd. I have notice this only happening on concert pavement. On black top pavement it hooks hard and shifts every time . I've tried many attempts to get this to happen on black top and it wont.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #5 ·
I have and I'm also SFR tuned. I have had the tune sense May and never had this problem before until last month it started to do this. I have talked to the guys from SFR and they are saying it's not their tune that's causing this to happen. I have asked and looked everywhere for answers and nobody has experienced this problem.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #7 ·
That's is correct which is another problem because even with the SFR tune I can only go to 6200 rpms no higher but when it dose this slipps like feeling it goes to 8k rpms full redline.
 

·
Registered
Joined
·
283 Posts
Wow ok... You mentioned feeling like it's slipping... So when it does this, it doesn't launch hard, but rather the tranny itself feels like it's slipping?
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #9 ·
That's correct it starts to launch hard then you go no where. when this feeling of sleeping happens you can hit the gas but all it does is rev up the rpms while in 1st gear and goes no where. If you let the rpms down to like 3000 then you can shift it to 2nd.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #10 ·
I no for a fact you should not be able to use 1st gear as if it was in N. When it goes to 8000 rpm you can keep hiring the gas and would act like I was in N.
 

·
Registered
Joined
·
283 Posts
Yeah no that's definitely a problem... 1) You should never be able to hit anywhere near 8k under normal circumstances.... 2) the tranny shouldn't slip like that... As far as causes...I'm not an expert (or anything close) in auto tranny's (I have a manual myself), so hopefully some folks with far more knowledge than I will also comment here... That being said, try not to hit 8k anymore. It's particularly bad for our 3.8's
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #12 ·
Update... I think I might have fixes my issue. I took off oil catch can and cold air. I put the oem cold air back on. Now all my car dose with a hard launch is take off no more slipping. I'm not sure why my aftermarket cold air and oil catch can can cause the transmission to slip?
 
1 - 12 of 12 Posts
Top