Hyundai Genesis Forum banner
1 - 14 of 14 Posts

·
Have you seen my pants?
Joined
·
50 Posts
Discussion Starter · #1 ·
So I have a 2010 GenCoupe 3.8 Auto with 6000 kms, lately I have noticed a popping / banging sound coming from the front suspension when I travel over bumps. They don't have to be large bumps, even a little dip in the road produces this popping sound. It occurs on both driver and passenger sides. I have done no mods whatsoever and I barely drive the damn thing. Anybody have similar issues? What was the outcome? I have an appointment at my local dealer for next week to check this out. Any input would be greatly appreciated.
 

·
Registered
Joined
·
251 Posts
You'll get used to it lol,

I have the same problem, popping sound comming from the front suspension and sometimes from the back. The sound is noticed only on low speeds.

4 visits to the dealer and the issue is still not resolved, they still cannot locate where the sound is coming from exactly.

I hate the suspension of this car because its generally feels weak and cannot handle the weight of the car.
 

·
2.0T
Joined
·
325 Posts
Probably A loose nut on one of your anti sway bars.....I had A popping sound and this fixed it. I Had to heat up the nut first tho.
 

·
Have you seen my pants?
Joined
·
50 Posts
Discussion Starter · #4 ·
Probably A loose nut on one of your anti sway bars.....I had A popping sound and this fixed it. I Had to heat up the nut first tho.
I hope it is something as simple as this...I just don't want this to become a constant problem. I will find out on Thursday.

Thanks for the replies :)
 

·
Registered
Joined
·
1,355 Posts
yeah check the sway linkage at the strut. 19mm just went over my suspension yesterday doing adjustments and noticed i had one looser than i wanted.
 

·
Knows some stuff...
Joined
·
6,852 Posts
my fault, I ment to quote the second post
You'll get used to it lol,

I have the same problem, popping sound comming from the front suspension and sometimes from the back. The sound is noticed only on low speeds.

4 visits to the dealer and the issue is still not resolved, they still cannot locate where the sound is coming from exactly.

I hate the suspension of this car because its generally feels weak and cannot handle the weight of the car.
read this thread
http://www.gencoupe.com/general-discussion/36297-rear-end-noise.html


To the OP, Try to push down (if your are srtong enough) or pop your hood and stand somewhere inside (obvoiusly chose a strong area to do this) and jump up and down flexing your suspension to see if you hear it. To rule out if it is a moving issue only or a all around suspension problem.
 

·
Registered
Joined
·
251 Posts

·
FUNCTION OVER FORM
Joined
·
5,383 Posts
I'm going to put my car on jack stands, pull all the torque specs for all suspension bolts from the Hyundai Service Website & torque all the bolts underneath my car. That way I will know if any are left loose, because I'm tired of the popping/knocking noises I hear from my suspension intermittently.
 

·
Have you seen my pants?
Joined
·
50 Posts
Discussion Starter · #11 ·
I'm going to put my car on jack stands, pull all the torque specs for all suspension bolts from the Hyundai Service Website & torque all the bolts underneath my car. That way I will know if any are left loose, because I'm tired of the popping/knocking noises I hear from my suspension intermittently.
Good thinkin.....I hate noisy suspensions with a passion, it really cheapens the feel of the car IMO
 

·
Registered
Joined
·
1,810 Posts
I'm bringing mine in on thursday to have it checked also. I got a rattle/knock coming from the rear on the driver's side when I go over bumps.
 

·
Registered
Joined
·
1 Posts
Anyone figure it out?? Mine is a 2011 3.8 track 6 speed. I'm having a popping problems in the front and starting to have a clinking sound when I pull out and back up.

I just out in links in, the one on the driver's side broke off my bc set up. Swapped back to oem instead and it started have a popping type hitting noise again. Kind of like a in link, but I wouldn't think it would have broke again... happens when I go over bumps mainly..

The clink sound I'm hearing sound like it's in the middle. Can really tell what side bc sometime I hear it on driver's then other times I'm hearing it on passanger. I did break diff bolts and mounts twisted an axel. I replaced it all. Even put a new driveline in and couplings. I don't get it... could it be my shift linkage??
 

·
Registered
Joined
·
1,457 Posts
There was a known problem with spot welds on the inner fender apron near the firewall failing and causing what your describing. Just a possibility.
 
1 - 14 of 14 Posts
Top