Hyundai Genesis Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1 (Edited)
Hello fellow mbr's I have an issue with my car that i'm trying to pinpoint. First, no accidents. The power window driver side when you open the door goes down slightly which is normal, closing it also seals, normal again. When i try to make it go down or up using the switches it just won't go. Any ideas if it's the motor or regulator causing this? 2.0T Base Genesis Coupe 2010
 

·
Premium Member
Joined
·
15,282 Posts
Hello fellow mbr's I have an issue with my car that i'm trying to pinpoint. First, no accidents. The power window driver side when you open the door goes down slightly which is normal, closing it also seals, normal again. When i try to make it go down or up using the switches it just won't go. Any ideas if it's the motor or regulator causing this? 2.0T Base Genesis Coupe 2010
Sounds to me that its an issue with the switches
 

·
I'd rather do it myself
Joined
·
18,711 Posts
Attached to the motor at the connector there is a 'safety ecu' for that window. It detects if there is an object jamming and also provides the short drop. But the auto up/down and stepped up/down go through it too. So I would guess that is what is bad. And I believe it is part of the motor.

I have a thread where I though that was the problem with mine when getting the hard bottoming but was the stops themselves. The wire diagrams and talk of the safety ecu are in it. Power windows hard bottoming
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Thanks for all the info guys! I'm going to take it apart tonight and see what the issue is. Just don't want to bring it to a garage for a slight inconvenience for drive thru access lol
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
A few days later... sorry! I ordered and replaced the power motor and inspected all connections and there fine. Went to try to open and close the window and now its just dead. I was wondering then what the actual issue would be and pulled apart as well the regulator. I manually was able to slide it up and down. Seemed to stick alot so I greased up the slide itself and was alot easier to move it. I installed everything back in place and tried again and it still doesn't work. It doesn't even push it up into the window seal when door is closed. The passenger side window button still works and goes up and down fine so I'm not sure if its just the button itself that may have a disconnected wire or is there a way to recalibrate the window itself after a replacement part failed? Any ideas would be very much appreciated! Thanks
 

·
I'd rather do it myself
Joined
·
18,711 Posts
If it is not going up or down it's not calibration. You are going to have to see that when you push the switch you get a ground to the motor. It would be a separate wire for each direction. it's all a ground at the switch except for the hot for the lights.

Safety ECU is the motor connector.




 

·
Registered
Joined
·
5 Posts
Discussion Starter #8 (Edited)
I took a look at the ground wires but it all seems fine. I tried a ECU reset and the window worked all morning no problem! Sealed when open and closed, went all the way up and down no problem. This afternoon though it went back to only sealing but no window function when driving. Any other ideas?

Edit It worked again this morning for about 15 minutes then nothing again lol Starting to think it may just be the switch is faulty at this point.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #10
I didn't dissasemble it so I'll do that after work. Its got to be a random loose connection somewhere in there. Everything else is working great in the driver door when it allows me to move it. New motor and nothing wrong with the regulator. It's gotta be a spotty connection noticing how erratic it behaves.
 
1 - 10 of 10 Posts
Top