Hyundai Genesis Forum banner

81 - 91 of 91 Posts

·
Registered
Joined
·
1 Posts
Had a funny clunking noise from my trunk when I accelerated, stopped or turned sharply. Looked in the trunk when I got home to find that an orange had escaped my sack lunch and was rolling around on the flat trunk floor.

Other that that, my 2012 2.0t premium has been great! No problems.
 

·
BBoost Me Baby
Joined
·
713 Posts
Wow, i think i might be the only one with out that much except for the damm tranny not opening the gates to switch sometimes but thats all, i haven't really noticed anything or im too dumb to notice. but will keep an eye out.
 

·
Registered
Joined
·
30 Posts
I'm with ya BoosRider - but I have only had mine a month soo. I'm still a newly wed but I'm the kind that researches the crap out of what I get so when I get it - it's love for life.

As well, I have a solution for the seatbelt issue but am gonna see if I can get a prototype made and make some change. I would gather I will test them out cheaply for the family here. Anyone wanna work with me are welcome to ping me. We'll need investors, manufacturers, designers etc.

Talk to you soon GenFam.
 

·
Registered
Joined
·
33 Posts
Is anyone having O2 sensor problems?
I have 2011 2.0 R-Spec, 8,000 miles... purchased back in 1 OCT 2010.

Around March 2011, I went on 2 week vacation... when I returned, my car flipped a check engine light. Took it to the dealer, the next day they told me they need to replace the O2 sensor. OK cool, they replaced it.

Fast forward to SEP 2011... I've been deployed for 5 months now, my roommate drives it once a week. Just last week, the car has another check engine light.
I'm assuming its the O2 sensor???
 

·
Senior Member
Joined
·
211 Posts
As well, I have a solution for the seatbelt issue but am gonna see if I can get a prototype made and make some change. I would gather I will test them out cheaply for the family here. Anyone wanna work with me are welcome to ping me. We'll need investors, manufacturers, designers etc.

Talk to you soon GenFam.
Put a magnet behind the trim piece where the buckle rests, works great. Guy on here did a DYI on this a couple months ago. You don't see anything, the buckle just magically(magnetically) clicks onto the panel and no noise.:bowdown:
 

·
Registered
Joined
·
30 Posts
As well if anyone is interested. I put my wings on front and back. The top down method i found on youtube didn't work for me. My hands aren't that big but I didn't want to risk busting my front end to have a rattling new ride.

- So I took off the air dam under the front bumper
- Undid the expansion fasteners on the top of the grill and that did give me room to pry it a little bit and look behind it (hand was not gonna make it and come back unharmed)
- couple screws later and the job was don son ...
- made a video but gotta trip it down and figure how to get it uploaded to the YouTube
 

·
Senior Member
Joined
·
211 Posts
As well if anyone is interested. I put my wings on front and back. The top down method i found on youtube didn't work for me. My hands aren't that big but I didn't want to risk busting my front end to have a rattling new ride.

- So I took off the air dam under the front bumper - Undid the expansion fasteners on the top of the grill and that did give me room to pry it a little bit and look behind it (hand was not gonna make it and come back unharmed)
- couple screws later and the job was don son ...
- made a video but gotta trip it down and figure how to get it uploaded to the YouTube
Why didn't you just remove the emblem from there, that's what I did. Didn't touch any screws from grill.
 

·
Registered
Joined
·
30 Posts
I did think about just using the double sided tape that came on the badge but I don't trust the double sided tape and wanted to use the screws for added security.

Just anal about some stuff for the most part. I didn't want a chance of that sucker coming off in a high pressure car wash or when I'm cruising down the road at Mach 2.
 

·
Registered
Joined
·
1 Posts
I have a 2012 genesis couple 2.0 turbo. I've had recent AC issues - mechanic first blamed the expansion valve, then the hoses, now the compressor which i'm having to get replaced. window motors sometimes do not work correctly and windows get temporarily stuck halfway up. I just keep trying the button and it eventually works again. lights behind the buttons where you choose AC vs defrost vs heat is going out.

Other than that this car is great. It handles really well and I feel safe driving it in wet weather or around turns. Just wish I didn't have these issues above right after the warranty went out!
 
81 - 91 of 91 Posts
Top