Hyundai Genesis Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Hello guys,

I own a 2013 2.0T with 117k km on it, bone stock. Recently bought it and had no issues at all ran fine even at heavy loads. Just two days ago, at WOT the car would be really sluggish, then start to jerk really hard and misfire on cylinder 4. I replaced the sparkplugs, and still would do the same thing.

Today I have also noticed a really rough noise that's only there on extremely cold starts. Started the car after leaving it overnight (13 hours), that's the video. Took it the shop the mechanic let it cool down for 5 hours and nothing. There are no codes except the misfire on the 4 cylinder. Left it there overnight, but any help would be appreciated.

 

·
Registered
2014 Hoondai 🏎️💨 GC 2.0T FBO+SFR
Joined
·
99 Posts
Okay so you said misfire do that can indicate four things. We have no ignition, or no gasoline, or no air and/or no compression.
So if you replaced sparks and still have misfire on c4 then swap the ignition coil with a different cylinder and see if the misfire follows, if the misfire follows the coil then you have at least 1 bad coil. If it stays misfire on c4 then check the wire harness to coils if failed repair and retest and if pass perform compression if fails then engine is gone if pass then check fuel injector.

What mechanic shop you taken it to and they say nothing🤯?
Let us know how it goes.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
Hey, appreciate the reply.

No, we know that there is a misfire issue, and probably the coil will be replaced. Don't know if it is a compression issue, the misfire is only at WOT. I will find out about thay tomorrow when I test it.

I'm more worried about the rough cold start. If you want to checked the video I attached in the dodgy site. The noise is only there for a minute then nothing and only during cold starts (10+ hours )
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #5 ·
Oh, sorry about that. So, yes I got a coil that was fried and it was swapped. However the bigger issue is the previous owner rewired the electrical from the coil all the way to the ECU. It was soldered on the ECU and it fried the coil when it got rusted.

Both me and the mechanic are baffled why would someone do that. Why not splice into the wire already there and what happened that made him go to that extreme.

The video for the rough cold start up is at Streamable Video -Rough start up

Still can't figure it out and it's only for 1 minutes on colder days.
 

·
Registered
2014 Hoondai 🏎️💨 GC 2.0T FBO+SFR
Joined
·
99 Posts
When you first start up the engine and it makes a loud hissing sound from the turbo and BOV.
In my car when first start up the blow off valve opens up all the way and the turbo blows at about 0psi until after 1 minute then turbo goes down to -19psi.
 

·
Registered
2014 Hoondai 🏎️💨 GC 2.0T FBO+SFR
Joined
·
99 Posts
I could not hear a grinding at first, all I could hear was loud air noise that is why I thought it was BOV or Turbo.
I heard the light grinding now. Does it sound like is coming from the front of the engine? Or inside the engine?
 

·
Registered
Joined
·
413 Posts
First things first check your spark plugs. Swap #1 and #4 and visually check them. If the problem is only under heavy throttle it's likely spark blowout. If you have an OBD2 scanner check your AFR and timing under full throttle and post the results. BK2 stores all that info.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #10 ·
I could not hear a grinding at first, all I could hear was loud air noise that is why I thought it was BOV or Turbo.
I heard the light grinding now. Does it sound like is coming from the front of the engine? Or inside the engine?

It's mainly the front of the engine. We checked all the belt tensioners there nothing was alarming. Still can't figure it out.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #11 ·
First things first check your spark plugs. Swap #1 and #4 and visually check them. If the problem is only under heavy throttle it's likely spark blowout. If you have an OBD2 scanner check your AFR and timing under full throttle and post the results. BK2 stores all that info.
Hey appreciate the reply! The misfire has been fixed, indeed it was a bad coil due to its wiring being soldered. Overtime corrosion made the connection loose and fried the coil. But we can't figure out why would someone do that.

The grinding noise is still a mystery.
 

·
Registered
Joined
·
413 Posts
Hey appreciate the reply! The misfire has been fixed, indeed it was a bad coil due to its wiring being soldered. Overtime corrosion made the connection loose and fried the coil. But we can't figure out why would someone do that.

The grinding noise is still a mystery.
Did you post a video of the noise? Misfires on the BK2 are easy so I'm glad that's resolved. Swapping spark plug or coil pack 1/4 or 2/3 gives a good idea. I'm wondering if you have wastegate rattle at start up like most of us. It's worst in the winter and when it's cold and you turn the AC/defrost on.
 

·
Registered
2014 Hoondai 🏎️💨 GC 2.0T FBO+SFR
Joined
·
99 Posts
Good progress with the misfire. On the noise from the front of the engine could be either a water pump going bad or the chain ⛓ is not as tensioned as it should. These cars are known for loose chains too but it's weird that you are only at 117k.
 
1 - 13 of 13 Posts
Top