Hyundai Genesis Forum banner

1 - 20 of 91 Posts

·
Registered
Joined
·
465 Posts
Discussion Starter #1
Hello,

I've searched the web, and this forum, and haven't found anything about this specific to the Genesis Coupe. I did see a thread about it regarding Genesis Sedans, however.

I've only had my car a couple of days, but when I was driving today, every minute or so, the seat belt warning light would come on and flash for 5 or 6 seconds, then go off again. I was alone, and I was wearing my seat belt. I did disconnect it and reconnect it several times. It made no difference.

I got out for a bit to play tennis, and when I got back in, it wasn't doing it.

Anyone else experience this?
 

·
Premium Member
Joined
·
15,173 Posts
the pass seatbelt light on the center deck light up too? Try buckling the pass seatbelt and see if it happens again, then unbuckle it and see if it's still there , so you'll isolated what isn't working right when you take it to the dealer.
 

·
Registered
Joined
·
465 Posts
Discussion Starter #3
I actually tried buckling the pass. seat belt; it had no effect.

I wondered if maybe the seat belt indicator had some sort of secondary warning function. I tried opening and closing my door too, but that had no effect. And oddly, my "open door" light didn't come on when I did it...
 

·
Former GTO hater/ owner
Joined
·
603 Posts
Anything on the passenger seat lower cushion (like a lunchbox, cd storage container, etc)?
 

·
Registered
Joined
·
465 Posts
Discussion Starter #5
My wallet. But I buckled the passenger belt and it still did it.

Funny thing is that when it was doing that, the open door light wasn't on when I opened my door to see if that was part of the problem.

Hasn't done it since, and now my open door light functions correctly. I can't help but to think it was some secondary warning or something, but maybe it was just a malfunction.
 

·
Registered
Joined
·
1 Posts
Jonahan,

I had a very similar experience. My one week old 2013 Genesis Coupe had a temporary malfunction as well. The first symptom was the flashing seat belt warning and chime. Then I noticed that the "auto" setting in the head lights was not working. It was dark outside but the car lights were not coming on. When I switched to the head light on position on the light switch the lights came on. The lights indicator section of the instrument panel (including the door open indicator) was not working. Taking the seat belt on and off on both the passenger and driver side didn't make any difference. Turning the ignition key completely off and back on didn't help the situation either.

Needless to say I was quite bummed out about my brand new car developing malfunctions of this type. When I got home I realized that the trunk open switch didn't work either. At this time I was suspecting a blown fuse. However, after parking the car for about an hour I went back to check again and found that everything was back to normal! Its been two days and the issue has not re-surfaced again.

I'm not sure what to make of this. Maybe, there is a fuse that is not making good contact...

Senani

About an hour later
 

·
Registered
Joined
·
82 Posts
Mine did this today, and noticed the LED lights won't work while malfunction occurs? Obviously it's all intertwined because it all worked fine after letting it sit for 30sec and restarting. Headlights worked but parking and LEDs stopped during the issue. Hope that doesn't become a regular thing.
 

·
Registered
Joined
·
26 Posts
My 2013 Gen Coupe 3.8GT A/T, now 8000km and 4 months old, has the following problems in this order:
1. Gear shifting problems, tends to be stuck at high rev in low gear.
-> will get dealer to do the ECU update service campaign.

2. a week ago, R forward region of car started having creaking noises when road is slightly uneven, it got louder after going over a small pot-hole. Now the creaking noise is non-stop even on flat road. Suspension problem? or body panel loosened?
-> hopefully dealer can fix this.

3. Four days ago, immediately after changing into winter tires at a shop, trunk lid button stopped working for a minute or so. Worked again afterwards on its own.

4. An hour ago, auto headlight and LED daytime running light stopped working. Turning signals stop making the usual "clicking" sound (but the turning lights still work). Dash failed to dim (stuck at full brightness). Seatbelt alarm kept going off every minute or so. Fuse problem?

All this for a 4 month old car... hopefully all fixable by dealer in one go........

Jonahan,

I had a very similar experience. My one week old 2013 Genesis Coupe had a temporary malfunction as well. The first symptom was the flashing seat belt warning and chime. Then I noticed that the "auto" setting in the head lights was not working. It was dark outside but the car lights were not coming on. When I switched to the head light on position on the light switch the lights came on. The lights indicator section of the instrument panel (including the door open indicator) was not working. Taking the seat belt on and off on both the passenger and driver side didn't make any difference. Turning the ignition key completely off and back on didn't help the situation either.

Needless to say I was quite bummed out about my brand new car developing malfunctions of this type. When I got home I realized that the trunk open switch didn't work either. At this time I was suspecting a blown fuse. However, after parking the car for about an hour I went back to check again and found that everything was back to normal! Its been two days and the issue has not re-surfaced again.

I'm not sure what to make of this. Maybe, there is a fuse that is not making good contact...

Senani

About an hour later
 

·
Registered
Joined
·
432 Posts
do you think they smuggled little Koreans in your car, then at the right time they get out. They might be hiding behind the dash..
 

·
Registered
Joined
·
4,574 Posts
My 2013 Gen Coupe 3.8GT A/T, now 8000km and 4 months old, has the following problems in this order:
1. Gear shifting problems, tends to be stuck at high rev in low gear.
-> will get dealer to do the ECU update service campaign.

2. a week ago, R forward region of car started having creaking noises when road is slightly uneven, it got louder after going over a small pot-hole. Now the creaking noise is non-stop even on flat road. Suspension problem? or body panel loosened?
-> hopefully dealer can fix this.

3. Four days ago, immediately after changing into winter tires at a shop, trunk lid button stopped working for a minute or so. Worked again afterwards on its own.

4. An hour ago, auto headlight and LED daytime running light stopped working. Turning signals stop making the usual "clicking" sound (but the turning lights still work). Dash failed to dim (stuck at full brightness). Seatbelt alarm kept going off every minute or so. Fuse problem?

All this for a 4 month old car... hopefully all fixable by dealer in one go........
Is the creaking on the passenger side by a pillar or by rear seat, if so both are normal.
 

·
FS section ravager
Joined
·
2,183 Posts
Jonahan,

I had a very similar experience. My one week old 2013 Genesis Coupe had a temporary malfunction as well. The first symptom was the flashing seat belt warning and chime. Then I noticed that the "auto" setting in the head lights was not working. It was dark outside but the car lights were not coming on. When I switched to the head light on position on the light switch the lights came on. The lights indicator section of the instrument panel (including the door open indicator) was not working. Taking the seat belt on and off on both the passenger and driver side didn't make any difference. Turning the ignition key completely off and back on didn't help the situation either.

Needless to say I was quite bummed out about my brand new car developing malfunctions of this type. When I got home I realized that the trunk open switch didn't work either. At this time I was suspecting a blown fuse. However, after parking the car for about an hour I went back to check again and found that everything was back to normal! Its been two days and the issue has not re-surfaced again.

I'm not sure what to make of this. Maybe, there is a fuse that is not making good contact...

Senani

About an hour later
I had this issue as well. Hasn't resurfaced a week later.
 

·
Registered
Joined
·
26 Posts
Just a follow-up, problem #4 (seatbelt alarm, headlight problem, etc) was gone by the time I restarted the engine an hour later. Will still mention to dealer when I go in.

My 2013 Gen Coupe 3.8GT A/T, now 8000km and 4 months old, has the following problems in this order:
1. Gear shifting problems, tends to be stuck at high rev in low gear.
-> will get dealer to do the ECU update service campaign.

2. a week ago, R forward region of car started having creaking noises when road is slightly uneven, it got louder after going over a small pot-hole. Now the creaking noise is non-stop even on flat road. Suspension problem? or body panel loosened?
-> hopefully dealer can fix this.

3. Four days ago, immediately after changing into winter tires at a shop, trunk lid button stopped working for a minute or so. Worked again afterwards on its own.

4. An hour ago, auto headlight and LED daytime running light stopped working. Turning signals stop making the usual "clicking" sound (but the turning lights still work). Dash failed to dim (stuck at full brightness). Seatbelt alarm kept going off every minute or so. Fuse problem?

All this for a 4 month old car... hopefully all fixable by dealer in one go........
 

·
Registered
Joined
·
2,345 Posts
I caught this issue on video:

 

·
Registered
Joined
·
2,345 Posts
The lack of chiming when not moving with the key on is normal isn't it?
Correct. It only chimes when you start moving AND do not have seatbelt on. In my case, I had my seatbelt on.

I would guess it is probably the door switch or the door switch input on the BCM.
Switch is fine because the window still drops when door is open and shuts when door is closed. It is a logic problem in the BCM. Also the fact that the brake warning did not light up when I applied hand brake has nothing to do with door switch.
 

·
Registered
Joined
·
2,345 Posts
Have you tried reseating the BCM connector?
No i havent. It happens so seldom that i dont think that will help because the only solution seems to be by restarting the car and sometimes by needing to lock then unlock via remote. I never have to hit or wiggle any connectors to fix it.

I may try that for the heck of it. However it may be many months before this happens again.


Sent from my iPhone using AutoGuide.com App
 
1 - 20 of 91 Posts
Top