Hyundai Genesis Forum banner
1 - 4 of 4 Posts

· Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hey guys I've noticed my car sputters around 2500 RPMs to 3000 RPMs it only happens when I first turn on the car and drive but mostly when it's cold. I've called a couple mechanics and they said since it's not consistent and only happen when I'm first driving or cold so it's not my fuel pump I've already changed my spark plugs what can it be? It's 16 3.8 rspec!
 

· Registered
Joined
·
1,793 Posts
I haven't had this problem but I'd start by purchasing or borrowing a quality scan tool and check for any soft codes. If it only occurs when cold Id guess it's fuel related, I'd thoroughly clean the throttle body, change the fuel filter, and make sure the fuel isn't contaminated with water or anything else just to eliminate the simple stuff first.
You could also run some Techtron in the fuel to attempt to clean out the fuel injectors. These are all simple relatively inexpensive things to try first before getting in deeper.
 

· Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
I haven't had this problem but I'd start by purchasing or borrowing a quality scan tool and check for any soft codes. If it only occurs when cold Id guess it's fuel related, I'd thoroughly clean the throttle body, change the fuel filter, and make sure the fuel isn't contaminated with water or anything else just to eliminate the simple stuff first.
You could also run some Techtron in the fuel to attempt to clean out the fuel injectors. These are all simple relatively inexpensive things to try first before getting in deeper.

Thanks 🙏🏻 I'm going to try cleaning throttle body today and see, the only codes i have are p0420, p0430 and p0507, these codes have been on for about a year now. I've tried tech Tron once and issue kept on happening I guess i can try again, I've had this issue for about 2months now
 
1 - 4 of 4 Posts
Top