Hyundai Genesis Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
I recently installed a new head unit (Atoto F7) and after it was put in I was getting a hissing noise coming from my speakers(I assume from having 2 amplifiers now) my whole sound system sounded a lot better than the stock head unit and my subwoofer had a lot more bass. I put rca’s on the positive and negative wires for the front right, front left, rear right, and rear left as I just had them hooked up the the harness before. Installing the rca’s got rid of the hissing noise but now my system seems to have barely any bass and the subwoofer is only noticeable on certain songs. I’m looking to have my subwoofer sound the same as it did before the rcas were installed but I don’t want that hiss. Any help would be appreciated.

Thanks
 

·
I'd rather do it myself
Joined
·
19,439 Posts
So you have an amp feeding the stock amp?

Someone on here just hooked a separate amp to the stock sub and got quite and improvement out of it.

Do you have the center speaker?
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
The head unit comes with an amp inside of it I believe. If I’m correct with the head unit feeding the stock amp through the speaker wire on the harness from the car to the head unit it would give me 2 amplifiers. My car is a 2011 2.0t premium so I have the subwoofer and amp but I’m not sure if I have the center speaker.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #4 ·
So you have an amp feeding the stock amp?

Someone on here just hooked a separate amp to the stock sub and got quite and improvement out of it.

Do you have the center speaker?
Do you have a link or know how they hooked the amplifier to the stock sub?
 

·
I'd rather do it myself
Joined
·
19,439 Posts
They just used a dual channel hi/lo converter using the sub speaker wires as the input.
 
1 - 5 of 5 Posts
Top