Hyundai Genesis Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have a 4.6 A/T 2010 genesis premium that is completely dead. Car has 170k miles and I have had it since 35k miles. It has a new die hard battery, new spark plugs and oil was just done. The car has always had issues with no crank no start. Each time the battery has been switched out the car turned back on. This time none of the old ways of turning genny on are working. I’ve attached a photo of the codes my scanner picked up a month ago I replaced the evap purge valve in the engine thinking that would fix the problem, then a few days later car was dead. Lights and everything else in the car in working but it won’t turn over. No engine codes and the navigation in the vehicle won’t turn off either no matter how many times I press the push to start to turn everything off. Also the car would not start mostly after getting fuel. The only way to get gas was to fill up with leaving the car on. Any suggestions please? If it’s the starter or fuel pump why am I not receiving codes specific to a starter or fuel pump? Maybe I am missing something l, this car has been hell to own. Thank you for your help

btw just saw freeze frame dtc code was also p2187. Is my fuel pump done?
Font Screenshot Multimedia Software Darkness
 

·
Advenio Pariter
Joined
·
4,079 Posts
This is a Genesis Coupe forum. You might get some useful answers, but not by an owner of the car like you have. You should go post onto a Genesis forum that covers the sedan. You might get some better responses there. Thanks
 

·
Premium Member
Joined
·
16,577 Posts
I have a 4.6 A/T 2010 genesis premium that is completely dead. Car has 170k miles and I have had it since 35k miles. It has a new die hard battery, new spark plugs and oil was just done. The car has always had issues with no crank no start. Each time the battery has been switched out the car turned back on. This time none of the old ways of turning genny on are working. I’ve attached a photo of the codes my scanner picked up a month ago I replaced the evap purge valve in the engine thinking that would fix the problem, then a few days later car was dead. Lights and everything else in the car in working but it won’t turn over. No engine codes and the navigation in the vehicle won’t turn off either no matter how many times I press the push to start to turn everything off. Also the car would not start mostly after getting fuel. The only way to get gas was to fill up with leaving the car on. Any suggestions please? If it’s the starter or fuel pump why am I not receiving codes specific to a starter or fuel pump? Maybe I am missing something l, this car has been hell to own. Thank you for your help

btw just saw freeze frame dtc code was also p2187. Is my fuel pump done? View attachment 79263
Looks like an issue with the gas tank, specifically the gas tank vent system (solenoid) or something else in the same area.

I would first check if the gas cap is screwed on correctly. if it's not that, then research where the emissions solenoid is for your car.

If the solenoid is shot, it's likely because of overfilling the gas tank too often.

Remember kids, when filling up, when the handle clicks and stops pumping, DON'T fill it any more.
The carbon canister for the evap system absorbs it, breaks down and clogs the solenoid.
This is with any gasoline/diesel car.
 
1 - 3 of 3 Posts
Top