Hyundai Genesis Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter · #1 ·
I have the strangest symptoms on my Genesis. I originally thought the heater would not blow hot, but turns out the heater will only blow hot on hi, I lose coolant but no leaks inside or out, after driving a few minutes the passenger side of the windshield will get vapor smoke coming out from the hood/windshield. The motor oil looks fine and no white smoke from exhaust so it's not a head gasket. If I set the heater to 89 (the last digital numeric before hi) it starts blowing cold. wtf? I am running out of trouble shooting parts.
 

·
Registered
Joined
·
591 Posts
Heater core possibly leaking or blocked
 

·
I'd rather do it myself
Joined
·
19,453 Posts
Blowing cold because you are so low on coolant it isn't going through the heater core. If it's on the inside of the windshield that is definitely the heater core. Check first though that the hoses on the engine side of the heater core are not leaking.
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #4 · (Edited)
Heater core possibly leaking or blocked
We reverse flushed it today and the coolant came out so clean from the heater core it looked like it was coming out of a new bottle. So it's definitely not clogged, and the interior area of the heater core is bone dry so its not leaking inside either. Coolant level is fine but does drop after a local drive. We just keep refilling it. My next step is a pressure test.
 

·
Registered
Joined
·
591 Posts
Let us know how it turns out
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #6 ·
I have the strangest symptoms on my Genesis. I originally thought the heater would not blow hot, but turns out the heater will only blow hot on hi, I lose coolant but no leaks inside or out, after driving a few minutes the passenger side of the windshield will get vapor smoke coming out from the hood/windshield. The motor oil looks fine and no white smoke from exhaust so it's not a head gasket. If I set the heater to 89 (the last digital numeric before hi) it starts blowing cold. wtf?

Final Analysis and Solution:
Turns out the smoke and coolant odor was coming from a pin hole leak in the outlet hose (firewall side) that would only leak when the system was under full pressure. New factory hoses; no leaks
The heater/defroster only working on Hi is a faulty actuator which would require the removal of the dash to fix so we'll live with it for the life of the car.

**Another Issue not previously stated** was the air conditioner exit temperature was 66.0 degrees Fahrenheit when set at 63 with tested with outside temp of 95F.
A check of the freon level showed system was full but had some wiggle room for about 2-3 ounces of freon. I add about 3 ounces of refrigerant which dropped the vent exit temp to 54F on a 94F day.

I think she's ready for a new collage semester, hopefully problem free.
 

·
Registered
Joined
·
140 Posts
I have an 10 and have a bad actuator motor to. Ac only blows out sometimes. All the other times you hear it blowing behind the dash like the damper is shut.


Sent from my iPhone using Tapatalk
 

·
Premium Member
Joined
·
16,142 Posts
there should always be airflow out of somewhere. the HVAC system isn't designed to completely shut.

How long has it been since you changed the cabin filter?
 

·
Premium Member
Joined
·
16,142 Posts
Almost all cars since the 80s have had a cabin air filter.
should be change every 10k miles.

You should probably check the owner's manual for suggested maintenance schedules.
 
1 - 11 of 11 Posts
Top