Hyundai Genesis Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
2010 Genesis Couple Grand Touring

Looking for any input people might have on the following three issues.

Fog lights:
  • They don't work, and haven't for a while. The fog lights don't come on and the light on the dash doesn't come on either.
  • I have checked fuses and they seemed ok (didn't check continuity on them), I also checked the relay and it seemed ok (at least had same resistances as a different relay).

Driver's side door lock:
  • The key fob and the button to unlock on the handle do not unlock the driver's side door.
  • I have to use the manual key to open the driver's side door.
  • The key fob will unlock and lock the passengers side door which works just fine and as expected.
  • Seems like the problem is with the driver's side actuator (part 81315-2M000 I think), but I am not sure.

Navigation / Infotainment screen:
  • The screen on car startup will just be white / gray / "snowy" with no indications of buttons.
  • If it's fairly hot outside (greater than 90 deg F) it will work from the start, or it will start working after a few minutes, whereas it used to be down around 30/40 deg F as the threshold for working/not working.
  • This problem has continually gotten worse over the years and is definitely related to temperature (the colder it is outside the less likely it will work).
  • The radio / CD / mp3 / phone / etc all work from the steering wheel buttons just fine so I am still able to change stations or songs anytime I want just without visual feedback.
  • My gut says the infotainment unit (I think part 96560-2M100S4) has to be replaced but I was hoping there might be a cheaper / easier fix.


Thank you.
 

·
I'd rather do it myself
Joined
·
19,573 Posts
There is a joint connector in the engine fuse box between the fog lights and the relay, I would take it out and reseat it, spray some cleaner /lube in it. If that does not fix then take the relay out and jumper the pins 30 and 87. Numbers should be on the bottom of the relay. With the key on they should light up.

Door is probably the handle.

And try reseating and cleaning the connector on the info screen. I would look on eBay for a used one if that doesn't work.
Rectangle Azure Slope Schematic Font

Photograph White Black Motor vehicle Automotive exterior
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Thank you for taking the time to answer my questions.

Did some troubleshooting and found the following:

Fog lights: I jumpered like you suggested and the fog lights came on, at this point I figure the problem is either a faulty relay or the on/off switch off the steering column.

For the info screen: I was able to disassemble it and disconnected and reconnected all of the cables but it still had the same problem. I unfortunately figure replacement is the most likely resolution.

For the handle, what makes you think it is the handle? I figured the door latch / actuator were more likely. The driver side handle still opens the door if it is unlocked.
 

·
I'd rather do it myself
Joined
·
19,573 Posts
Others have had to have the handle replaced.


You could try and clean the switch by spraying it heavily with WD 40 and then working it many times. Note: the low beams need to be on.
 
1 - 4 of 4 Posts
Top